[regression] boot degraded question never posed

Bug #628400 reported by Dustin Kirkland  on 2010-09-01
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
initramfs-tools (Ubuntu)
High
Surbhi Palande
Maverick
High
Surbhi Palande
plymouth (Ubuntu)
High
Unassigned
Maverick
High
Unassigned

Bug Description

Binary package hint: mdadm

If you "sudo dpkg-reconfigure mdadm" and choose *not* to boot your RAID if it becomes degraded, you should get a prompt in initramfs if your RAID does become degraded.

I believe its plymouth or some such which is hiding this prompt from the user. Eventually, it times out and dumps you to an initramfs prompt.

This is a regression in Maverick from the behavior in Hardy - Lucid.

Dustin Kirkland  (kirkland) wrote :

Marking against mdadm and plymouth -- not sure where the regression is or where the fix belongs.

Milestoning this against GA, targeting at Maverick.

Changed in mdadm (Ubuntu):
importance: Undecided → High
Changed in plymouth (Ubuntu):
importance: Undecided → High
Changed in mdadm (Ubuntu):
milestone: none → ubuntu-10.10
Changed in plymouth (Ubuntu):
milestone: none → ubuntu-10.10
tags: added: regression-potential
tags: added: iso-testing
Thierry Carrez (ttx) wrote :

@Dustin: are you sure this is a regression from Lucid ?

Thierry Carrez (ttx) on 2010-09-02
tags: added: server-mrs
Thierry Carrez (ttx) on 2010-09-02
tags: added: server-mro
removed: server-mrs

Positive. I have tested this in Lucid frequently.

Actually, Mathiaz says that he tested this at Alpha3 and saw the
question posed. If that's the case, this is a regression since
Alpha3. That should be easier to bisect...

Colin Watson (cjwatson) wrote :

Unlikely to be plymouth given that plymouth has hardly changed since lucid.

Robbie Williamson (robbiew) wrote :

There has been only one change from lucid to maverick plymouth:
  plymouth (0.8.2-2ubuntu3) maverick; urgency=low
   * src/plugins/splash/ubuntu-text/plugin.c: Change Ubuntu version to 10.10
      (LP: #588633).
   -- Colin Watson <email address hidden> Fri, 25 Jun 2010 15:56:04 +0100

Changed in mdadm (Ubuntu Maverick):
assignee: nobody → Surbhi Palande (csurbhi)
status: New → Triaged
Changed in plymouth (Ubuntu Maverick):
status: New → Invalid
Surbhi Palande (csurbhi) wrote :

mdadm in maverick is a very old version, which was last updated in Dec 2010. So if it worked in Lucid, then on the surface of it, the regression seems unlikely to be in mdadm. Here is the last debian/chanagelog entry
------------
mdadm (2.6.7.1-1ubuntu15) lucid; urgency=low

  * Rename debian/mdadm.vol_id.udev to debian/mdadm.mdadm-blkid.udev so that
    the rules file ends up with a more reasonable name following changes in
    debhelper 7.4.2, and adjust the initramfs hook to match (LP: #493772).
  * Build-depend on debhelper 7.4.2.

 -- Colin Watson <email address hidden> Sat, 12 Dec 2009 14:36:53 +0000
------------

Steve Langasek (vorlon) wrote :

If anything, I think this is probably a bug in initramfs-tools, a new Debian version of which was merged into maverick for the first time in a long while. Note that plymouth still isn't included in the initramfs by default, so shouldn't be hiding anything; though it is possible that grub itself may be hiding it, I think it's at least as likely that the initramfs-tools hooks no longer work as expected.

So I would suggest testing by downgrading initramfs-tools and regenerating the initramfs to see if it's reproducible, and if it still is, then we're probably looking at an interaction between current grub2 behavior and initramfs-tools.

Surbhi Palande (csurbhi) wrote :

With FRAMEBUFFER=y in intramfs.conf, you can see the expected messages on a serial console but not on the VT. This bug seems to be caused by the "chvt 1" in initramfs/scritps/function::try_failure_hooks(). Replacing this with "plymouth hide-splash", gets the message on the VT.

Changed in mdadm (Ubuntu Maverick):
status: Triaged → In Progress
Surbhi Palande (csurbhi) wrote :

Attaching a tested patch. Do considering merging this for Maverick.

Colin Watson (cjwatson) wrote :

I think you need a '|| true' after this since it will return 1 if plymouthd isn't running. Also, plymouth isn't necessarily in the initramfs at all, so to avoid an error message I'd suggest guarding this with 'if command -v plymouth >/dev/null 2>&1'.

Steve Langasek (vorlon) on 2010-09-10
affects: mdadm (Ubuntu Maverick) → initramfs-tools (Ubuntu Maverick)
Surbhi Palande (csurbhi) wrote :

@Colin, Thanks! I have updated the patch with the suggestions. I hope this looks fine now.

Colin Watson (cjwatson) wrote :

It does indeed, thanks. Uploading.

Colin Watson (cjwatson) wrote :

initramfs-tools (0.98.1ubuntu2) maverick; urgency=low

  * scripts/functions: Adding plymouth hide-splash to see the initramfs prompt
    messages on VT. (LP: #628400)

 -- Surbhi Palande <email address hidden> Mon, 13 Sep 2010 10:24:22 +0100

Changed in initramfs-tools (Ubuntu Maverick):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers