fails to handle partitions over 9

Bug #539577 reported by Lieven on 2010-03-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
initramfs-tools (Debian)
Fix Released
Unknown
initramfs-tools (Ubuntu)
High
Colin Watson
Lucid
High
Colin Watson

Bug Description

Binary package hint: debian-installer

release: Lucid Alpha 3
image: kubuntu-alternate-i386

I just tried to install a command line system, but the kernel failed to install. I checked VT4, which said it failed because of missing packages, probably the kernel-headers. I'm fairly sure this didn't happen a few weeks ago, but now it does. I guess it must have something to do with the upcoming beta release, but still, this isn't a desired effect. I tried all the available kernels in the debian-installer, but they all failed to install.

I guess I will probably be advised to wait until beta, but maybe someone can give me an explanation why this is happening.

Thanks.

There are various possibilities, but I can only diagnose what's going on
if I can see the full logs. Could you please attach /var/log/syslog
from the installation environment to this bug? You can extract it by
going back to the main menu and selecting "Save debug logs".

 status incomplete

Changed in debian-installer (Ubuntu):
status: New → Incomplete
Lieven (lieven-debels) wrote :
Lieven (lieven-debels) wrote :
Lieven (lieven-debels) wrote :
Lieven (lieven-debels) wrote :
Lieven (lieven-debels) wrote :
Lieven (lieven-debels) wrote :

Thanks for your fast response. I've attached all the debug logs, and I also filled out most of the installation report.

Colin Watson (cjwatson) wrote :

This is actually an outstanding bug in initramfs-tools to do with handling of partitions with numbers over 9, which I'll try to get fixed for beta-2. Debian fixed it a while back but unfortunately it has been ages since we merged this particular package ...

affects: debian-installer (Ubuntu) → initramfs-tools (Ubuntu)
Changed in initramfs-tools (Ubuntu):
importance: Undecided → High
status: Incomplete → Triaged
Changed in initramfs-tools (Ubuntu Lucid):
assignee: nobody → Colin Watson (cjwatson)
summary: - kernel won't install because of missing package(s)
+ fails to handle partitions over 9
Changed in initramfs-tools (Ubuntu Lucid):
milestone: none → ubuntu-10.04-beta-2
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package initramfs-tools - 0.92bubuntu68

---------------
initramfs-tools (0.92bubuntu68) lucid; urgency=low

  * Backport from Debian:
    - hook-functions: Cope with partitions over 9 (LP: #539577).
 -- Colin Watson <email address hidden> Fri, 19 Mar 2010 18:57:43 +0000

Changed in initramfs-tools (Ubuntu Lucid):
status: Fix Committed → Fix Released
Changed in initramfs-tools (Debian):
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.