Fail to Upgrade to Lucid due initramfs-tools broken package

Bug #520004 reported by Nicolas Valcarcel on 2010-02-10
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
initramfs-tools (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: initramfs-tools

nxvl [~]
duffy$ sudo dpkg --configure -a
Setting up initramfs-tools (0.92bubuntu64) ...
update-initramfs: deferring update (trigger activated)

Processing triggers for initramfs-tools ...
update-initramfs: Generating /boot/initrd.img-2.6.31-20-generic
.: 4: Can't open /scripts/functions
.: 4: Can't open /scripts/functions
cpio: ./lib/udev/firmware.sh: Cannot stat: No such file or directory
update-initramfs: failed for /boot/initrd.img-2.6.31-20-generic
dpkg: subprocess installed post-installation script returned error exit status 1

Nicolas Valcarcel (nvalcarcel) wrote :

Just tracked down the issue until mkinitramfs. It's crashing in "/tmp/mkinitramfs_$CODE/scripts/local-top/cryptroot prereqs", the script starts with a line saying: ". /scripts/functions" (shell script) which isn't there, the comment on that line makes reference to Bug #272301

StoatWblr (stoatwblr) wrote :

Please reread report, This is NOT a duplicate of 519855

NOT a duplicate.

dino99 (9d9) wrote :

sudo dpkg --configure -a does not help (says that dpkg has not ended the latest job)

dino99 (9d9) wrote :

found the reason and the solution on my end:

- first i've installed kernel 2.6.33-020633-generic for testing: unfortunatly dkms failed and update-manager removed all nvidia drivers (might say only desactivate), so i uninstalled this kernel and install "nouveau"

- one reboot later, when i've checked for upgrading packages, an initramfs-tools error appear complaining about that missing initrd.img of 2.6.33 kernel. running dpkg --configure -a did not resolve the problem.
Have to erase it : rm -f /var/lib/initramfs-tools/2.6.33-020633-generic

- run again dpkg --configure -a and that problem is gone.

-update & upgrade work fine again.

dino99 (9d9) wrote :

some jockey error

maximilian attems (maks-debian) wrote :

The initramfs-tools upgrade bug should be fixed in recent initramfs-tools > 0.92, so starting from maverick, marking as such.

Changed in initramfs-tools (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments