initramfs-tools package seems to fail postinstall on armel

Bug #422101 reported by Paul Larson on 2009-08-31
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubiquity
Fix Released
Undecided
Oliver Grawert
initramfs-tools (Ubuntu)
High
Oliver Grawert
Karmic
High
Oliver Grawert

Bug Description

During the ubiquity install from imx51 image, I got an error saying that "The following packages are in a broken state", but there was no list after that. After rebooting, I ran dpkg -C and it said that initramfs-tools was only half configured.

initramfs-tools version is: 0.92bubuntu41

I ran dpkg --configure on it manually after reboot and it appeared to work correctly.

Related branches

Paul Larson (pwlars) on 2009-08-31
affects: ubuntu → initramfs-tools (Ubuntu)
tags: added: armel
Colin Watson (cjwatson) wrote :

Can we have the installer logs, please? /var/log/installer/syslog

If that log is missing, then the installation was incomplete. In order to get more information, you'll need to repeat the installation and attach /var/log/syslog to this bug before rebooting.

Changed in initramfs-tools (Ubuntu):
status: New → Incomplete
Paul Larson (pwlars) wrote :

/var/log/syslog was the only one I had - attached

Changed in initramfs-tools (Ubuntu):
status: Incomplete → New
Oliver Grawert (ogra) wrote :

i see the same on my test install and end up with a similar empty syslog

Changed in initramfs-tools (Ubuntu):
status: New → Confirmed
Oliver Grawert (ogra) wrote :
Steve Langasek (vorlon) wrote :

Choice portion of the log:

Sep 3 09:49:02 ubuntu ubiquity: update-initramfs: Generating /boot/initrd.img-2.6.31-100-imx51
Sep 3 09:50:14 ubuntu ubiquity: /dev/mmcblk0 is not a block device
Sep 3 09:50:14 ubuntu ubiquity: dpkg: Unterprozess installiertes post-installation-Skript gab den Fehlerwert 1 zurück
Sep 3 09:50:15 ubuntu python: E:Sub-process /usr/bin/dpkg returned an error code (2)

Changed in initramfs-tools (Ubuntu):
importance: Undecided → High
Oliver Grawert (ogra) wrote :

well, the prob here is that update-initramfs is running in the actual live system through a trigger (caused by removing dmraid) instead of being run in-target where it should be (which actually happened some lines before already) ...

i see that casper adds a diversion for update-initramfs on boot, that should probably be kept in place longer (or even not be removed at all)

That doesn't make sense - packages are removed from the target and so
the trigger would take place there too.

Oliver Grawert (ogra) on 2009-09-04
Changed in initramfs-tools (Ubuntu Karmic):
assignee: nobody → Oliver Grawert (ogra)
milestone: none → karmic-alpha-6
Oliver Grawert (ogra) on 2009-09-14
Changed in initramfs-tools (Ubuntu Karmic):
status: Confirmed → Invalid
Changed in ubiquity:
assignee: nobody → Oliver Grawert (ogra)
Oliver Grawert (ogra) on 2009-09-14
Changed in ubiquity:
status: New → Fix Committed
Loïc Minier (lool) wrote :

Dropping milestone since bug is invalid

Changed in initramfs-tools (Ubuntu Karmic):
milestone: karmic-alpha-6 → none
Oliver Grawert (ogra) on 2009-10-16
Changed in ubiquity:
status: Fix Committed → Fix Released
tags: added: iso-testing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers