[ia64] update-initramfs fails to run elilo after updating an initramfs

Bug #396000 reported by Michael Casadevall on 2009-07-06
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
initramfs-tools (Ubuntu)
Critical
Unassigned
Nominated for Karmic by r12056
Nominated for Lucid by r12056

Bug Description

On Ubuntu karmic (but likely true of older versions), update-initramfs fails to call elilo to update the EFI partition and properly install the new initramfs, which can cause issues such as failure to boot when packages like udev are updated. The kernel properly calls elilo, so this is just an issue when the initramfs is updated separately from the kernel packages.

(I can't file a bug with ubuntu-bug on this due to apport currently segfaulting on ia64, but I can test any patches or provide any info by hand)

Steps to Reproduce:
1. On ubuntu-karmic, install any package that will update the initramfs without updating the kernel

Excepted Behavior:
The initramfs on the EFI boot partition is properly updated

Current Behavior:
The initramfs isn't udpated at all

Justification for Critical priority:
A mismatched kernel/initramfs/userland can leave the system in a non-bootable state on ia64, which is what happened to me (udev wasn't properly updated on the initramfs forcing me to boot the old kernel, and force-updating everything then calling elilo)

Changed in initramfs-tools (Ubuntu):
importance: Undecided → Critical
description: updated
tags: added: ia64
Changed in initramfs-tools (Ubuntu):
status: New → In Progress
Launchpad Janitor (janitor) wrote :
Download full text (23.6 KiB)

This bug was fixed in the package initramfs-tools - 0.96.1ubuntu1

---------------
initramfs-tools (0.96.1ubuntu1) maverick; urgency=low

  * Resynchronise with Debian:
    - Fixes redboot partition handling (LP: #319730).
    - Don't hardcode incorrect elilo path (LP: #396000).
    Remaining changes:
    - Use busybox-initramfs for Depends, and set BUSYBOXDIR to match.
    - Mount /dev with the default tmpfs size rather than sourcing udev.conf.
    - Set takeover=1 in update-initramfs.
    - Allow the mounting of a root filesystem as a loop device on top of a
      host filesystem, used for Wubi installs.
    - Add vfat support to the initramfs.
    - Reduce timeout to 30 seconds; corner cases (giant disk arrays,
      clusters) will need to provide their own rootdelay= boot arg.
    - Add 2>&1 to the run-init line.
    - Add mountroot failure support, to allow meaningful messages when no
      root device can be found.
    - Panic if either the root device doesn't exist, or blkid cannot
      identify it. Allows for mountroot failure hooks for md devices to be
      displayed.
    - Ignore blacklist for forced vga= usage.
    - Loop for 5 seconds waiting for $suspend to show up, adjustable with
      the resumedelay= command-line arg.
    - Allow for alternative PREREQS to be specified using | as the
      separator.
    - Support loading compcache from the initramfs.
    - Remove klibc utilities if busybox is in use.
    - Change to tty1 on failure.
    - Revert "framebuffer: Let udev create fb devices." udev isn't started
      at this point and therefore can't create framebuffer devices.
    - Create /dev/mem and /dev/zero if video=uvesafb.
    - Make debug option write debug output to
      /dev/.initramfs/initramfs.debug rather than /tmp/initramfs.debug, so
      that it can be retrieved after boot.
    - Add hid_* modules, since some keyboards will not be usable at the
      initramfs/busybox prompt without them.
    - Replace all instances of vol_id with blkid, and depend on util-linux.
    - Use gzip from busybox instead of klibc. Depend on busybox-initramfs
      (>= 1:1.13.3-1ubuntu5) to ensure that we have it.
    - Remove bnx2 from the initramfs; it needs firmware, and at this stage
      we only support network modules that don't need firmware loading.
    - update-initramfs: check whether kernel-img.conf exists and
      postinst_hook is set before calling flash-kernel.
    - Don't display "Loading, please wait..." message when 'quiet' is in
      /proc/cmdline.
    - Allow scripts and hooks to specify OPTION=VAR, and unless VAR is set
      to something other than "n", the script will not be included.
    - Restore the framebuffer hook and script, copying KMS and other
      framebuffer drivers into the initramfs, but make them optional; you
      need to set FRAMEBUFFER=y for these to be included.
    - Silence /bin/resume output when trying to resume.
    - Depend on a sufficient version of udev to load fbcon.
    - Conflict with older versions of usplash.
    - Don't load keymaps unless we're loading a framebuffer; but set the
      keymap before giving a root shell.
    - Add new initramfs-tools-bin package containing ...

Changed in initramfs-tools (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers