Dapper install fails after reboot: could not mount root fs

Bug #35657 reported by Adam Wiggins on 2006-03-19
12
Affects Status Importance Assigned to Milestone
initramfs-tools (Ubuntu)
High
Unassigned

Bug Description

Installed from flight5 AMD64 install CD. Installation appeared to go completely normally; I used custom partitioning to tell it to use my existing / (sda1), swap (sda2), and /home (sda3) so that I could format / but leave /home untouched. (Breezy was the previous install.)

After rebooting, I got the message:

mount: Mounting /dev/sda1 on /root failed: No such device

...plus some more cascading errors, you can see them all in the photo I took of the screen:

http://dusk.org/adam/tmp/dappermountfailed.jpg

It should be noted that I have a four disk IDE RAID using a 3ware hardware raid controller. However, the driver for this device has worked perfectly in every distro I've ever used it with, and obviously the installer had no problem detecting and using it.

I tried booting from the rescue CD, and it mounted /dev/sda1 with no problem at all. /root was empty but I assume that was the purpose. I poked around the filesystem and everything appears to be complete in order. It just won't boot itself.

Adam Wiggins (hiro) wrote :

After more tinkering, it turns out it was the driver. The initrd was not getting created with the 3w_9xxx driver. Steps to fix:

- Boot the CD in rescue mode, select "shell in installer environment"
- From the prompt, enter:

mount -o bind /target/dev /dev
chroot /target /bin/bash
cd /etc/mkinitrd
echo 3w_9xxx >> modules
dpkg-reconfigure linux-image-`uname -r`
exit
exit

- Select "reboot the system" and remove CD from tray

On my system, there was no /etc/mkinitd/modules file at all. Kinda seems like the installer forgot / failed to create it?

Let me know if I can provide any more information from the install logs or anything. I'd call this pretty critical if anyone using a hardware RAID controller is going to end up with an unbootable system after install.

Adam Conrad (adconrad) wrote :

The 3w-9xxx module is certainly supposed to be copied to the default initramfs (and seems to be for most users). Would it be possible to attempt another Flight-5 install and see if maybe it was a moon phase thing, or something else?

If that one fails as well, I'd love a copy of the non-booting initrd from /boot before you regenerate a working one.

Matt Zimmerman (mdz) on 2006-04-07
Changed in initramfs-tools:
status: Unconfirmed → Needs Info
Matt Zimmerman (mdz) wrote :

This bug is waiting for an additional test for confirmation; please respond

Craig Box (craig.box) wrote :

See also Bug #40075, which is a different card, but the same error.

Unfortunately I don't have an initrd from the machine, and it's in production, so I can't really reinstall it. Perhaps the other commenter could?

Adam Wiggins (hiro) wrote :

I just tried a reinstall with the latest release candidate (6.06-rc) on the same system and it installed without a hitch. As far as I am concerned you can close this bug.

Rocco Stanzione (trappist) wrote :

Closing per request.

Changed in initramfs-tools:
status: Needs Info → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers