Eliminate calls to modprobe

Bug #338806 reported by Scott James Remnant (Canonical) on 2009-03-06
8
Affects Status Importance Assigned to Milestone
initramfs-tools (Ubuntu)
High
Scott James Remnant (Canonical)

Bug Description

Binary package hint: initramfs-tools

initramfs-tools and other scripts using the initramfs to call modprobe, or using force_load_module, etc. will be audited. Any modules capable of auto-loading will have their calls eliminated since they are a performance drag, any modules not capable of auto-loading may just be built into the kernel on the basis that it's pretty hard to stop them loading if they're loaded here.

Additional tasks will be opened for this bug on other packages found.

Changed in initramfs-tools:
assignee: nobody → scott
Steve Langasek (vorlon) wrote :

FFe approved, as per previous discussion.

Changed in initramfs-tools:
importance: Undecided → High
status: New → Confirmed

All of the changes I've intended to make have been made - and the cost of modprobe is now near-zero anyway

Changed in initramfs-tools (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers