Dapper does not boot after last update

Bug #32446 reported by Björn Röder on 2006-02-22
22
Affects Status Importance Assigned to Milestone
initramfs-tools (Ubuntu)
High
Unassigned

Bug Description

OK, you have to help me with this finding out what problem exactly that is:

After last dapper update it just does not boot/startup anymore. Though after grub screen dapper tells me it does read/unpack the image file correctly it then immediately stops with a variety of errors. Error messages scroll down way too fast so I cannot even read them to post them. Basically all errors have to do with dapper not being able to read /dev and /scripts.

Because of this it is not able to access /dev/hda3 where my root (/ ) is located at whereas /boot is located at /dev/hda1. Boot flag is set to hda1 correctly and grub's menu.lst also looks fine.

There is no errors with my harddrives since I can access them via a live cd and chroot into that environment.

OK, if this sounds a little confused it is because I AM confused.

EDIT: Is there a way to slow down/pause the error messages I get booting?

foxy123 (foxy) wrote :

just like to confirm it. I use i686 kernel which doe not boot after the update, while old 2.6.15-15-686 boots ok.

Björn Röder (overgee) wrote :

Just to add additional information: I use the same kernel (i686). 2.6.15-15-686 used to work fine just before last update. Now the same error appears as described trying to boot with the old kernel still installed.

Björn Röder (overgee) on 2006-02-22
description: updated
Björn Röder (overgee) wrote :

I finally got it to boot using kernel 2.6.15-16-386 (recovery mode).
Still the following errors appear during startup routine:

* at "Loading hardware drivers" [fail] saying "hw_random: RNG not detected"
* "Starting PCMCIA server" [fail]
* hangs up at "Setting up LVM Volume Group" saying "udevd-event[3461]: wait_for_sysfs: waiting for "/sys/devices/platform/i82365.0/bus failed" -> I then hit [ctrl]+[c]
* gets stuck again at "Starting Enterprise Volume Management System" -> I then have to reboot / sometimes I'm lucky and dapper passes this stage without an error.

Michael Heča (orgoj) wrote :

I have same problem after upgrade. With kernel 2.6.15-15 and 2.6.15-16 don't detect hda on boot and can't mount root filesystem. System have amd64 CPU and use x86 binnaries. Other system with Pentium Celeron boot fine with 2.6.15-16 and splash image working now (previous kernel have not usplash image).

Not sure, but my problem seems to be related/similar:
Cannot boot with the newest kernel update neither. After choosing the kernel in grub I get imeditely the follwing error message:
[4294667.898000]pnp: PnPACPI:METHOD_NAME__CRS failure for PNP0c02
[4294667.898000]pnp: PnPACPI:METHOD_NAME__CRS failure for PNP0200
[4294667.898000]pnp: PnPACPI:METHOD_NAME__CRS failure for INT0800
[4294667.898000]pnp: PnPACPI:METHOD_NAME__CRS failure for PNP0103
...
[4294668.632000]crc error
[4294668.633000]Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block (0,0)

The problem appears both with 2.6.15.15-386 and 2.6.15.15-686 kernels - strangely sometimes I can boot - sometimes I cannot (Today I didn't manage - and honestly before yesterday everything works fine so in my case it is perhaps related to some updates)

When I boot with the old 2.6.15-15 kernel everything works fine.

Michael Heča (orgoj) wrote :

On amd64 with amd64 distribution and 2.16.17 kernel is the same problem after upgrading from Breezy.

Problem is fixed after running: update-initramfs -u. On automaticaly installed kernel is no modules for nvidia sata ide.

Dutch (straykat) wrote :

Did an update on a fresh install:
(Kubuntu Dapper 6.04 Flight 5 AMD64) 22 March 06.
Reboot hung up at "waiting for root file system..."
Did another install & update 23 March 06 with same result?

Dutch (straykat) wrote :

Further to last post:
Did another fresh install & update wth the addition of orgoj post 2006-03-05. This worked. Then opened up universe & multi-universe & did another update.
Reboot stalled on "Loading restricted drives...fail"?

LeitoMonk (monk) wrote :

This is mi lspci
0000:00:00.0 Host bridge: nVidia Corporation nForce2 AGP (different version?) (rev a2)
0000:00:00.1 RAM memory: nVidia Corporation nForce2 Memory Controller 1 (rev a2)0000:00:00.2 RAM memory: nVidia Corporation nForce2 Memory Controller 4 (rev a2)0000:00:00.3 RAM memory: nVidia Corporation nForce2 Memory Controller 3 (rev a2)0000:00:00.4 RAM memory: nVidia Corporation nForce2 Memory Controller 2 (rev a2)0000:00:00.5 RAM memory: nVidia Corporation nForce2 Memory Controller 5 (rev a2)0000:00:01.0 ISA bridge: nVidia Corporation nForce2 ISA Bridge (rev a4)
0000:00:01.1 SMBus: nVidia Corporation nForce2 SMBus (MCP) (rev a2)
0000:00:02.0 USB Controller: nVidia Corporation nForce2 USB Controller (rev a4)
0000:00:02.1 USB Controller: nVidia Corporation nForce2 USB Controller (rev a4)
0000:00:02.2 USB Controller: nVidia Corporation nForce2 USB Controller (rev a4)
0000:00:04.0 Ethernet controller: nVidia Corporation nForce2 Ethernet Controller (rev a1)
0000:00:06.0 Multimedia audio controller: nVidia Corporation nForce2 AC97 Audio Controler (MCP) (rev a1)
0000:00:08.0 PCI bridge: nVidia Corporation nForce2 External PCI Bridge (rev a3)0000:00:09.0 IDE interface: nVidia Corporation nForce2 IDE (rev a2)
0000:00:1e.0 PCI bridge: nVidia Corporation nForce2 AGP (rev a2)
0000:01:08.0 FireWire (IEEE 1394): Agere Systems FW323 (rev 61)
0000:02:00.0 VGA compatible controller: nVidia Corporation NV18 [GeForce4 MX - nForce GPU] (rev a3)

When i use the kernel 2.6.15-19-386, the mzchine don't boot. Say "waiting for root file system..."

what's wrong?

Sounds like a broken initramfs problem to me.

Changed in udev:
assignee: keybuk → nobody
Matt Bretl (mpbretl) wrote :

I can confirm this as well. I haven't been able to boot the Flight 4/5/6 LiveCDs. One trend I'm noticing is that these problems seem to be on nForce boards... coincidence?

https://launchpad.net/distros/ubuntu/+bug/36667

Martin Pool (mbp) wrote :

I also have this, on an old K6 machine; 2.6.15-20-686 hangs at "waiting for root filesystem", apparently without detecting any ide drives.

Breezy's 2.6.12-10 worked; I'm not yet sure about anything in between.

Martin Pool (mbp) wrote :

I booted with an old kernel into the same installation. I noticed that pdc202xx_new couldn't detect my old Promise ide controller to which some non-boot disks are attached, so I removed that, modprobed pdc202xx_old, and added that module to /etc/modules.

I regenerated the initramfs with

  update-initramfs -k 2.6.15-20-668 -u

and now it boots OK.

How did it get a bad version in the first place? I installed the kernel image as part of a dist-upgrade with no visible problems.

Matt Zimmerman (mdz) on 2006-04-17
Changed in initramfs-tools:
assignee: nobody → adconrad
Matt Zimmerman (mdz) wrote :

Adam, is this expected to be fixed by your changes in 0.40ubuntu29?

joe_f (jferrare) wrote :

I'd like to confirm with another nForce board. Installed the AMD64 Dapper beta the day it was announced on Distrowatch. No upgrade or additions to the system after install. Booted into it today (23 April), saw the update notification, upgraded by taking whatever it offered. It went without incident or error (that I noticed). Upon reboot I got the following errors (going mostly by memory):
-- ramdisk couldn't find initial ramdisk
--VFS cannot open 802 partition
--Please append proper boot= option
--Kernel panic, not syncing

Machine is a nForce4 board (DFI Lanparty) with an Operton 175. I'm dual-booting with Zenwalk using lilo. I accessed the partition from Zenwalk and confirmed that the kernel, initrd and their symlinks were still there and correctly linked. Didn't know what else to try. Can I chroot into it and update?

Adam Conrad (adconrad) wrote :

joe_f: can you first save a copy of the broken initrd for me, and attach it to this bug report for me too look at?

Then you can easily chroot it and "update-initramfs -u -k 2.6.15-21-amd64-k8" (or whatever version you have installed), and you should be okay. I hope. If not, I'd like a copy of the newly-broken initrd too. :/

joe_f (jferrare) wrote :

Sadly, no I can't. I've got a new hard drive in the mail and am trying out a few distros to see if I want to switch. I installed Suse 10.1 over that Ubuntu install. However, I reinstalled Ubuntu and updated just to get you that initrd. Fortunately or unfortunately, the update went without incident and I'm typing this from a freshly updated Dapper with no booting problems. Apparently, somebody fixed the problem.

I tried chroot, by the way, but it gave me an error about the /bin/bash exec being wrong. Maybe it's a 32-bit, 64-bit problem, as I was chrooting in from a 32-bit Zenwalk install. The only chrooting I've done in the past is during Gentoo installs, so I'm far from an expert. Anyway, happy to have Ubuntu back on the drive. Suse was nice, but I've pretty much settled on dual-booting Slackware for 32-bit and Ubuntu for 64-bit. Nice work.

Sorry, I didn't think to save a copy. If it happens again I will.

--
Martin

Matt Zimmerman (mdz) wrote :

This bug report has a lot of irrelevant information, but the original report sounds like a corrupt initramfs, possibly due to bug #31126. Björn Röder, can you comment?

Zer0 (laudens) wrote :

Writing from Italy

Hellò I updated Dapper (Ubuntu 6.0.4) but when I reboot my pc it shows me only the login windows. So I have to click on Options and shutdown. 2ND thing: After that update it doesn't shows me anymore the Mount Drive icon (only 1 of DVD) I mounted there 4 days ago.
Why all these? I tried to many fixings but it still the same. I think is a bug...
in an update? I use AMD 1700+ but kernel is exact for that cpu. Do you have an answer for me?
Regards: Gogo

Lixin Chin (wstfgl) wrote :

Just to confirm this bug:
2.6.15-23-686
on an Intel Centrino (Samsung X50 laptop, Intel ICH6 sata controller)

Breezy's 2.6.12 kernel worked fine, but Dapper's kernel always hangs at boot at the "waiting for root filesystem" bit.

Even worse, installing the Dapper kernel seems to corrupt the system so that the Breezy kernel no longer boots (Seg faults at boot).

Ronny Bangsund (ronnyb) wrote :

I can confirm this bug on a P4 w/VIA
chipset, kernel 2.6.15-23-686.

Breezy's 2.6.12 kernel survived the
ordeal, but I had to reinstall Breezy
to get a usable system.

Thiago Addevico (tapresa) wrote :

Got the same bug here, on a Asus K8N4-E with sata hard disk, when updated. I don't know if anybody else tried it, but I also tried to install from live cd, and the partition tool didn't show the disk info. Is there any helpful intersection?

Guillermo Molleda (gmolleda) wrote :

I have a new laptop all intel (barebone Centrino DUO T2300, pro wireless 3945, graphics card, SATA module is "ata_piix" I think is ICH7 type...). The Ubuntu Dapper 6.06 go well in CD-Live mode, but can't mount sata partitions.

I have could install: in the process, if I remove and create partitions, the system is installed. But if restart, the error can't mount root filesystem is forever.

All old CD-live (Debian sarge, Ubuntu Breezy, knoppix, Fedora core 5, ...) go well with SATA, but the only detect my wireless and my graphics card is Dapper.

I can mount the partition with Dapper if I run other CD-Live Linux. It is goot for try change something to will do run.

I need do it go.

Thanks you.

Michael Erskine (msemtd) wrote :

I have a similar problem following a routine kernel upgrade - older kernels will not boot either - reported Bug #52937 and am currently trying suggestions from http://forums.debian.net/viewtopic.php?t=7295

BTW: Bug #32123 looks simillar

ntrcessor (ntrcessor) wrote :

I had the same issue for awhile, (2.6.15-2[67]-386 then I noticed that my boot partition was full! I removed some of the older items...the apt-get upgrade didn't report any errors the first few times. But the last time I ran it it did. I am still waiting for the upgrade to finish so don't know if it boots yet.

(I also had -23 and -25 on there. I cut back to just -23 since that was the only bootable image.) apt-get upgrade just installed -26 again. If 26 works at reboot, then i will remove -23 and see if I can upgrade to -27.

Strange as upgrades used to ask if I wanted to keep the old kernel, in a boot up script if we succeeded in booting completely. Maybe that was a script I had written,that somehow got replaced w/ another w/ same name.

Adam Conrad (adconrad) on 2008-01-23
Changed in initramfs-tools:
assignee: adconrad → nobody
C. Cooke (ccooke) wrote :

 Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue for you. Can you try with the latest Ubuntu release? Thanks in advance.

Martin Pool (mbp) wrote :

I think it's obsolete. Recent versions boot fine with me.

C. Cooke (ccooke) wrote :

Okay, great - I'm marking this as Fixed.

Thanks again.

Changed in initramfs-tools:
status: Confirmed → Fix Committed
Przemek K. (azrael) on 2009-12-07
Changed in initramfs-tools (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers