'Do you wish to start the degraded RAID' not visible

Bug #268873 reported by Michael Kofler
6
Affects Status Importance Assigned to Milestone
initramfs-tools (Ubuntu)
Medium
Dustin Kirkland 

Bug Description

installed intrepid alpha 5 (using vmware) for a RAID1 + LVM scenario

removed disk0, tried to boot, and fell back into busybox

the problem: for a normal alternate installation (not from the server CD), splash is activated by default; therefore, the question 'Do you wish to start the degraded RAID' times out because it is invisible in the graphical boot animation; the text modus is only activated after the timeout; you can avoid this by booting in recovery mode or by removing the splash option in the GRUB kernel line

apart from this minor glitch, everything works fine now as described in

https://bugs.launchpad.net/ubuntu/+source/mdadm/+bug/120375/comments/105

---

PS: I really believe bootdegraded=1 should be the default setting (remote servers, root servers at a remote ISP etc.)

also: for a server installation I prefer LTS, and it looks like I have to wait for 10.04 to get these fixes included by default; please re-consider providing updates and including them in 8.04.2

Revision history for this message
Dustin Kirkland  (kirkland) wrote :

To your PS, see bug #268580. There will be a question in the installer asking a user who as set up the root filesystem on a RAID to make a conscious decision as to whether BOOT_DEGRADED=true|false.

As for splash, good catch. I haven't tested with splash. I think there's something we can do here... Let me work up another patch.

:-Dustin

Revision history for this message
Dustin Kirkland  (kirkland) wrote :

Patch attached, tested, works for me. Requesting sponsorship.

:-Dustin

Changed in initramfs-tools:
assignee: nobody → kirkland
importance: Undecided → Medium
status: New → Confirmed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package initramfs-tools - 0.92bubuntu12

---------------
initramfs-tools (0.92bubuntu12) intrepid; urgency=low

  * scripts/functions: must chvt(1) during failure hooks, as console input
    might be required (eg, boot degraded raid) (LP: #268873).

 -- Dustin Kirkland <email address hidden> Thu, 11 Sep 2008 16:49:17 -0400

Changed in initramfs-tools:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers