The installer fails in creating a valid initramfs for a LSI/Megaraid RAID controller

Bug #23559 reported by Francesco Paolo Lovergine on 2005-10-09
10
Affects Status Importance Assigned to Milestone
initramfs-tools (Ubuntu)
High
Adam Conrad

Bug Description

0000:02:0e.0 RAID bus controller: LSI Logic / Symbios Logic MegaRAID (rev 07)
        Subsystem: Unknown device 1734:1065

This controller used on Fujitsu-Siemens RX300 and possibly other servers is
quite peculiar. On the basis of my analysis, it works using two different kernel
modules in 2.6.12, due to the configuration choosen by the admin. In RAID5 it
works with megaraid_mbox, in RAID1 it works by means of mptscsih. In both cases
d-installer recognizes the controller and completes the installation, but fails
in creating a initramfs useful for reboot when the system disk is in RAID1 mode:
it adds only megaraid_mbox, so booting fails due to lack of the other module
(mptscsih). But for that, the installer works like a charm...

Tessa (unit3) wrote :

Note that also, for those of us with Dell PERC2 controllers, *none* of the
drivers in 2.6.12 seem to work, and so it fails to boot no matter what.

Adam Conrad (adconrad) wrote :

All the megaraid drivers have been included for a while now in dapper, closing this bug...

Changed in initramfs-tools:
status: Unconfirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.