resume after hibernation fails because resume script is never executed

Bug #1829726 reported by Bas Zoetekouw on 2019-05-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
initramfs-tools (Ubuntu)
Undecided
Unassigned

Bug Description

In recent versions of initramfs-tools-core, the hibernation resume script (/usr/share/initramfs-tools/scripts/local-premount/resume) is no longer +x, so it's silently skipped during boot, causing resume after hibernation to fail.

I'm not sure when this change was introduced. All I can see is that it worked fine on 18.04, but that it's broken in current 19.10-dev.

╰─▶ ls -la /usr/share/initramfs-tools/scripts/local-premount/resume
-rw-r--r-- 1 root root 1,5K apr 29 09:24 /usr/share/initramfs-tools/scripts/local-premount/resume

Unpacking the initramfs confirms this:

╰─▶ unmkinitramfs /boot/initrd.img-5.0.0-13-generic initramfs

╰─▶ ls -la initramfs/main/scripts/local-premount/
total 32K
drwxr-xr-x 2 bas bas 4,0K mei 20 10:49 ./
drwxr-xr-x 10 bas bas 4,0K mei 20 10:49 ../
-rw-r--r-- 1 bas bas 246 mei 20 10:29 ORDER
-rwxr-xr-x 1 bas bas 270 mrt 12 04:53 btrfs*
-rwxr-xr-x 1 bas bas 4,1K apr 29 09:24 fixrtc*
-rwxr-xr-x 1 bas bas 226 mei 3 07:49 ntfs_3g*
-rw-r--r-- 1 bas bas 1,5K apr 29 09:24 resume

╰─▶ cat initramfs/main/scripts/local-premount/ORDER
/scripts/local-premount/btrfs "$@"
[ -e /conf/param.conf ] && . /conf/param.conf
/scripts/local-premount/fixrtc "$@"
[ -e /conf/param.conf ] && . /conf/param.conf
/scripts/local-premount/ntfs_3g "$@"
[ -e /conf/param.conf ] && . /conf/param.conf

summary: - resume afte hibernation fails because resume script is never executed
+ resume after hibernation fails because resume script is never executed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers