intramfs-tools 0.130ubuntu3.3 in bionic-security breaks netplan.io in -security or in release

Bug #1811210 reported by Balint Reczey on 2019-01-10
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
initramfs-tools (Ubuntu)
Undecided
Unassigned
Bionic
High
Unassigned

Bug Description

Adding Breaks: netplan.io (<< 0.36.2) made initramfs-tools uninstallable by default unattended-upgrades configuration because netplan.io >= 0.36.2 is not available from bionic or bionic-security (only in bionic-updates).

This is originally reported as https://github.com/mvo5/unattended-upgrades/issues/165 .

U-u's email reporting behaviour is a valid different question, but IMO when such Break is added in -security a non-breaking version of the other package should be added to -security, too, like when we add new dependencies.

Please provide a netplan.io version in -security that allows upgrade of initramfs-tools either by uploading 0.36.2 or just cherry-picking the needed fixes and relaxing the Breaks: in initramfs-tools.

Balint Reczey (rbalint) on 2019-01-10
Changed in initramfs-tools (Ubuntu Bionic):
importance: Undecided → High
Marc Deslauriers (mdeslaur) wrote :

A rebuild of netplan.io into the security pocket was performed an hour ago and should fix this issue.

I am marking this bug as fix released, feel free to re-open it if the issue isn't actually resolved.

Thanks!

Changed in initramfs-tools (Ubuntu):
status: New → Confirmed
status: Confirmed → Fix Released
Changed in initramfs-tools (Ubuntu Bionic):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers