conffile prompt on dapper->hardy upgrade

Bug #172853 reported by Michael Vogt on 2007-11-29
2
Affects Status Importance Assigned to Milestone
initramfs-tools (Ubuntu)
High
Martin Pitt

Bug Description

Binary package hint: initramfs-tools

I get the following during a dapper->hardy upgrade:

update-initramfs: deferring update (trigger activated)^M
^M
Setting up initramfs-tools (0.85eubuntu21) ...^M
^M
Configuration file `/etc/initramfs-tools/initramfs.conf'^M
 ==> File on system created by you or by a script.^M
 ==> File also in package provided by package maintainer.^M
   What would you like to do about it ? Your options are:^M
    Y or I : install the package maintainer's version^M
    N or O : keep your currently-installed version^M
      D : show the differences between the versions^M
      Z : background this process to examine the situation^M
 The default action is to keep your current version.^M
*** initramfs.conf (Y/I/N/O/D/Z) [default=N] ? [87.0243] volumeid: Installed volumeid

md5sums:
e283c86ee4e9f0476276b72ead5f3951 /etc/initramfs-tools/initramfs.conf
296b675c518585686980060dc68e300f /etc/initramfs-tools/initramfs.conf.dpkg-dist

Michael Vogt (mvo) wrote :
Changed in initramfs-tools:
milestone: none → ubuntu-8.04-beta
importance: Undecided → Medium
Jorge Castro (jorge) on 2008-02-19
Changed in initramfs-tools:
status: New → Confirmed
Martin Pitt (pitti) wrote :

I'll take that one.

Changed in initramfs-tools:
assignee: nobody → pitti
importance: Medium → High
status: Confirmed → In Progress
Martin Pitt (pitti) on 2008-03-13
Changed in initramfs-tools:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package initramfs-tools - 0.85eubuntu31

---------------
initramfs-tools (0.85eubuntu31) hardy; urgency=low

  * debian/initramfs-tools.preinst: If /etc/mkinitramfs/initramfs.conf was not
    modified, do not copy it over to /etc/initramfs-tools on a dapper->hardy
    upgrade, since this causes an unnecessary dpkg conffile prompt.
    (LP: #172853)

 -- Martin Pitt <email address hidden> Thu, 13 Mar 2008 19:19:59 +0100

Changed in initramfs-tools:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments