Please include mlx4 and mlx5 InfiniBand modules

Bug #1719302 reported by Benjamin Drung on 2017-09-25
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
initramfs-tools (Debian)
Fix Released
Unknown
initramfs-tools (Ubuntu)
High
Unassigned

Bug Description

Mellanox ConnectX architecture is: mlx4_core is the lower level PCI driver which register on the PCI id, and protocol specific drivers are depended on it: mlx4_en - for Ethernet and mlx4_ib for Infiniband. NIC could have multiple ports which can change their type dynamically. We use the request_module() call to load the relevant protocol driver when needed: on loading time or at port type change event.

The mlx4_core and mlx5_core modules are included in the initrd, but not mlx4_ib and mlx5_ib. Thus the request_module() call will not find these modules and fail load them. The mlx*_ib module loading will not be retried.

Therefore also include mlx4_ib and mlx5_ib in the initrd to make autoloading them work. A patch is attached to the related Debian bug report.

Changed in initramfs-tools (Debian):
status: Unknown → New
tags: added: rls-aa-incoming
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in initramfs-tools (Ubuntu):
status: New → Confirmed
Luke Williams (wililupy) on 2018-01-02
Changed in initramfs-tools (Ubuntu):
importance: Undecided → High
Talat Batheesh (talat-b87) wrote :

Hi Luke,
Any update with this bug?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package initramfs-tools - 0.130ubuntu2

---------------
initramfs-tools (0.130ubuntu2) bionic; urgency=medium

  * Include mlx4 and mlx5 InfiniBand modules (Closes: #871595, LP: #1719302)

 -- Benjamin Drung <email address hidden> Sat, 27 Jan 2018 12:51:45 +0100

Changed in initramfs-tools (Ubuntu):
status: Confirmed → Fix Released
Changed in initramfs-tools (Debian):
status: New → Fix Committed
Changed in initramfs-tools (Debian):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.