package linux-firmware 1.157.8 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1

Bug #1659785 reported by Asif Ahmad Khan on 2017-01-27
46
This bug affects 10 people
Affects Status Importance Assigned to Milestone
initramfs-tools (Ubuntu)
Critical
vimal kumar v.s.

Bug Description

i can't upgrade from ubuntu 14.04 to 16.04, please help to fix this problem.

ProblemType: Package
DistroRelease: Ubuntu 16.04
Package: linux-firmware 1.157.8
ProcVersionSignature: Ubuntu 3.13.0-108.155-generic 3.13.11-ckt39
Uname: Linux 3.13.0-108-generic x86_64
ApportVersion: 2.20.1-0ubuntu2.5
Architecture: amd64
Date: Fri Jan 27 11:09:05 2017
Dependencies:

DistributionChannelDescriptor:
 # This is a distribution channel descriptor
 # For more information see http://wiki.ubuntu.com/DistributionChannelDescriptor
 canonical-oem-somerville-trusty-amd64-20140620-0
ErrorMessage: subprocess installed post-installation script returned error exit status 1
InstallationDate: Installed on 2017-01-25 (2 days ago)
InstallationMedia: Ubuntu 14.04 "Trusty" - Build amd64 LIVE Binary 20140620-04:25
PackageArchitecture: all
RelatedPackageVersions:
 dpkg 1.18.4ubuntu1.1
 apt 1.2.19
SourcePackage: initramfs-tools
Title: package linux-firmware 1.157.8 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1
UpgradeStatus: No upgrade log present (probably fresh install)

Asif Ahmad Khan (asifkhan) wrote :
tags: removed: need-duplicate-check

how can i fix this problem

On Fri, Jan 27, 2017 at 4:10 PM, Apport retracing service <
<email address hidden>> wrote:

> ** Tags removed: need-duplicate-check
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1659785
>
> Title:
> package linux-firmware 1.157.8 failed to install/upgrade: subprocess
> installed post-installation script returned error exit status 1
>
> Status in initramfs-tools package in Ubuntu:
> New
>
> Bug description:
> i can't upgrade from ubuntu 14.04 to 16.04, please help to fix this
> problem.
>
> ProblemType: Package
> DistroRelease: Ubuntu 16.04
> Package: linux-firmware 1.157.8
> ProcVersionSignature: Ubuntu 3.13.0-108.155-generic 3.13.11-ckt39
> Uname: Linux 3.13.0-108-generic x86_64
> ApportVersion: 2.20.1-0ubuntu2.5
> Architecture: amd64
> Date: Fri Jan 27 11:09:05 2017
> Dependencies:
>
> DistributionChannelDescriptor:
> # This is a distribution channel descriptor
> # For more information see http://wiki.ubuntu.com/
> DistributionChannelDescriptor
> canonical-oem-somerville-trusty-amd64-20140620-0
> ErrorMessage: subprocess installed post-installation script returned
> error exit status 1
> InstallationDate: Installed on 2017-01-25 (2 days ago)
> InstallationMedia: Ubuntu 14.04 "Trusty" - Build amd64 LIVE Binary
> 20140620-04:25
> PackageArchitecture: all
> RelatedPackageVersions:
> dpkg 1.18.4ubuntu1.1
> apt 1.2.19
> SourcePackage: initramfs-tools
> Title: package linux-firmware 1.157.8 failed to install/upgrade:
> subprocess installed post-installation script returned error exit status 1
> UpgradeStatus: No upgrade log present (probably fresh install)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/initramfs-tools/+bug/1659785/+
> subscriptions
>

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in initramfs-tools (Ubuntu):
status: New → Confirmed

@ Asif Ahmad Khan

You can't fix the problem yourself. Some developer will fix it for you, and you will be noticed about it.

Thanks for reporting 🍀

Changed in initramfs-tools (Ubuntu):
importance: Undecided → High
importance: High → Critical

Is this the same Bug? https://bugs.launchpad.net/ubuntu/+source/initramfs-tools/+bug/1745428 (package linux-firmware 1.157.15 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1)

Steve Langasek (vorlon) wrote :

I'm sorry, but this was wrongly triaged as a critical bug in initramfs-tools, when in fact it appears to be a bug in some software not originating in Ubuntu. The error in your logs was:

> update-initramfs: Generating /boot/initrd.img-3.13.0-108-generic
> E: /usr/share/initramfs-tools/hooks/casper-memdisk failed with return 1.
> update-initramfs: failed for /boot/initrd.img-3.13.0-108-generic with 1.
> dpkg: error processing package linux-firmware (--configure):
> subprocess installed post-installation script returned error exit status 1

There is no script named /usr/share/initramfs-tools/hooks/casper-memdisk as part of any package in the Ubuntu archive.

Changed in initramfs-tools (Ubuntu):
status: Confirmed → Invalid
Changed in initramfs-tools (Ubuntu):
assignee: nobody → vimal kumar v.s. (daredevilking)
status: Invalid → Incomplete
salmedram (salmedram) on 2018-08-06
Changed in initramfs-tools (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers