Support rootfs on xhci-plat-hcd attached storage

Bug #1649213 reported by Ike Panhc on 2016-12-12
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
initramfs-tools (Ubuntu)
Undecided
Ike Panhc
Trusty
Undecided
Ike Panhc
Xenial
Undecided
Ike Panhc
Zesty
Undecided
Ike Panhc

Bug Description

[Impact]
If you install Ubuntu onto USB storage behind a Platform USB host controller, it will not be able to boot because the generated initramfs will not include the host controller driver.

[Test Case]
Install to a USB stick attached to platform USB controller and reboot. Booting will fail because it will be unable to find the root file system.

[Regression Risk]
Driver is only loaded when system requires xhci-plat-hcd, minimizing the impact to all other systems.

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1649213

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Ike Panhc (ikepanhc) wrote :

bug 1625222 is duplicated bug for kernel which already in progress. To use that one for tracking kernel makes more sense to me.

Ike Panhc (ikepanhc) wrote :

This issue for linux is fix-committed in xenial yakkety and zesty. Delete affects package

Changed in initramfs-tools (Ubuntu Zesty):
assignee: nobody → Ike Panhc (ikepanhc)
Changed in initramfs-tools (Ubuntu Xenial):
assignee: nobody → Ike Panhc (ikepanhc)
Changed in initramfs-tools (Ubuntu Trusty):
assignee: nobody → Ike Panhc (ikepanhc)
no longer affects: linux (Ubuntu)
Ike Panhc (ikepanhc) wrote :

initramfs-tools v0.125 or above picks up every hcd.ko for usb. Set to invalid.

Changed in initramfs-tools (Ubuntu Zesty):
status: New → Invalid
Changed in linux (Ubuntu Zesty):
status: Incomplete → Invalid
Changed in linux (Ubuntu Xenial):
status: New → Invalid
Changed in linux (Ubuntu Trusty):
status: New → Invalid
dann frazier (dannf) on 2016-12-15
no longer affects: linux (Ubuntu Zesty)
no longer affects: linux (Ubuntu Xenial)
no longer affects: linux (Ubuntu Trusty)

Hello Ike, or anyone else affected,

Accepted initramfs-tools into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/initramfs-tools/0.122ubuntu8.8 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in initramfs-tools (Ubuntu Xenial):
status: New → Fix Committed
tags: added: verification-needed
Brian Murray (brian-murray) wrote :

Is the Trusty task valid? I don't see an upload in its SRU queue.

On Thu, Jan 5, 2017 at 2:46 PM, Brian Murray <email address hidden> wrote:
> Is the Trusty task valid? I don't see an upload in its SRU queue.

It is - I think Ike maybe waiting for the current trusty-proposed
version to migrate before rebasing.

  -dann

Ike Panhc (ikepanhc) wrote :

initramfs-tools in xenial-proposed solves this issue.

ubuntu@test:~$ dpkg --list | grep initramfs-tools
ii initramfs-tools 0.122ubuntu8.8 all generic modular initramfs generator (automation)
ii initramfs-tools-bin 0.122ubuntu8.8 amd64 binaries used by initramfs-tools
ii initramfs-tools-core 0.122ubuntu8.8 all generic modular initramfs generator (core tools)
ubuntu@test:~$ zcat initrd.img-4.4.0-59-generic | cpio -idmv 2> /dev/null
ubuntu@test:~$ find . -name 'xhci-plat*'
./lib/modules/4.4.0-59-generic/kernel/drivers/usb/host/xhci-plat-hcd.ko

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package initramfs-tools - 0.122ubuntu8.8

---------------
initramfs-tools (0.122ubuntu8.8) xenial; urgency=medium

  * hook-functions: include xhci-plat-hcd in auto_add_modules_list
    (LP: #1649213)

 -- Ike Panhc <email address hidden> Wed, 14 Dec 2016 13:59:43 +0800

Changed in initramfs-tools (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for initramfs-tools has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Hello Ike, or anyone else affected,

Accepted initramfs-tools into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/initramfs-tools/0.103ubuntu4.7 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in initramfs-tools (Ubuntu Trusty):
status: New → Fix Committed
tags: removed: verification-done
tags: added: verification-needed
Ike Panhc (ikepanhc) wrote :

Thanks. initramfs-tools in trusty-proposed solves this issue.

ubuntu@test:~$ zcat /boot/initrd.img-4.4.0-62-generic | cpio -idmv 2> /dev/null
ubuntu@test:~$ find . -name 'xhci-plat*'
./lib/modules/4.4.0-62-generic/kernel/drivers/usb/host/xhci-plat-hcd.ko
ubuntu@test:~$ dpkg --list | grep initramfs-tools
ii initramfs-tools 0.103ubuntu4.7 all tools for generating an initramfs
ii initramfs-tools-bin 0.103ubuntu4.7 amd64 binaries used by initramfs-tools

tags: added: verification-done
removed: verification-needed
Robie Basak (racb) wrote :

There are a bunch of autopkgtest failure against this SRU. See https://people.canonical.com/~ubuntu-archive/pending-sru.html. Please could you check to see if these are real issues, are hiding real test results or are merely false positives with no other impact?

Ike Panhc (ikepanhc) wrote :

Have a quick review on the last error of test log

autopkgtest for linux-lts-vivid (ppc64el): ERROR: running version does not match source package
autopkgtest for linux-lts-vivid (i386): ERROR: running version does not match source package
autopkgtest for linux-lts-vivid (amd64): ERROR: running version does not match source package
autopkgtest for linux-lts-vivid (armhf): rebuild FAIL timed out
autopkgtest for linux-lts-utopic (ppc64el): ERROR: running version does not match source package
autopkgtest for linux-lts-utopic (i386): ERROR: running version does not match source package
autopkgtest for linux-lts-utopic (amd64): ERROR: running version does not match source package
autopkgtest for linux-lts-utopic (armhf): rebuild FAIL timed out
autopkgtest for linux-lts-wily (armhf): rebuild FAIL timed out
autopkgtest for linux (ppc64el): Run kernel regression tests ... FAIL
autopkgtest for linux-lts-xenial (ppc64el): ERROR: running version does not match source package
autopkgtest for linux-lts-xenial (i386): ERROR: running version does not match source package
autopkgtest for linux-lts-xenial (armhf): rebuild FAIL timed out

Ike Panhc (ikepanhc) wrote :

All armhf errors are kernel rebuild timeout due to slow machine.
One error (linux of ppc64el) are kernel regression test fail. Need to look into why.
Other errors are machine running different kernel version, trusty generic (3.13) and backport kernels.

Ike Panhc (ikepanhc) wrote :

@racb, Is there any doc about autopkgtest so that I can reproduce the error and get to bottom of this.

Ike Panhc (ikepanhc) wrote :

Found an open bug about different kernel version.

https://bugs.launchpad.net/auto-package-testing/+bug/1561110

Ike Panhc (ikepanhc) wrote :

armhf rebuild test and regression testing are all in kernel-team's script. I am working on solving this but they are not initramfs-tools' issue.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package initramfs-tools - 0.103ubuntu4.7

---------------
initramfs-tools (0.103ubuntu4.7) trusty; urgency=medium

  * hook-functions: copy xhci-plat-hcd also.
    (LP: #1649213)

 -- Ike Panhc <email address hidden> Tue, 10 Jan 2017 12:31:44 +0800

Changed in initramfs-tools (Ubuntu Trusty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers