Activity log for bug #1615641

Date Who What changed Old value New value Message
2016-08-22 13:40:47 Colin Ian King bug added bug
2016-08-22 13:40:57 Colin Ian King initramfs-tools (Ubuntu): importance Undecided High
2016-08-22 13:41:15 Colin Ian King description I've noticed that boots on Ubuntu Yakkety have slowed down recently. I added some debug into my kernel to see where delays are occurring and I can observed 5 seconds being consumed in /scripts/local-premount/resume : Aug 22 14:34:36 lenovo kernel: [ 6.823263] _do_fork: 1 (init) Aug 22 14:34:36 lenovo kernel: [ 6.823333] do_exec: 824 (init) /scripts/local-premount/ntfs_3g Aug 22 14:34:36 lenovo kernel: [ 6.823766] _do_fork: 1 (init) Aug 22 14:34:36 lenovo kernel: [ 6.823845] do_exec: 825 (init) /scripts/local-premount/resume Aug 22 14:34:36 lenovo kernel: [ 6.824214] _do_fork: 825 (resume) Aug 22 14:34:36 lenovo kernel: [ 6.824322] do_exec: 826 (resume) /sbin/wait-for-root Aug 22 14:34:36 lenovo kernel: [ 11.825642] _do_fork: 1 (init) Aug 22 14:34:36 lenovo kernel: [ 11.825800] do_exec: 827 (init) /sbin/wait-for-root Aug 22 14:34:36 lenovo kernel: [ 11.826691] _do_fork: 1 (init) It seems that /scripts/local-premount/resume is being called and wait-for-root times out after 5 seconds. The resume script does set a 5 second timeout, so I must be hitting that for some reason. I've noticed that boots on Ubuntu Yakkety have slowed down recently. I added some debug into my kernel to see where delays are occurring and I can observe 5 seconds being consumed in /scripts/local-premount/resume : Aug 22 14:34:36 lenovo kernel: [ 6.823263] _do_fork: 1 (init) Aug 22 14:34:36 lenovo kernel: [ 6.823333] do_exec: 824 (init) /scripts/local-premount/ntfs_3g Aug 22 14:34:36 lenovo kernel: [ 6.823766] _do_fork: 1 (init) Aug 22 14:34:36 lenovo kernel: [ 6.823845] do_exec: 825 (init) /scripts/local-premount/resume Aug 22 14:34:36 lenovo kernel: [ 6.824214] _do_fork: 825 (resume) Aug 22 14:34:36 lenovo kernel: [ 6.824322] do_exec: 826 (resume) /sbin/wait-for-root Aug 22 14:34:36 lenovo kernel: [ 11.825642] _do_fork: 1 (init) Aug 22 14:34:36 lenovo kernel: [ 11.825800] do_exec: 827 (init) /sbin/wait-for-root Aug 22 14:34:36 lenovo kernel: [ 11.826691] _do_fork: 1 (init) It seems that /scripts/local-premount/resume is being called and wait-for-root times out after 5 seconds. The resume script does set a 5 second timeout, so I must be hitting that for some reason.
2016-12-07 07:40:26 Launchpad Janitor initramfs-tools (Ubuntu): status New Confirmed