Support root on ehci-msm attached storage

Bug #1588946 reported by dann frazier on 2016-06-03
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
initramfs-tools (Ubuntu)
Undecided
dann frazier
Xenial
Undecided
dann frazier
linux (Ubuntu)
Undecided
Manoj Iyer
Xenial
Undecided
Unassigned

Bug Description

[Impact]
If you install Ubuntu onto USB storage behind a Qualcomm QSD/MSM USB host controller, it will not be able to boot because the generated initramfs will not include the host controller driver.

[Test Case]
Install to a USB stick attached to QSD/MSM controller and reboot. Booting will fail because it will be unable to find the root file system.

[Regression Risk]
This driver is only available on ARM platforms, minimizing the impact to all other architectures.

dann frazier (dannf) on 2016-06-03
Changed in initramfs-tools (Ubuntu Xenial):
status: New → Confirmed
Changed in initramfs-tools (Ubuntu):
status: New → In Progress
dann frazier (dannf) wrote :

Marking linux as affected, since we also need qhci-msm module included in the usb-modules udeb.

Changed in linux (Ubuntu):
status: New → Confirmed
assignee: nobody → Manoj Iyer (manjo)
Changed in initramfs-tools (Ubuntu):
assignee: nobody → dann frazier (dannf)
dann frazier (dannf) on 2016-06-03
summary: - Support booting from ehci-msm attached storage
+ Support root on ehci-msm attached storage
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package initramfs-tools - 0.122ubuntu9

---------------
initramfs-tools (0.122ubuntu9) yakkety; urgency=medium

  * hook-functions: include ehci-msm in auto_add_modules_list
    (LP: #1588946)

 -- dann frazier <email address hidden> Fri, 03 Jun 2016 13:37:06 -0600

Changed in initramfs-tools (Ubuntu):
status: In Progress → Fix Released
dann frazier (dannf) on 2016-06-06
Changed in initramfs-tools (Ubuntu Xenial):
status: Confirmed → In Progress
assignee: nobody → dann frazier (dannf)

Hello dann, or anyone else affected,

Accepted initramfs-tools into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/initramfs-tools/0.122ubuntu8.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in initramfs-tools (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed
dann frazier (dannf) on 2016-06-08
tags: added: verification-done
removed: verification-needed

The verification of the Stable Release Update for initramfs-tools has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package initramfs-tools - 0.122ubuntu8.1

---------------
initramfs-tools (0.122ubuntu8.1) xenial; urgency=medium

  * hook-functions: include ehci-msm in auto_add_modules_list
    (LP: #1588946)

 -- dann frazier <email address hidden> Mon, 06 Jun 2016 12:31:45 -0600

Changed in initramfs-tools (Ubuntu Xenial):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in linux (Ubuntu Xenial):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers