initramfs-tools ignores the FRAMEBUFFER option

Bug #1561643 reported by Alberto Milone on 2016-03-24
30
This bug affects 3 people
Affects Status Importance Assigned to Milestone
initramfs-tools (Ubuntu)
High
Andy Whitcroft
Declined for Artful by Dimitri John Ledkov
Xenial
Undecided
Unassigned
Bionic
High
Brian Murray

Bug Description

[Impact]
initramfs-tools would always include all "framebuffer" drivers/firmware inside initramfs, which was making it ever more huge. In some systems with low memory, that would even prevent systems to boot. kdump, for example, had an impact.

[Test case]
Different systems on different arches were tested. When cryptsetup (or cryptsetup-initramfs) was installed, framebuffer drivers were included in the ramdisk. When not installed, the initramfs was smaller. Systems booted on both cases. Systems with encrypted disks were tested as well.

[Regression Potential]
Systems may not boot because of missing drivers. Users may have a different experience during boot because of missing "framebuffer" drivers.

==================

initramfs-tools ignores the FRAMEBUFFER option. This means that the framebuffer hook will always include the drm modules, regardless of whether it is dealing with an encrypted system or not.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: initramfs-tools 0.122ubuntu6
ProcVersionSignature: Ubuntu 4.4.0-15.31-generic 4.4.6
Uname: Linux 4.4.0-15-generic x86_64
NonfreeKernelModules: nvidia_uvm nvidia_drm nvidia_modeset nvidia
ApportVersion: 2.20-0ubuntu3
Architecture: amd64
CurrentDesktop: Unity
Date: Thu Mar 24 18:06:24 2016
InstallationDate: Installed on 2016-02-16 (37 days ago)
InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Alpha amd64 (20160209)
PackageArchitecture: all
SourcePackage: initramfs-tools
UpgradeStatus: No upgrade log present (probably fresh install)

Alberto Milone (albertomilone) wrote :
Alberto Milone (albertomilone) wrote :

I am attaching the output of the following command:
lsinitramfs /boot/initrd.img-`uname -r` | grep drm

Changed in initramfs-tools (Ubuntu):
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Andy Whitcroft (apw)
Andy Whitcroft (apw) on 2016-03-24
Changed in initramfs-tools (Ubuntu):
milestone: none → ubuntu-16.03
Wladimir Mutel (mwg) wrote :

I reported the same problem with more details at https://bugs.launchpad.net/initramfs-tools/+bug/1651170
But I am not sure that anyone is reading initramfs-tools bug reports ever.
I don't like that my initrd*.img is about 50 MB large, but who else cares, the storage is cheap and fast now.

tags: added: patch
tags: added: rls-bb-incoming
Wladimir Mutel (mwg) wrote :

Dear Thadeu,
I tested your patch and it seems to be working well
on my i386 system it reduced initrd from 8.1 to 2.9 MB
but does it have a chance to be integrated into Ubuntu 18.04 Bionic ?
Or I should wait for Ubuntu 20.04 ?
Now it is not even integrated into Ub. 18.10 Cosmic

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package initramfs-tools - 0.131ubuntu12

---------------
initramfs-tools (0.131ubuntu12) cosmic; urgency=medium

  * Do not include graphical drivers when FRAMEBUFFER is not set (LP: #1561643)

 -- Thadeu Lima de Souza Cascardo <email address hidden> Thu, 13 Sep 2018 08:49:11 -0300

Changed in initramfs-tools (Ubuntu):
status: Confirmed → Fix Released
Wladimir Mutel (mwg) wrote :

God, I can't believe it would really get into Ubuntu 20.04
Only 1.5 short years of waiting left

Brian Murray (brian-murray) wrote :

I'll upload this to Stable Release Updates queue for Ubuntu 18.04 but this bug could use a test case and additional SRU information which can be found at https://wiki.ubuntu.com/StableReleaseUpdates. Thanks!

Changed in initramfs-tools (Ubuntu Bionic):
assignee: nobody → Brian Murray (brian-murray)
status: New → In Progress
importance: Undecided → High
Robie Basak (racb) wrote :

This is blocked from processing due to missing SRU information as requested by Brian in comment 9 above. If you'd like to get this bug fixed, please help. See https://wiki.ubuntu.com/StableReleaseUpdates#Procedure for details. Otherwise the proposed fix will get rejected from the SRU queue.

description: updated

Hello Alberto, or anyone else affected,

Accepted initramfs-tools into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/initramfs-tools/0.130ubuntu3.7 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in initramfs-tools (Ubuntu Bionic):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-bionic
tags: removed: rls-bb-incoming

Tested on a chroot that the resulting initramfs is smaller and doesn't contain the framebuffer drivers. After installing some cryptsetup packages, those same drivers were included again after regenerating initrd images.

Cascardo.

tags: added: verification-done verification-done-bionic
removed: verification-needed verification-needed-bionic

The verification of the Stable Release Update for initramfs-tools has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package initramfs-tools - 0.130ubuntu3.7

---------------
initramfs-tools (0.130ubuntu3.7) bionic; urgency=medium

  [ Steve Langasek ]
  * hooks/resume: cherry-pick patch from upstream git to fix
    auto-configuration of resume devices that are on LVM; always refer to
    them by name, never by UUID. LP: #1768230.

  [ Thadeu Lima de Souza Cascardo ]
  * Do not include graphical drivers when FRAMEBUFFER is not set.
    (LP: #1561643)

 -- Brian Murray <email address hidden> Thu, 17 Jan 2019 12:26:22 -0800

Changed in initramfs-tools (Ubuntu Bionic):
status: Fix Committed → Fix Released
Wladimir Mutel (mwg) wrote :

can't believe it was fixed in less than 3 short years

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers