package linux-image-extra-4.4.0-7-generic 4.4.0-7.22 failed to install/upgrade: run-parts: /etc/kernel/postinst.d/initramfs-tools exited with return code 2

Bug #1549531 reported by heiko on 2016-02-24
48
This bug affects 9 people
Affects Status Importance Assigned to Milestone
initramfs-tools (Ubuntu)
High
Unassigned

Bug Description

Upgrade failure.
But system is still running ...

Edit (of 2016-02-25):
Package in question is installed. So what's the issue? Is it just a wrong message I received from the system? (It was telling me that my system would be corrupted and probably unusable ... I'm happy it is not the case ...)

Edit (of 2016-02-26):
Because of some sound issues I applied following command to reinstall recent kernel: sudo apt-get install --reinstall linux-image-$(uname -r)
That fixed my sound problems so far.

ProblemType: Package
DistroRelease: Ubuntu 16.04
Package: linux-image-extra-4.4.0-7-generic 4.4.0-7.22
ProcVersionSignature: Ubuntu 4.4.0-7.22-generic 4.4.2
Uname: Linux 4.4.0-7-generic x86_64
ApportVersion: 2.20-0ubuntu3
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: heiko 2026 F.... pulseaudio
Date: Thu Feb 25 00:27:59 2016
ErrorMessage: run-parts: /etc/kernel/postinst.d/initramfs-tools exited with return code 2
HibernationDevice: RESUME=UUID=b80b33ed-aad7-449d-a704-2b3c4433fc09
InstallationDate: Installed on 2015-12-29 (57 days ago)
InstallationMedia: Ubuntu-GNOME 15.10 "Wily Werewolf" - Release amd64 (20151021)
MachineType: LENOVO 6468AF4
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-7-generic root=UUID=f4457ebc-0b50-4985-af9f-ef80749359d2 ro quiet splash vt.handoff=7
PulseList: Error: command ['pacmd', 'list'] failed with exit code 1: No PulseAudio daemon running, or not running as session daemon.
RelatedPackageVersions: grub-pc 2.02~beta2-36
SourcePackage: initramfs-tools
Title: package linux-image-extra-4.4.0-7-generic 4.4.0-7.22 failed to install/upgrade: run-parts: /etc/kernel/postinst.d/initramfs-tools exited with return code 2
UpgradeStatus: Upgraded to xenial on 2016-02-24 (0 days ago)
dmi.bios.date: 02/27/2012
dmi.bios.vendor: LENOVO
dmi.bios.version: 7LETD0WW (2.30 )
dmi.board.name: 6468AF4
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: 6468AF4L3C2596
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr7LETD0WW(2.30):bd02/27/2012:svnLENOVO:pn6468AF4:pvrThinkPadT61:rvnLENOVO:rn6468AF4:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 6468AF4
dmi.product.version: ThinkPad T61
dmi.sys.vendor: LENOVO

heiko (heikosch) wrote :
tags: removed: need-duplicate-check
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in initramfs-tools (Ubuntu):
status: New → Confirmed
heiko (heikosch) on 2016-02-25
description: updated
description: updated
heiko (heikosch) on 2016-02-26
description: updated
Changed in initramfs-tools (Ubuntu):
importance: Undecided → High

I got only the "some packages did not ..." "System might be unusable" messages. Since I am not experienced in Ubuntu I do not know what to do to get more specific information. Nor do I have a workaround. Afraid to reboot.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers