initrd-tools: use qla1280 on 2.6 instead qlogicisp

Bug #15194 reported by Debian Bug Importer on 2005-04-10
10
Affects Status Importance Assigned to Milestone
initramfs-tools (Debian)
Fix Released
Unknown
initramfs-tools (Ubuntu)
High
Adam Conrad

Bug Description

Automatically imported from Debian bug report #289995 http://bugs.debian.org/289995

* Norbert Tretkowski wrote:
> Attached patch modifies mkinitrd so the new qla1280 driver is used
> for qlogic 1020/1040 controllers with current 2.6 kernels on alpha.

This patch fails when you try to create an initrd for a 2.4 kernel on
a running 2.6 kernel using qla1280.

I'll provide a better patch soon.

Norbert

# Automatically generated email from bts, devscripts version 2.8.14
severity 289995 grave

Debian Bug Importer (debzilla) wrote :

Automatically imported from Debian bug report #289995 http://bugs.debian.org/289995

Debian Bug Importer (debzilla) wrote :

Message-ID: <email address hidden>
Date: Wed, 12 Jan 2005 09:52:12 +0100
From: Norbert Tretkowski <email address hidden>
To: Debian Bug Tracking System <email address hidden>
Subject: initrd-tools: use qla1280 on 2.6/alpha instead qlogicisp

--17pEHd4RhPHOinZp
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline

Package: initrd-tools
Version: 0.1.76
Severity: normal
Tags: patch

Attached patch modifies mkinitrd so the new qla1280 driver is used
for qlogic 1020/1040 controllers with current 2.6 kernels on alpha.

Maybe it's a good idea to add a Conflicts: to the older (and current)
alpha kernel images, because the qla1280 driver from kernel-source
2.6.8-11 and earlier does not support the qlogic 1020/1040 controllers.

The first release which will add qlogic 1020/1040 support to the
qla1280 driver will be kernel-image-2.6.8-alpha 2.6.8-7, which I'll
upload as soon as kernel-source-2.6.8 2.6.8-13 is available.

Regards, Norbert

-- System Information:
Debian Release: 3.1
  APT prefers testing
  APT policy: (500, 'testing'), (1, 'experimental')
Architecture: i386 (i686)
Kernel: Linux 2.6.10-1-686
Locale: LANG=POSIX, LC_CTYPE=de_DE (charmap=ISO-8859-1)

Versions of packages initrd-tools depends on:
ii coreutils [fileutils] 5.2.1-2 The GNU core utilities
ii cpio 2.5-1.1 GNU cpio -- a program to manage ar
ii cramfsprogs 1.1-6 Tools for CramFs (Compressed ROM F
ii dash 0.5.1-3 The Debian Almquist Shell
ii util-linux 2.12-10 Miscellaneous system utilities

-- no debconf information

--17pEHd4RhPHOinZp
Content-Type: text/plain; charset=us-ascii
Content-Disposition: attachment; filename="qlogic.diff"

--- /usr/sbin/mkinitrd.bak 2004-12-30 18:30:33.000000000 +0100
+++ /usr/sbin/mkinitrd 2005-01-12 09:46:27.000000000 +0100
@@ -557,6 +557,8 @@
    exit 1
   fi

+ QLA_SCSI=qlogicisp
+
   # Educate mkinitrd about different arches..
   case "$(dpkg --print-architecture)" in
    mips) ARCH_ESP=jazz_esp ;;
@@ -575,6 +577,13 @@
     esac
    ;;
    sparc | sparc64) ARCH_ESP=esp ;;
+ alpha)
+ case $VERSION in
+ 2.6*)
+ QLA_SCSI=qla1280
+ ;;
+ esac
+ ;;
   esac

   find /proc/scsi -type d -mindepth 1 -maxdepth 1 \
@@ -585,7 +594,7 @@
     s/^aac$/aacraid/; t
     s/^am53c974$/AM53C974/; t
     s/^eata2x$/eata/; t
- s/^isp1020$/qlogicisp/; t
+ s/^isp1020$/'$QLA_SCSI'/; t
     s/^isp2x00$/qlogicfc/; t
     s/^ncr53c7xx$/53c7,8xx/; t
     s/^ncr53c8xx$/sym53c8xx/; t

--17pEHd4RhPHOinZp--

Debian Bug Importer (debzilla) wrote :

Message-ID: <email address hidden>
Date: Sat, 22 Jan 2005 17:17:36 +0100
From: Norbert Tretkowski <email address hidden>
To: <email address hidden>
Subject: Re: Bug#289995: initrd-tools: use qla1280 on 2.6/alpha instead qlogicisp

* Norbert Tretkowski wrote:
> Attached patch modifies mkinitrd so the new qla1280 driver is used
> for qlogic 1020/1040 controllers with current 2.6 kernels on alpha.

This patch fails when you try to create an initrd for a 2.4 kernel on
a running 2.6 kernel using qla1280.

I'll provide a better patch soon.

Norbert

Debian Bug Importer (debzilla) wrote :

Message-Id: <email address hidden>
Date: Sun, 10 Apr 2005 14:16:21 +0200
From: Bastian Blank <email address hidden>
To: <email address hidden>
Subject: severity of 289995 is grave

# Automatically generated email from bts, devscripts version 2.8.14
severity 289995 grave

Source: initrd-tools
Source-Version: 0.1.78

We believe that the bug you reported is fixed in the latest version of
initrd-tools, which is due to be installed in the Debian FTP archive:

initrd-tools_0.1.78.dsc
  to pool/main/i/initrd-tools/initrd-tools_0.1.78.dsc
initrd-tools_0.1.78.tar.gz
  to pool/main/i/initrd-tools/initrd-tools_0.1.78.tar.gz
initrd-tools_0.1.78_all.deb
  to pool/main/i/initrd-tools/initrd-tools_0.1.78_all.deb

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed. If you
have further comments please address them to <email address hidden>,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Bastian Blank <email address hidden> (supplier of updated initrd-tools package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing <email address hidden>)

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.7
Date: Sun, 10 Apr 2005 14:03:43 +0200
Source: initrd-tools
Binary: initrd-tools
Architecture: source all
Version: 0.1.78
Distribution: unstable
Urgency: high
Maintainer: Debian kernel team <email address hidden>
Changed-By: Bastian Blank <email address hidden>
Description:
 initrd-tools - tools to create initrd image for prepackaged Linux kernel
Closes: 284961 289995
Changes:
 initrd-tools (0.1.78) unstable; urgency=high
 .
   * Bastian Blank
     - Always map sym53c8xx to sym53c8xx_2 for 2.4 kernels. (closes: #284961)
     - Map between qlogicisp and qla1280 on alpha. (closes: #289995)
Files:
 f9672f63eca739b3de483a385aa257ed 616 utils optional initrd-tools_0.1.78.dsc
 945aa7e33118cbdc6109aa3bf70a867d 25679 utils optional initrd-tools_0.1.78.tar.gz
 9a8548d60e4a1ac1b30252faf3c6e8ba 28732 utils optional initrd-tools_0.1.78_all.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.0 (GNU/Linux)

iEYEARECAAYFAkJZNNIACgkQLkAIIn9ODhGoYgCgtFoJ38n6Ny1XibDLGYvtezQH
5DsAoPRJrN7BPYZYpdnJUIjE0nEnYDx9
=ToW4
-----END PGP SIGNATURE-----

Debian Bug Importer (debzilla) wrote :

Message-Id: <email address hidden>
Date: Sun, 10 Apr 2005 10:32:29 -0400
From: Bastian Blank <email address hidden>
To: <email address hidden>
Subject: Bug#289995: fixed in initrd-tools 0.1.78

Source: initrd-tools
Source-Version: 0.1.78

We believe that the bug you reported is fixed in the latest version of
initrd-tools, which is due to be installed in the Debian FTP archive:

initrd-tools_0.1.78.dsc
  to pool/main/i/initrd-tools/initrd-tools_0.1.78.dsc
initrd-tools_0.1.78.tar.gz
  to pool/main/i/initrd-tools/initrd-tools_0.1.78.tar.gz
initrd-tools_0.1.78_all.deb
  to pool/main/i/initrd-tools/initrd-tools_0.1.78_all.deb

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed. If you
have further comments please address them to <email address hidden>,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Bastian Blank <email address hidden> (supplier of updated initrd-tools package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing <email address hidden>)

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.7
Date: Sun, 10 Apr 2005 14:03:43 +0200
Source: initrd-tools
Binary: initrd-tools
Architecture: source all
Version: 0.1.78
Distribution: unstable
Urgency: high
Maintainer: Debian kernel team <email address hidden>
Changed-By: Bastian Blank <email address hidden>
Description:
 initrd-tools - tools to create initrd image for prepackaged Linux kernel
Closes: 284961 289995
Changes:
 initrd-tools (0.1.78) unstable; urgency=high
 .
   * Bastian Blank
     - Always map sym53c8xx to sym53c8xx_2 for 2.4 kernels. (closes: #284961)
     - Map between qlogicisp and qla1280 on alpha. (closes: #289995)
Files:
 f9672f63eca739b3de483a385aa257ed 616 utils optional initrd-tools_0.1.78.dsc
 945aa7e33118cbdc6109aa3bf70a867d 25679 utils optional initrd-tools_0.1.78.tar.gz
 9a8548d60e4a1ac1b30252faf3c6e8ba 28732 utils optional initrd-tools_0.1.78_all.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.0 (GNU/Linux)

iEYEARECAAYFAkJZNNIACgkQLkAIIn9ODhGoYgCgtFoJ38n6Ny1XibDLGYvtezQH
5DsAoPRJrN7BPYZYpdnJUIjE0nEnYDx9
=ToW4
-----END PGP SIGNATURE-----

Jeff Bailey (jbailey) wrote :

Doesn't apply to us, we don't have an Alpha port. But the fixes is merged as
part of 0.1.78 anyway.

ShawnStarr (shawn-starr) wrote :

I am reopening this. This is not Alpha specific. One of my friends has the Qlogic ISP1040(B) and cannot install Ubuntu at
all, kernel panics on driver detection of SCSI disks. We should not be loading the broken qlogicisp driver AFAIK. Use
qla1280.

This is broken in HOARY.

Jeff Bailey (jbailey) wrote :

(In reply to comment #6)
> I am reopening this. This is not Alpha specific. One of my friends has the
Qlogic ISP1040(B) and cannot install Ubuntu at
> all, kernel panics on driver detection of SCSI disks. We should not be loading
the broken qlogicisp driver AFAIK. Use
> qla1280.
>
> This is broken in HOARY.

Can you try one of the nightly Breezy snapshots to see if it works for you?
http://cdimage.ubuntu.com/daily/current/

Tks,
Jeff Bailey

ShawnStarr (shawn-starr) wrote :

Panic below:

QLogic Corporation
PCI SCSI ROM BIOS Version 4.15
Copyright (C) Qlogic Corporation 1993-1997. All rights reserved.

Press <Alt-Q> for Fast!UTIL

ISP Firmware 2.26
Using IRQ number 10

Device Device Adapter SCSI SCSI Vendor Product Product
Number Type Number ID LUN ID ID Revision
 80 Disk 0 2 0 IBM DDYS-T18350N S94Q
ROM BIOS Installed

Call Trace
==========

SCSI subsystem intialized
ACPI: PCI Interrupt Link [LNKA] eanbled at IRQ 10
ACPI: PCI Interrupt 0000:00:08.0[A] -> Link [LNKA] -> GSI 10
(level, low) -> IRQ10
ERROR: SCSI host `isp1020` has no error handling
ERROR: This is not a safe way to run your SCSI host
ERROR: The error handling must be added to this driver
[<d889d249>] scsi_host_alloc+0x63/0x2cc [scsi_mod]
[<d889d4b7>] scsi_register+0x10/0x54 [scsi_mod]
[<d8881041>] isp1020_detect+0x41/0x20f [qlogicisp]
[<d883f050>] init_this_scsi_driver+0x50/0xc4 [qlogicisp]
[<c012967a>] sys_init_module+0xb5/0x172
[<c0102ef9>] syscall_call+0x7/0xb
qlogicisp : new isp1020 revision ID (5)
scsi0: QLogic ISP1020 SCSI on PCI bus 00 device 40 irq 10 MEM base
0xd8862000
  Vendor: IBM Model: DDYS-T18350N Rev: S94Q
  Type: Direct-Access ANSI SCSI revision
SCSI device sda: 35566480 512-byte hdwr sectors (18210 MB)
SCSI device sda: drive cache: write back
SCSI device sda: 35566480 512-byte hdwr sectors (18210 MB)
SCSI device sda: drive cache: write back
/dev/scsi/host0/bus0/target2/lun0: p1
Attached scsi disk sda at scsi0, channel 0, id 2, lun 0

EFLAGS: 00010006 (2.6.12-8-386)
EIP is at isp1020_inter_handler+0x1c4/0x232 [qlogicisp]
eax: 00040000 ebx: 00000000 ecx: 00040000 edx: 00000001
esi: 00000000 edi: 00000000 ebp: 00000003 esp: d583dee0
ds: 007b es: 007b ss: 0068
Process test (pid: 2372, threadinfo=d583c000 task=d7b33560)
Stack: d789d080 0000a5a5 d6e92204 00000286 00000000 00000000
0000000a d888161f 0000000a d6e92000 d583df50 d618dec0 c012d97f 0000000a
d6e92000 d583df50 d583df50 c0319f80 0000000a d7c4ae20 d583df50 c012da1e
d5d60a80 00800100

Call Trace:
[<d888161f>] do_isp1020_intr_handler+0x15/0x21 [qlogicisp]
[<c012d97f>] handle_IRQ_event+0x20/0x4c
[<c012da1e>] __do_IRQ+0x73/0xb1
[<c0104ca5>] do_IRQ+0x19/0x24
[<c01038b6>] common_interrupt+0x1a/0x20
[<c02610b0>] schedule+0x45e/0x4a4
[<c0102f66>] work_resched+0x5/0x16
Code: c7 80 f8 00 00 00 01 00 00 00 f6 42 0d 20 74 10 8d bb b8
00 00 00 8d 72 20 b9 18 00 00 00 f3 a5 80 3a 03 75 0f 52 e8 6e 00 00 00 <89> 83
48 01 00 00 5f eb 0a c7 83 48 01 00 00 00 00 07 00 66 83
<0> Kernel panic - not syncing: Fatal exception in interrupt

ShawnStarr (shawn-starr) wrote :

This is with colony 4.. Still not using right kernel driver. Not fixed yet.

Jeff Bailey (jbailey) wrote :

(In reply to comment #9)
> This is with colony 4.. Still not using right kernel driver. Not fixed yet.

Ben, the PCI ID is claimed by both drivers:

alias pci:v00001077d00001020sv*sd*bc*sc*i* qla1280
alias pci:v00001077d00001020sv*sd*bc*sc*i* qlogicisp

Should the qlogicisp module just be removed from stock kernels? I see that it's
not present in the amd64 kernel (although it is present on i686 and ppc64-smp)

Or should I add in whitelisting/blacklisting of some sort? What's generally the
right thing where two drivers claim the same PCI address?

Reassigning to initramfs-tools from initrd-tools for now.

Tks,
Jeff Bailey

ShawnStarr (shawn-starr) wrote :

Raising Severity to Critical. He still cannot install Ubuntu on machine. I know
this will take some time to resolve however. But this may affect other hardware
that may also experience sharing of PCI ID.

alias pci:v00001077d00001020sv*sd*bc*sc*i* qla1280
alias pci:v00001077d00001020sv*sd*bc*sc*i* qlogicisp

Is there not a subvendor PCI ID (if its different than Qlogic) or some other
marker we can use to distinguish the two?

Im also following the Debian folks, there is no resolution so, perhaps bump to
Ubuntu 6.04?

Matt Zimmerman (mdz) wrote :

What's the root issue here? If there are two potentially applicable drivers,
loading them both should be harmless. We necessarily do this in other cases
where we can't distinguish based on PCI ID.

If one of the drivers is causing a panic, then that's a bug in the kernel.
Please verify with the latest kernel in Breezy (2.6.12-9.23)

ShawnStarr (shawn-starr) wrote :

User has tried Fedora Core 4, no problem occuring. Correct kernel driver loaded. We should flip order of detection.

- Older drivers last, newer first.

ShawnStarr (shawn-starr) wrote :

My friend will try this with Ubuntu Breezy final CD. If this still occurs, will move bug to kernel area.

Adam Conrad (adconrad) wrote :

This should have been fixed long ago in dapper (or even in breezy final, it's hard to tell for sure). Closing it, please reopen (with recent ouput from a dapper kernel) if you can still reproduce it.

Changed in initramfs-tools:
status: Unconfirmed → Fix Released
Changed in initramfs-tools:
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.