Root lvm lv mounted with wrong name

Bug #1513272 reported by Phillip Susi on 2015-11-05
24
This bug affects 5 people
Affects Status Importance Assigned to Milestone
initramfs-tools (Debian)
Fix Released
Unknown
initramfs-tools (Ubuntu)
Undecided
Unassigned

Bug Description

In 15.04 and before, my root showed up in mound/findmnt/etc as /dev/vg/root, but now it shows up as /dev/dm-11. This appears to be due to the following new code in scripts/local:

ROOT=$(resolve_device "$ROOT")

This resolves the symbolic link /dev/vg/lv to /dev/dm-xx and mounts that instead. It should not be doing this.

Changed in initramfs-tools (Debian):
status: Unknown → New
Phillip Susi (psusi) on 2015-11-05
tags: added: regression-release
Changed in initramfs-tools (Debian):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in initramfs-tools (Ubuntu):
status: New → Confirmed
James Dennis (jtmes) wrote :

Seeing this change of behavior on Ubuntu 14.04.4

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.