Comment 22 for bug 1509769

Lepe (alepe-com) wrote :

It happened to me when updating 2 x Raspberry Pi 2B from 14.04 to 15.10.

The solution is to add:

Machine: Raspberry pi 2 Model B
Machine: BCM2709
Kernel-Flavors: rpi2
Boot-Kernel-Path: /boot/firmware/kernel7.img

(source: https://gist.github.com/shawnbon206/b38138874f1d32feb653)

Into: /usr/share/flash-kernel/db/all.db b/rpi2/usr/share/flash-kernel/db/all.db
(requires root permissions)

Then issue:
# flash-kernel
Will print:
> flash-kernel: installing version 3.18.0-25-rpi2

After rebooting, its working fine:
$ uname -a
> Linux ubuntu 3.18.0-25-rpi2 #26-Ubuntu SMP PREEMPT Sun Jul 5 06:46:34 UTC 2015 armv7l armv7l armv7l GNU/Linux

$ cat /etc/lsb-release
> DISTRIB_ID=Ubuntu
> DISTRIB_RELEASE=15.10
> DISTRIB_CODENAME=wily
> DISTRIB_DESCRIPTION="Ubuntu 15.10"