package initramfs-tools 0.103ubuntu4.2 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1

Bug #1388353 reported by 1nv4d3r89 on 2014-11-01
70
This bug affects 15 people
Affects Status Importance Assigned to Milestone
initramfs-tools (Ubuntu)
Undecided
yousuf

Bug Description

I just was updating package's
package initramfs-tools 0.103ubuntu4.2 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1

ProblemType: Package
DistroRelease: Ubuntu 14.04
Package: initramfs-tools 0.103ubuntu4.2
ProcVersionSignature: Ubuntu 3.13.0-37.64-generic 3.13.11.7
Uname: Linux 3.13.0-37-generic x86_64
ApportVersion: 2.14.1-0ubuntu3.6
Architecture: amd64
Date: Sat Nov 1 13:19:01 2014
DuplicateSignature: package:initramfs-tools:0.103ubuntu4.2:subprocess installed post-installation script returned error exit status 1
ErrorMessage: subprocess installed post-installation script returned error exit status 1
InstallationDate: Installed on 2014-07-17 (106 days ago)
InstallationMedia: Ubuntu-GNOME 14.04 LTS "Trusty Tahr" - Release amd64 (20140715)
PackageArchitecture: all
SourcePackage: initramfs-tools
SystemImageInfo:
 current build number: 0
 device name:
 channel: daily
 last update: Unknown
Title: package initramfs-tools 0.103ubuntu4.2 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1
UpgradeStatus: No upgrade log present (probably fresh install)

1nv4d3r89 (inja-kasist-penhan) wrote :
tags: removed: need-duplicate-check
Tim (cojavajedi) wrote :

Happened to me too, because my /boot was full.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in initramfs-tools (Ubuntu):
status: New → Confirmed
Stephen Brandt (brandt-stephen) wrote :

If there was an easy way (graphic interface) to delete/skip/add packages, or units, I would attempt to upgrade whatever would fit in the existing area.

yousuf (yosuf789) on 2015-01-12
Changed in initramfs-tools (Ubuntu):
assignee: nobody → yousuf (yosuf789)

sudo apt-get install --reinstall initramfs-tools
worked for me.

sudo apt-get install --reinstall initramfs-tools
then rebooting
worked for me.

Tony (simtybrut) wrote :

I am getting a report that \boot folder does not have enough memory. How can I increase memory allocated to this folder so I can do an update? I have a lot of Hard Drive space available, and I would like to be able to update this software.

Also, is there a disk cleanup program available, as I am not allowed to access anything in \boot to clean up as the error prompt recommends.

Thanks
Tony Anderson

<email address hidden>

Changed in initramfs-tools (Ubuntu):
status: Confirmed → Invalid
Brent Baccala (baccala) wrote :

I saw this symptom, but for a different reason.

Installing and removing initramfs-tools-ubuntu-touch removes /usr/sbin/flash-touch-initrd, but leaves the script /etc/initramfs/post-update.d/zz-flash-touch-initrd, which attempts to call /usr/sbin/flash-touch-initrd and fails.

My solution was to purge, not simply remove, initramfs-tools-ubuntu-touch.

Ryan (cooperrc84) wrote :

My initramfs-tools seems to be part of the problem too:
sudo apt-get install --reinstall initramfs-tools
> E: Internal Error, No file name for initramfs-tools:amd64

sudo apt-get install initramfs-tools
> subprocess installed post-installation script returned error exit status 1
> Errors were encountered while processing:
> linux-image-3.13.0-55-generic
> linux-image-extra-3.13.0-55-generic
> linux-image-generic
> initramfs-tools
>E: Sub-process /usr/bin/dpkg returned an error code (1)

/boot is just too small by default for the number of kernels kept if you are setting up Ubuntu 14.04 with encrypted disks.

I convert this back to a bug. If you install Ubuntu 14.04 with encrypted disks, /boot is only 236M big. This is barely enough to keep 4 kernel versions. So either increase the default size of /boot so it can hold the number of old kernels, Ubuntu keeps by default or lower the number of old kernels, Ubuntu keeps by default to 2-3.

Changed in initramfs-tools (Ubuntu):
status: Invalid → Confirmed
lonnie toney (ltoney999) wrote :

please tell me how to get more space in boot

Changed in initramfs-tools (Ubuntu):
status: Confirmed → Invalid

Easiest is to use Ubuntu Tweak's janitor function.

Harder is to manually resize boot partitition bigger at install time.

Hardest is making a backupand resizing partitions after installation.

I got the same error on my system when running
apt-get install --reinstall initramfs-tools

By running
apt-get install initramfs-tools
it complained of not being able to create a file called /var/tmp/mkinitramfs-FW_XXXXXX
This was because the folder
/var/tmp
didn't exist... I recreated that and both commands above worked fine again

Pavlushka (pavelsayekat) wrote :

update-initramfs: Generating /boot/initrd.img-3.13.0-77-generic
/etc/initramfs/post-update.d//zz-flash-touch-initrd: 9: /etc/initramfs/post-update.d//zz-flash-touch-initrd: /usr/sbin/flash-touch-initrd: not found
run-parts: /etc/initramfs/post-update.d//zz-flash-touch-initrd exited with return code 127
 as i removed the ubuntu-touch-generic-initrd after package upgrades.

Pavlushka (pavelsayekat) wrote :

Running Ubuntu-14.0.3:amd64 Linux 3.13.0-77-generic, tried all the answers but didn't work, getting this bug after package upgrade on 20-02-16, even purging initramfs-tools didn't work. So now I am running on 3.13.0-76 kernel.

jerry lucas (4-jerry-b) wrote :

Been getting this bug for about a year now and no solution in sight. Tried all the suggestions and no go. Traditionally the LINUX boot sector has been small. This isa general problem that should have been fixed long ago.

go to /etc/initramfs-tools/update-initramfs.conf and disable update, worked
for me for ubuntu 14.04.4 and in xenial beta, it didn't bothered. but first
i had to rescue my system bcoz the tool had already broken the initrd
img, good luck.
On Mar 20, 2016 7:50 PM, "jerry lucas" <email address hidden> wrote:

> Been getting this bug for about a year now and no solution in sight.
> Tried all the suggestions and no go. Traditionally the LINUX boot
> sector has been small. This isa general problem that should have been
> fixed long ago.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1388353
>
> Title:
> package initramfs-tools 0.103ubuntu4.2 failed to install/upgrade:
> subprocess installed post-installation script returned error exit
> status 1
>
> Status in initramfs-tools package in Ubuntu:
> Invalid
>
> Bug description:
> I just was updating package's
> package initramfs-tools 0.103ubuntu4.2 failed to install/upgrade:
> subprocess installed post-installation script returned error exit status 1
>
> ProblemType: Package
> DistroRelease: Ubuntu 14.04
> Package: initramfs-tools 0.103ubuntu4.2
> ProcVersionSignature: Ubuntu 3.13.0-37.64-generic 3.13.11.7
> Uname: Linux 3.13.0-37-generic x86_64
> ApportVersion: 2.14.1-0ubuntu3.6
> Architecture: amd64
> Date: Sat Nov 1 13:19:01 2014
> DuplicateSignature: package:initramfs-tools:0.103ubuntu4.2:subprocess
> installed post-installation script returned error exit status 1
> ErrorMessage: subprocess installed post-installation script returned
> error exit status 1
> InstallationDate: Installed on 2014-07-17 (106 days ago)
> InstallationMedia: Ubuntu-GNOME 14.04 LTS "Trusty Tahr" - Release amd64
> (20140715)
> PackageArchitecture: all
> SourcePackage: initramfs-tools
> SystemImageInfo:
> current build number: 0
> device name:
> channel: daily
> last update: Unknown
> Title: package initramfs-tools 0.103ubuntu4.2 failed to install/upgrade:
> subprocess installed post-installation script returned error exit status 1
> UpgradeStatus: No upgrade log present (probably fresh install)
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/initramfs-tools/+bug/1388353/+subscriptions
>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers