Unable to mount root fs after upgrade to 2.6.22-11.32

Bug #138325 reported by Brian Pitts on 2007-09-08
26
This bug affects 3 people
Affects Status Importance Assigned to Milestone
initramfs-tools (Ubuntu)
High
Unassigned
Declined for Gutsy by Andy Whitcroft

Bug Description

Binary package hint: linux-source-2.6.22

Dist-upgraded a month ago on an Inspiron 1420N from Dell's feisty to gutsy. After a dist-upgrade and reboot this morning

VFS: Cannot open root devide "UUID=..." or unknown-block(0,0)
Please append a correct "root=" boot option; here are the available partitions:
kernel panic - not syncing: VFS: unable to mount root fs on unknown-block(0,0)

I removed the UUID from above. The available partitions list was empty. Running 2.6.20-16-generic now without problems

Brian Pitts (bpitts) wrote :

The autogenerated /boot/grub/menu.lst lacked initrd entries for the new kernel. Adding these solved the problem.

Amit Kucheria (amitk) on 2007-09-12
Changed in linux-source-2.6.22:
importance: Undecided → Medium
Mark Reitblatt (mark-reitblatt) wrote :

I had this same problem happen to me, except on a new install. I noticed that update-initramfs failed initially because of a typo in /etc/initramfs-tools/conf.d/resume:
RESUME=/dev/sdb5\040(delete)
It complained about the '(' so I deleted the whole "(delete)" thing. Ran update-initramfs and added the line to the boot options and it worked fine.

Changed in linux-source-2.6.22:
importance: Medium → High
status: New → Triaged
Mark Reitblatt (mark-reitblatt) wrote :

This might be a HW specific bug, so for the record this is on a Thinkpad X61, so Santa Rosa chipset.

Changed in initramfs-tools:
status: Triaged → Confirmed
Vertago1 (vertago1) wrote :

I had this same problem when doing an update via the internet. My update process kept closing after it downloaded the packages without applying them. I ended up applying them using adept updater, since the repositories had been changed. Adept crashed about halfway through and I had to run dpkg --configure -a. Afterwards I rebooted and kernel 2.6.22 wouldn't boot with the same error above. I ended up running kernel 2.6.20 then I installed the generic kernel modules for 2.6.22 from gutsy universe which hadn't been installed and rebooted with no problem.

I came to this solution after trying the solutions other people had posted involving initrd-tools with no effect.

rickyrockrat (rickyrockrat) wrote :

This happens on Gutsy, x86_64 intel and on fiesty, x86_64 intel.

I followed instructions to temporarily add the hardy archive to get the new kernel via apt-get. On both machines, the package gave me the WRONG uuid, on all my installed kernels in the menu.lst file.

I had to boot to a finnix CD, and have it generate the correct uuids then replaced what APT or is it the package fault? did to me.

schmeii (schmeii) wrote :

I have the same bug when updating hardy to intrepid (beta). A fresh install is just fine.
I also noticed that the grub entries titles are Debian instead of Ubuntu.

abdulmajeed (abmjeed) on 2013-10-06
Changed in initramfs-tools (Ubuntu):
status: Confirmed → In Progress
Andy Whitcroft (apw) wrote :

I believe this this is a stale bug, the version in question is long since gone. If this is reproducible in recent kernels please do reopen. Thank.s

Changed in initramfs-tools (Ubuntu):
status: In Progress → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers