initramfs-tools ROOTDELAY too low, box drops into shell during boot

Bug #1326199 reported by Anton Blanchard on 2014-06-04
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
initramfs-tools (Ubuntu)
Undecided
Adam Conrad
Trusty
Undecided
Adam Conrad

Bug Description

[Impact]
See original description.

[Test Case]
Install updated packages on an affected ppc machine, update-initramfs -u, reboot without any special rootdelay set on the cmdline, watch it not fail to boot.

[Regression Potential]
This is already tested locally by Anton, so barring me having made a typo in the uploaded version, the potential for new bugs is pretty much nil. Bumping the rootdelay to 180 (from 30) could be seen as a regression in itself, as people who are legitimately failing to find a root device will have to wait that much longer to get dropped to a shell to investigate, which is why I limited the fix to PPC only for now.

[Other Info]
A better long-term fix would be to make scripts/local (or wait-for-root) a bit smarter and learn about specific driver quirks and multipath devices, etc, as IPR controllers can't be the only place we see this bug, and it would be nice to have backoff in cases where we expect delays, but quicker failure modes in cases when we don't.

[Original Description]
After installing Trusty on a ppc64el box, each boot drops into a shell because we aren't waiting long enough for the root device:

Gave up waiting for root device. Common problems:
 - Boot args (cat /proc/cmdline)
   - Check rootdelay= (did the system wait long enough?)
   - Check root= (did the system wait for the right device?)
 - Missing modules (cat /proc/modules; ls /dev)
ALERT! /dev/disk/by-uuid/d55ef64e-2d0c-4a51-9c6f-20999ee0276e does not exist. Dropping to a shell!

The dmesg shows the device appeared at 49 seconds:

[ 49.367749] sdb: sdb1 sdb2 sdb3

I could fix this by overriding ROOTDELAY on the command line:

rootdelay=180

Could we get ROOTDELAY in initramfs-tools bumped for ppc64el?

tags: added: ppc64el
Adam Conrad (adconrad) on 2014-06-04
affects: initramfs-tools → initramfs-tools (Ubuntu)
Changed in initramfs-tools (Ubuntu):
assignee: nobody → Adam Conrad (adconrad)
Changed in initramfs-tools (Ubuntu Trusty):
assignee: nobody → Adam Conrad (adconrad)
Adam Conrad (adconrad) on 2014-06-04
Changed in initramfs-tools (Ubuntu):
status: New → In Progress
Changed in initramfs-tools (Ubuntu Trusty):
status: New → In Progress
Adam Conrad (adconrad) on 2014-06-04
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package initramfs-tools - 0.103ubuntu7

---------------
initramfs-tools (0.103ubuntu7) utopic; urgency=medium

  * Default to a rootdelay of 180 on powerpc/ppc64/ppc64el to account
    for the slower device discovery on IPR controllers (LP: #1326199)
 -- Adam Conrad <email address hidden> Tue, 03 Jun 2014 21:39:01 -0600

Changed in initramfs-tools (Ubuntu):
status: In Progress → Fix Released

Hello Anton, or anyone else affected,

Accepted initramfs-tools into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/initramfs-tools/0.103ubuntu4.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in initramfs-tools (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed
Zhao Er Tao (ertaozh) wrote :

I had updated my local mirror for initramfs-tools with the latest pkgs, but it seems that the initramfs prompt problem still wasn't fixed.
My idea is that the two files may need to packages into ubuntu 14.04 LE OS images since I notice that the object system doesn't get the two file from my local mirror. Am I right?

-rw-r--r-- 1 root root 44K Jun 5 09:06 initramfs-tools_0.103ubuntu4.2_all.deb
-rw-r--r-- 1 root root 8.7K Jun 5 09:06 initramfs-tools-bin_0.103ubuntu4.2_ppc64el.deb

Brian Murray (brian-murray) wrote :

The fix for this bug is in the architecture all package, so you need to install initramfs-tools_0.103ubuntu4.2_all.deb and initramfs-tools-bin_0.103ubuntu4.2_ppc64el.deb.

Zhao Er Tao (ertaozh) wrote :

You mean I need to type 'exit' to exit from initramfs prompt and go into the system, then install the two files manually. This issue will not occur in next reboot?

Anton Blanchard (anton-samba) wrote :

Thanks Adam and Stéphane.

I tested 0.103ubuntu4.2 and it fixed this issue.

tags: added: verification-done
removed: verification-needed
Anton Blanchard (anton-samba) wrote :

I worked with Er Tao and can confirm it fixes his issue too.

Breno Leitão (breno-leitao) wrote :

Closing the bug per previous comments.

Changed in initramfs-tools (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for initramfs-tools has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers