/init: line 327: egrep: not found

Bug #1315755 reported by Sworddragon on 2014-05-03
80
This bug affects 17 people
Affects Status Importance Assigned to Milestone
initramfs-tools (Ubuntu)
High
Dimitri John Ledkov
Trusty
High
Unassigned
Utopic
High
Dimitri John Ledkov

Bug Description

I'm using Ubuntu 14.10 dev with upstart 1.12.1-0ubuntu4 and on every boot I'm seeing the message "/init: line 327: egrep: not found" but egrep is installed on my system:

sworddragon@ubuntu:~$ egrep -V
egrep (GNU grep) 2.18
Copyright (C) 2014 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>.
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.

Written by Mike Haertel and others, see <http://git.sv.gnu.org/cgit/grep.git/tree/AUTHORS>.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in upstart (Ubuntu):
status: New → Confirmed
syscon-hh (syscon-kono) wrote :

This bug was introduced by upgrade the packages
 * busybox-initramfs
 * busybox-static
from issue "1.22.0-5ubuntu1" to "1.22-0-6ubuntu1"

Downgrade to the mentioned former version (anymore available in the archives, but stored localy) or to "1.21.0-1ubuntu1" followed by
 * "sudo update-initramfs -u"
eliminates the bug described.

Changed in upstart (Ubuntu):
importance: Undecided → High
assignee: nobody → Dimitri John Ledkov (xnox)
Changed in upstart (Ubuntu Trusty):
assignee: nobody → Dimitri John Ledkov (xnox)
status: New → Confirmed
importance: Undecided → High
Changed in upstart (Ubuntu Trusty):
assignee: Dimitri John Ledkov (xnox) → nobody
Changed in upstart (Ubuntu Utopic):
assignee: Dimitri John Ledkov (xnox) → nobody
affects: upstart (Ubuntu Utopic) → busybox (Ubuntu Utopic)
Changed in busybox (Ubuntu Utopic):
assignee: nobody → Dimitri John Ledkov (xnox)
Changed in busybox (Ubuntu Trusty):
status: Confirmed → Incomplete
Changed in busybox (Ubuntu Utopic):
status: Confirmed → Incomplete
assignee: Dimitri John Ledkov (xnox) → nobody
affects: busybox (Ubuntu Utopic) → initramfs-tools (Ubuntu Utopic)
Changed in initramfs-tools (Ubuntu Utopic):
status: Incomplete → In Progress
Changed in initramfs-tools (Ubuntu Trusty):
status: Incomplete → Triaged
assignee: nobody → Dimitri John Ledkov (xnox)
Changed in initramfs-tools (Ubuntu Utopic):
assignee: nobody → Dimitri John Ledkov (xnox)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package initramfs-tools - 0.103ubuntu6

---------------
initramfs-tools (0.103ubuntu6) utopic; urgency=medium

  * Create /bin/egrep -> busybox symlink, because initramfs-tools
    scripts/functions expect to have it & our busybox hook is executed
    after zz-busybox one. (LP: #1315755)
 -- Dimitri John Ledkov <email address hidden> Tue, 06 May 2014 21:30:41 +0100

Changed in initramfs-tools (Ubuntu Utopic):
status: In Progress → Fix Released
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1315755

tags: added: iso-testing
Adam Conrad (adconrad) on 2014-06-04
Changed in initramfs-tools (Ubuntu Trusty):
status: Triaged → Invalid
stsp (stsp-0) wrote :

This is a problem in Trusty too, if
BUSYBOX=n
in /etc/initramfs-tools/initramfs.conf.
Neither grep nor egrep seems to be added, so
the same error message appears.

Changed in initramfs-tools (Ubuntu Trusty):
status: Invalid → Confirmed
Changed in initramfs-tools (Ubuntu Trusty):
status: Confirmed → In Progress
Changed in initramfs-tools (Ubuntu Trusty):
assignee: Dimitri John Ledkov (xnox) → nobody

Hello Sworddragon, or anyone else affected,

Accepted initramfs-tools into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/initramfs-tools/0.103ubuntu4.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in initramfs-tools (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed
Dave Chiluk (chiluk) wrote :

I deployed a trusty vm, and checked the logs for the error, and did not see it so I'm marking this verification-done.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package initramfs-tools - 0.103ubuntu4.3

---------------
initramfs-tools (0.103ubuntu4.3) trusty; urgency=medium

  [ Dimitri John Ledkov ]

  * Create /bin/egrep -> busybox symlink, because initramfs-tools
    scripts/functions expect to have it & our busybox hook is executed
    after zz-busybox one. (LP: #1315755)

  [ Dave Chiluk]

  * Add resolve_device to initramfs-tools so that actual devices show up
    in df and /proc/self/mountinfo instead of the UUID symlink. This is
    a backport of commits f135e7cf, be18fee1, f1d6fb37 from
    git://git.launchpad.net/~ubuntu-kernel/ubuntu/+source/initramfs-tools
    (LP: #1535349)

 -- Andy Whitcroft <email address hidden> Thu, 25 Feb 2016 18:55:04 +0000

Changed in initramfs-tools (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for initramfs-tools has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers