busybox: can't access tty; job control turned off is misleading

Bug #129612 reported by Paul Dufresne on 2007-08-01
4
Affects Status Importance Assigned to Milestone
initramfs-tools (Ubuntu)
Undecided
Scott James Remnant (Canonical)

Bug Description

Binary package hint: casper

Well, first, I don't have seen this personally. As a bug triager, I found a bug with this description, but it seems that this
is not the problem reporter really cares about.

It make sense, busybox is just a small shell that came alive, only if an other problem happened.
And normally, that it the problem that caused busybox to be call that we care.

But there seems to be a bug in the way busybox is called, because some bug reports suggest that an
error message 'can't access tty; job control turned off' is given when busybox is called.

I suppose that then the shell is not accessible, and that it is harder to fix the real problem that caused
busybox to be called.

It seems many people get this error message, as can be seen on the forum:
http://ubuntuforums.org/showthread.php?t=415009&highlight=can%27t+access+tty

Seems that many people don't really understand that many many problems can cause busybox to be called, and give
this error message.

As I see this, this message error should not be shown.
What is supposed to happen, is to come to a # prompt where you can give commands, when an error happened with
the live cd which was not able to boot normally, for whatever reason.

Bug report that make me create this one was bug #127927.
Some other bugs showing this symptom are:
bug #78380, critical bug #106864, bug #93471, etc.

In fact my search for 'job control turned off' returns 81 results:
https://bugs.launchpad.net/ubuntu/+bugs?field.searchtext=job+control+turned+off&orderby=-importance&search=Search&field.status%3Alist=New&field.status%3Alist=Incomplete&field.status%3Alist=Confirmed&field.status%3Alist=Triaged&field.status%3Alist=In+Progress&field.status%3Alist=Fix+Committed&field.assignee=&field.bug_reporter=&field.omit_dupes=on&field.has_patch=&field.has_no_package=

Related branches

Paul Dufresne (paulduf) wrote :

Well, by reading bug #118561 I now realize that actually, the prompt is shown and working, making this bug pretty
low priority. (Make a lot confusion however).

So, as I understand, it seems best to ask people to 'cat /var/log/casper.log' and report unusual error in the result.
A bug suggest the following procedure to allow to mount a USB disk to copy casper.log (from bug #62679):
---
Please do:
set -x
. /scripts/casper
mountroot
and provide the output.

you should be able to connect and mount USB devices just fine at this stage.
---

Paul Dufresne (paulduf) wrote :

Just adding a note that bug #126335 is an other 'instance' of this one.

I thought I had already uploaded a fix for this

Changed in initramfs-tools:
assignee: nobody → keybuk
Colin Watson (cjwatson) wrote :

Moving milestone forward.

busybox (1:1.1.3-5ubuntu6) gutsy; urgency=low

  * Disable job control in the initramfs, it can never access the tty
    so always produces a confusing error message that people think is the
    real reason they're seeing the initramfs shell at all. LP: #129612.

 -- Scott James Remnant <email address hidden> Wed, 03 Oct 2007 16:59:01 +0100

Changed in initramfs-tools:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers