package initramfs-tools 0.99ubuntu13.4 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1

Bug #1256486 reported by Gabriel Barbieru on 2013-11-30
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
initramfs-tools (Ubuntu)
Undecided
Unassigned

Bug Description

was trying to install kubuntu-desktop with KDM

ProblemType: Package
DistroRelease: Ubuntu 12.04
Package: initramfs-tools 0.99ubuntu13.4
ProcVersionSignature: Ubuntu 3.8.0-33.48~precise1-generic 3.8.13.11
Uname: Linux 3.8.0-33-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.0.1-0ubuntu17.6
Architecture: amd64
Date: Sat Nov 30 11:26:01 2013
DuplicateSignature: package:initramfs-tools:0.99ubuntu13.4:subprocess installed post-installation script returned error exit status 1
ErrorMessage: subprocess installed post-installation script returned error exit status 1
InstallationMedia: Ubuntu 12.04.3 LTS "Precise Pangolin" - Release amd64 (20130820.1)
MarkForUpload: True
PackageArchitecture: all
SourcePackage: initramfs-tools
Title: package initramfs-tools 0.99ubuntu13.4 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1
UpgradeStatus: No upgrade log present (probably fresh install)

/boot was at 2% used. Despite that update manager failed with "Device out of space"

tags: removed: need-duplicate-check
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in initramfs-tools (Ubuntu):
status: New → Confirmed
description: updated
Jeff Vincent (jeffvincent) wrote :

I just had this happen when I had insufficient disk space on /boot. That doesn't seem to be your problem. However, I have also had a similar problem when there was enough disk space, but the file system had reached the limit for the maximum number of files allowed -- try looking into that. My solution was deleting old kernel files.

Andy Whitcroft (apw) wrote :

Processing triggers for initramfs-tools ...
update-initramfs: Generating /boot/initrd.img-3.8.0-33-generic
Warning: /dev/disk/by-id/ata-INTEL_SSDSC2CW120A3_CVCV2123011Z120BGN is not on the first disk
Fatal: No images have been defined.
run-parts: /etc/initramfs/post-update.d//runlilo exited with return code 1
dpkg: error processing initramfs-tools (--configure):
 subprocess installed post-installation script returned error exit status 1

Changed in initramfs-tools (Ubuntu):
status: Confirmed → Triaged
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers