package initramfs-tools 0.103ubuntu0.7 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1

Bug #1193500 reported by Houman on 2013-06-21
46
This bug affects 10 people
Affects Status Importance Assigned to Milestone
initramfs-tools (Ubuntu)
Undecided
Unassigned

Bug Description

When upgrading to gnome 3.8 via ppa.

sudo add-apt-repository ppa:gnome3-team/gnome3

sudo apt-get update && sudo apt-get install gnome-shell ubuntu-gnome-desktop

this is the error i am getting.

ProblemType: Package
DistroRelease: Ubuntu 13.04
Package: initramfs-tools 0.103ubuntu0.7
ProcVersionSignature: Ubuntu 3.8.0-25.37-generic 3.8.13
Uname: Linux 3.8.0-25-generic x86_64
ApportVersion: 2.9.2-0ubuntu8.1
Architecture: amd64
Date: Fri Jun 21 23:08:34 2013
DuplicateSignature: package:initramfs-tools:0.103ubuntu0.7:subprocess installed post-installation script returned error exit status 1
ErrorMessage: subprocess installed post-installation script returned error exit status 1
InstallationDate: Installed on 2013-06-21 (0 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Release amd64 (20130424)
MarkForUpload: True
PackageArchitecture: all
SourcePackage: initramfs-tools
Title: package initramfs-tools 0.103ubuntu0.7 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1
UpgradeStatus: No upgrade log present (probably fresh install)

Houman (houmie) wrote :
tags: removed: need-duplicate-check
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in initramfs-tools (Ubuntu):
status: New → Confirmed
Broomer68 (jbezemer) wrote :

difficulties to migrate from a failing nvidia to an ATI from the spare-parts-bin

Richard King (richieking1978) wrote :

Upgraded to 13.10 for experimental and mir checkup. Error occured with upgrading from 13.04 to 13.10 alpha.

Brian Murray (brian-murray) wrote :

This is because you have pango1.0 installed from a PPA which does not provide modules for which plymouth is looking. This is not something we, the developers of Ubuntu, can help you with.

Changed in initramfs-tools (Ubuntu):
status: Confirmed → Invalid
Adam Morris (adam-morris) wrote :

Sorry, but I am getting routed to this crash report and I don't have pango 1.0 installed from a PPA (at least as far as I can tell)

$ sudo dpkg -l | grep -i pango
ii gir1.2-coglpango-1.0 1.14.0-0ubuntu1 amd64 GObject introspection data for the CoglPango 1.0 library
ii gir1.2-pango-1.0 1.32.5-0ubuntu1 amd64 Layout and rendering of internationalized text - gir bindings
ii gstreamer0.10-x:amd64 0.10.36-1.1ubuntu1 amd64 GStreamer plugins for X11 and Pango
ii gstreamer0.10-x:i386 0.10.36-1.1ubuntu1 i386 GStreamer plugins for X11 and Pango
ii gstreamer1.0-x:amd64 1.0.6-1 amd64 GStreamer plugins for X11 and Pango
ii libcogl-pango12:amd64 1.14.0-0ubuntu1 amd64 Object oriented GL/GLES Abstraction/Utility Layer
ii libpango-perl 1.224-1 amd64 Perl module to layout and render international text
ii libpango1.0-0:amd64 1.32.5-0ubuntu1 amd64 Layout and rendering of internationalized text
ii libpango1.0-0:i386 1.32.5-0ubuntu1 i386 Layout and rendering of internationalized text
ii libpangomm-1.4-1:amd64 2.28.4-1ubuntu2 amd64 C++ Wrapper for pango (shared libraries)

Changed in initramfs-tools (Ubuntu):
status: Invalid → Confirmed
falcon7204 (falcon7204) wrote :

Affects installation of KDE Desktop Environment in Ubuntu 13.04 as well:

Processing triggers for libc-bin ...
ldconfig deferred processing now taking place
Processing triggers for ureadahead ...
Processing triggers for initramfs-tools ...
update-initramfs: Generating /boot/initrd.img-3.8.0-29-generic
cp: cannot stat ‘/module-files.d/libpango1.0-0.modules’: No such file or directory
cp: cannot stat ‘/modules/pango-basic-fc.so’: No such file or directory
E: /usr/share/initramfs-tools/hooks/plymouth failed with return 1.
update-initramfs: failed for /boot/initrd.img-3.8.0-29-generic with 1.
dpkg: error processing initramfs-tools (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 initramfs-tools
E: Sub-process /usr/bin/dpkg returned an error code (1)

Sir Malheur (sirmalheur) wrote :

Hello, here is a workaround that fixed the problem for me

###############################################
sudo rm -f /var/lib/dpkg/info/initramfs-tools.post*
sudo rm -f /var/lib/dpkg/info/initramfs-tools.pre*

sudo rm -f /var/lib/dpkg/info/bcmwl-kernel-source.post*
sudo rm -f /var/lib/dpkg/info/bcmwl-kernel-source.pre*

sudo dpkg --configure -a
###############################################

Source: http://ubuntuforums.org/showthread.php?t=1990236

Todd (dudemansomebody) wrote :

Heya.

I tried the above workaround, and it doesnt work for me. I have the following output:

######################################################

# myuser@09:30 Sat Oct 26:info$ sudo dpkg --configure -a

Setting up initramfs-tools (0.103ubuntu0.8) ...
Setting up linux-image-3.8.0-32-generic (3.8.0-32.47) ...
Running depmod.
update-initramfs: deferring update (hook will be called later)
Examining /etc/kernel/postinst.d.
run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 3.8.0-32-generic /boot/vmlinuz-3.8.0-32-generic
run-parts: executing /etc/kernel/postinst.d/dkms 3.8.0-32-generic /boot/vmlinuz-3.8.0-32-generic
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 3.8.0-32-generic /boot/vmlinuz-3.8.0-32-generic
update-initramfs: Generating /boot/initrd.img-3.8.0-32-generic
run-parts: executing /etc/kernel/postinst.d/pm-utils 3.8.0-32-generic /boot/vmlinuz-3.8.0-32-generic
run-parts: executing /etc/kernel/postinst.d/update-notifier 3.8.0-32-generic /boot/vmlinuz-3.8.0-32-generic
run-parts: executing /etc/kernel/postinst.d/zz-runlilo 3.8.0-32-generic /boot/vmlinuz-3.8.0-32-generic
Fatal: open /boot/vmlinuz-3.5.0-21-generic: No such file or directory
run-parts: /etc/kernel/postinst.d/zz-runlilo exited with return code 1
Failed to process /etc/kernel/postinst.d at /var/lib/dpkg/info/linux-image-3.8.0-32-generic.postinst line 1010.
dpkg: error processing linux-image-3.8.0-32-generic (--configure):
 subprocess installed post-installation script returned error exit status 2
dpkg: dependency problems prevent configuration of linux-image-extra-3.8.0-32-generic:
 linux-image-extra-3.8.0-32-generic depends on linux-image-3.8.0-32-generic; however:
  Package linux-image-3.8.0-32-generic is not configured yet.

dpkg: error processing linux-image-extra-3.8.0-32-generic (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-image-generic:
 linux-image-generic depends on linux-image-3.8.0-32-generic; however:
  Package linux-image-3.8.0-32-generic is not configured yet.
 linux-image-generic depends on linux-image-extra-3.8.0-32-generic; however:
  Package linux-image-extra-3.8.0-32-generic is not configured yet.

dpkg: error processing linux-image-generic (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-image-generic-pae:
 linux-image-generic-pae depends on linux-image-generic (= 3.8.0.32.50); however:
  Package linux-image-generic is not configured yet.

dpkg: error processing linux-image-generic-pae (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 linux-image-3.8.0-32-generic
 linux-image-extra-3.8.0-32-generic
 linux-image-generic
 linux-image-generic-pae

######################################################

Andy Whitcroft (apw) wrote :

Processing triggers for initramfs-tools ...
update-initramfs: Generating /boot/initrd.img-3.8.0-25-generic
cp: cannot stat ‘/module-files.d/libpango1.0-0.modules’: No such file or directory
cp: cannot stat ‘/modules/pango-basic-fc.so’: No such file or directory
E: /usr/share/initramfs-tools/hooks/plymouth failed with return 1.
update-initramfs: failed for /boot/initrd.img-3.8.0-25-generic with 1.
dpkg: error processing initramfs-tools (--configure):

Changed in initramfs-tools (Ubuntu):
status: Confirmed → Triaged
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers