package initramfs-tools 0.103ubuntu0.1 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1 on Toshiba AC100 with 12.10 alpha

Bug #1035647 reported by Johan Ehnberg
36
This bug affects 8 people
Affects Status Importance Assigned to Milestone
initramfs-tools (Ubuntu)
Triaged
Undecided
Unassigned

Bug Description

The post install trigger in /etc/initramfs/post-update.d/flash-kernel said no Android boot partition could be found.

It seems caused by the removed abootimg through 'apt-get autoremove.' This was after a clean install followed by a 'apt-get dist-upgrade', so it should not happen.

Likely it would make sense to have abootimg a dependency somewhere in what is installed by default.

ProblemType: Package
DistroRelease: Ubuntu 12.10
Package: initramfs-tools 0.103ubuntu0.1
Uname: Linux 3.1.10-4-ac100 armv7l
ApportVersion: 2.4-0ubuntu6
Architecture: armhf
Date: Sat Aug 11 17:39:36 2012
ErrorMessage: subprocess installed post-installation script returned error exit status 1
PackageArchitecture: all
SourcePackage: initramfs-tools
Title: package initramfs-tools 0.103ubuntu0.1 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Johan Ehnberg (johan-ehnberg) wrote :
Revision history for this message
Dr. Azrael Tod (i41b-launchpad-net-hpgu) wrote :

had the same problem, reinstalling abootimg fixed it

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in initramfs-tools (Ubuntu):
status: New → Confirmed
Revision history for this message
Andy Whitcroft (apw) wrote :

Processing triggers for initramfs-tools ...
update-initramfs: Generating /boot/initrd.img-3.1.10-4-ac100
flash-kernel: installing version 3.1.10-4-ac100
Couldn't find Android boot partition on /dev/mmcblk0
run-parts: /etc/initramfs/post-update.d//flash-kernel exited with return code 1
dpkg: error processing initramfs-tools (--remove):
 subprocess installed post-installation script returned error exit status 1

Changed in initramfs-tools (Ubuntu):
status: Confirmed → Triaged
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers