New helpers version fail on "unknown initscript"

Bug #1543051 reported by Michał Sawicz
24
This bug affects 2 people
Affects Status Importance Assigned to Milestone
init-system-helpers (Ubuntu)
Fix Released
High
Martin Pitt

Bug Description

On version 1.26:

invoke-rc.d: unknown initscript, /etc/init.d/ofono not found.
Running in chroot, ignoring request.
invoke-rc.d: policy-rc.d denied execution of start.

And happily continues.

On version 1.28, however:
invoke-rc.d: unknown initscript, /etc/init.d/ofono not found.
dpkg: error processing package ofono (--configure):
 subprocess installed post-installation script returned error exit status 100

While this might be an ofono issue, the behaviour change causes previously working packages to be uninstallable.

First noticed in buildd:
https://launchpadlibrarian.net/236956211/buildlog_ubuntu-xenial-amd64.unity8_8.11+16.04.20160208-0ubuntu1_BUILDING.txt.gz

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: init-system-helpers 1.28ubuntu1
ProcVersionSignature: Ubuntu 4.4.0-2.16-generic 4.4.0
Uname: Linux 4.4.0-2-generic x86_64
ApportVersion: 2.19.4-0ubuntu2
Architecture: amd64
CurrentDesktop: Unity
Date: Mon Feb 8 11:25:36 2016
PackageArchitecture: all
SourcePackage: init-system-helpers
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Michał Sawicz (saviq) wrote :
Revision history for this message
Martin Pitt (pitti) wrote :

I tried to reproduce this in a current xenial schroot (with policy-rc.d) and VM, and apt-get install ofono works in both cases. In the build log this happens while upgrading init-system-helpers as well, though, which might have an influence on this.

Changed in init-system-helpers (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
Revision history for this message
Martin Pitt (pitti) wrote :

I now downloaded the current xenial/amd64 Launchpad chroot tarball (which is really still wily), dist-upgraded that, and installed ofono, and I can reproduce the regression with that.

Changed in init-system-helpers (Ubuntu):
status: New → In Progress
importance: Undecided → High
Revision history for this message
Martin Pitt (pitti) wrote :

Fix committed to Debian master branch: http://anonscm.debian.org/cgit/collab-maint/init-system-helpers.git/commit/?id=628cb4328

Will backport to xenial.

Changed in init-system-helpers (Ubuntu):
assignee: Martin Pitt (pitti) → nobody
status: In Progress → Fix Committed
assignee: nobody → Martin Pitt (pitti)
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package init-system-helpers - 1.28ubuntu2

---------------
init-system-helpers (1.28ubuntu2) xenial; urgency=medium

  * invoke-rc.d: Fix package installation failure when installing a package
    with an upstart script and systemd unit, but no SysV script in a chroot.
    (LP: #1543051)

 -- Martin Pitt <email address hidden> Mon, 08 Feb 2016 12:48:13 +0100

Changed in init-system-helpers (Ubuntu):
status: Fix Committed → Fix Released
Revision history for this message
cobraking1993 (padmanagrajan) wrote :

Hi,

Here I am having a doubt, I am having a ltsp-chroot environment. and I am trying to install openssh-server in it, and I have got some waring message there as follows.
" Running in chroot, ignoring request.
invoke-rc.d: policy-rc.d denied execution of restart."
When I checked the ltsp-client I haven't get the ssh startup script there. Is there anything I need to done with the "init-system-helpers".

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers