package init-system-helpers 1.22ubuntu4 failed to install/upgrade: trying to overwrite '/lib/init/apparmor-profile-load', which is also in package upstart-bin 1.13.2-0ubuntu9

Bug #1439988 reported by fcole90
66
This bug affects 10 people
Affects Status Importance Assigned to Milestone
init-system-helpers (Ubuntu)
Fix Released
High
Robie Basak

Bug Description

x

ProblemType: Package
DistroRelease: Ubuntu 15.04
Package: init-system-helpers 1.22ubuntu4
ProcVersionSignature: Ubuntu 3.19.0-9.9-generic 3.19.1
Uname: Linux 3.19.0-9-generic x86_64
ApportVersion: 2.16.2-0ubuntu4
Architecture: amd64
Date: Fri Apr 3 10:20:08 2015
DpkgTerminalLog:
 Preparing to unpack .../init-system-helpers_1.22ubuntu6_all.deb ...
 Unpacking init-system-helpers (1.22ubuntu6) over (1.22ubuntu4) ...
 dpkg: error processing archive /var/cache/apt/archives/init-system-helpers_1.22ubuntu6_all.deb (--unpack):
  trying to overwrite '/lib/init/apparmor-profile-load', which is also in package upstart-bin 1.13.2-0ubuntu9
DuplicateSignature: package:init-system-helpers:1.22ubuntu4:trying to overwrite '/lib/init/apparmor-profile-load', which is also in package upstart-bin 1.13.2-0ubuntu9
ErrorMessage: trying to overwrite '/lib/init/apparmor-profile-load', which is also in package upstart-bin 1.13.2-0ubuntu9
InstallationDate: Installed on 2015-03-21 (12 days ago)
InstallationMedia: Ubuntu 15.04 "Vivid Vervet" - Alpha amd64 (20150321)
PackageArchitecture: all
RelatedPackageVersions:
 dpkg 1.17.24ubuntu1
 apt 1.0.9.7ubuntu3
SourcePackage: init-system-helpers
Title: package init-system-helpers 1.22ubuntu4 failed to install/upgrade: trying to overwrite '/lib/init/apparmor-profile-load', which is also in package upstart-bin 1.13.2-0ubuntu9
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
fcole90 (fcole90) wrote :
Revision history for this message
dino99 (9d9) wrote :

your system is not fully updated: you should have upstart-bin 1.13.2-0ubuntu11 & init-system-helpers 1.22ubuntu6

switch to 'main' server if you are updating from a local mirror

tags: removed: need-duplicate-check
dino99 (9d9)
Changed in init-system-helpers (Ubuntu):
status: New → Invalid
Revision history for this message
Manoj Iyer (manjo) wrote :

updating from http://us.archive.ubuntu.com/ubuntu/ vivid main I get the same error.

Revision history for this message
Gustav Ekner (gustav-ekner) wrote :

I get the same error.

Changed in init-system-helpers (Ubuntu):
status: Invalid → New
Revision history for this message
dino99 (9d9) wrote :

@Gustav @manjo

which are your packages version ? have you third party installed ?

you should have these now:
https://launchpad.net/ubuntu/+source/init-system-helpers
https://launchpad.net/ubuntu/+source/upstart

Changed in init-system-helpers (Ubuntu):
status: New → Incomplete
Revision history for this message
TitanKing (titan-phpdevshell) wrote :

I have the same issue:

Processing triggers for man-db (2.7.0.2-5) ...
Errors were encountered while processing:
 /var/cache/apt/archives/init-system-helpers_1.22ubuntu6_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

I tried different repo servers.

Revision history for this message
Michael Bienia (geser) wrote :

Happened to me too when I updated my vivid system after a few weeks again.

I still have upstart-bin (1.13.2-0ubuntu9) from before the transition to upstart installed and tried to upgrade it.

init-system-helpers has a Replaces/Breaks on the transitioned upstart package but not on the upstart-bin from before the transition. Trying to upgrade upstart-bin first doesn't work as this pulls init-system-helpers too and apt tries to upgrade init-system-helpers before upstart-bin.

init-system-helpers should also get a Replaces/Breaks on the old upstart-bin package. I assume upgrades from utopic (which have upstart-bin with files) to vivid are also affected by this.

Changed in init-system-helpers (Ubuntu):
status: Incomplete → Confirmed
Changed in init-system-helpers (Ubuntu):
importance: Undecided → High
Revision history for this message
Robie Basak (racb) wrote :

> init-system-helpers should also get a Replaces/Breaks on the old upstart-bin package.

Right. But instead it Breaks/Replaces upstart instead, which is wrong. This mistake was accidentally uploaded because of some coordination issues. Confusingly both upstart-bin 1.13.2-0ubuntu9 and upstart 1.13.2-0ubuntu9 shipped /lib/init/apparmor-profile-load, so I'll just declare Breaks/Replaces against both.

Changed in init-system-helpers (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Robie Basak (racb)
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package init-system-helpers - 1.22ubuntu8

---------------
init-system-helpers (1.22ubuntu8) vivid; urgency=medium

  * Make init "Essential: yes" again, it's the only way to guarantee a
    sane upgrade path for people without ubuntu-minimal (LP: #1436956)
 -- Adam Conrad <email address hidden> Tue, 07 Apr 2015 10:27:59 -0600

Changed in init-system-helpers (Ubuntu):
status: In Progress → Fix Released
Revision history for this message
Bart Janssens (bartholomeus-j) wrote :

I can confirm that the problem is resolved for me on a vivid install.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers