indicator-printers not working on Ubuntu 14.04

Bug #1304434 reported by antidopinguser on 2014-04-08
320
This bug affects 66 people
Affects Status Importance Assigned to Milestone
Print Indicator
In Progress
Undecided
Lars Karlitski
indicators-client (Ubuntu)
High
Unassigned
Trusty
High
Unassigned

Bug Description

[Impact]
The panel should have a print indicator as long as there are any print jobs queued or processed. Currently, this indicator never appears, even though printing works fine.

This is because the service that listens to CUPS fails to register its D-Bus name (as of revision 68), which results in the panel component not finding the service. The attached branch fixes this by making the service register the name the panel expects.

[Test Case]
Print a document from any application and check whether the print indicator appears while it is printing.

[Regression Potential]
Almost none. The print indicator is not working at all right now, and the fix only touches that indicator.

[Original Description]
even after lates updates still no printer notifications in the panel . I checked and the package "indicator-printers" is correctly installed and the printer prints without problems. But, there is no notification icons on unity panel. I had no problems at all with 13.10 instead

Related branches

Jiang.Qian (jiang-qian-gmail) wrote :

I can confirm this bug is here, running the latest ubuntu 14.04 daily built, updated every day.
I tried to start it manually by:
/usr/lib/i386-linux-gnu/indicator-printers/indicator-printers-service
but when I print still now indicators show up.
I am in gnome flashback with metacity, not compiz.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xorg-server (Ubuntu):
status: New → Confirmed
Talha Kabakuş (talhakabakus) wrote :

having same issue.

Peter Sewell (peter-sewell) wrote :

Yes, this is affecting me too.

JW (jweill35) wrote :

Same here

asala (asala) wrote :

Changed affected package from xorg-server to Indicator-printer... I'm no devel, but, well, sure it's not the X server.

affects: xorg-server (Ubuntu) → indicator-printers (Ubuntu)

fortunately i switched to chromeos

2014-04-30 18:09 GMT+02:00 asala <email address hidden>:

> Changed affected package from xorg-server to Indicator-printer... I'm no
> devel, but, well, sure it's not the X server.
>
> ** Package changed: xorg-server (Ubuntu) => indicator-printers (Ubuntu)
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1304434
>
> Title:
> indicator-printers not working on ubuntu 14.04 beta
>
> Status in “indicator-printers” package in Ubuntu:
> Confirmed
>
> Bug description:
> even after lates updates still no printer notifications in the panel .
> I checked and the package "indicator-printers" is correctly installed
> and the printer prints without problems. But, there is no notification
> icons on unity panel. I had no problems at all with 13.10 instead
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/indicator-printers/+bug/1304434/+subscriptions
>

Ubuntu 14.04 LTS still having this issue.

Thomas Hood (jdthood) on 2014-05-03
summary: - indicator-printers not working on ubuntu 14.04 beta
+ indicator-printers not working on Ubuntu 14.04

Waiting for a solution, I found this: download this applet (it's originally for KDE): https://launchpad.net/ubuntu/trusty/amd64/indicator-printers/0.1.7+14.04.20140313-0ubuntu1
and add "printer-applet" to start with ubuntu. This works for me, ubuntu 14.04 64 bits.

Aibara Iduas (aibaraiduas) wrote :

@fifilecanari - That link is just to the standard indicator applet, nothing to do with KDE.

no longer affects: indicator-printers
affects: indicator-printers → unity
Lars Karlitski (larsu) wrote :

Sorry about that bug. I wonder how it even got through unnoticed.

affects: unity → indicator-printers
Changed in indicator-printers:
status: New → In Progress
assignee: nobody → Lars Uebernickel (larsu)
Lars Karlitski (larsu) on 2014-05-15
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-printers (Ubuntu Trusty):
status: New → Confirmed
pureblood (freeseek) wrote :

I can confirm I have the same problem since updating to 14.04.

Adolfo Bastida (bastida) wrote :

Same problem.

pablopedro (pablopedroescobar) wrote :

Same problem.

Changed in indicator-printers (Ubuntu):
importance: Undecided → High
status: Confirmed → In Progress
Changed in indicator-printers (Ubuntu Trusty):
status: Confirmed → Triaged
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-printers - 0.1.7+14.10.20140527-0ubuntu1

---------------
indicator-printers (0.1.7+14.10.20140527-0ubuntu1) utopic; urgency=low

  [ Lars Uebernickel ]
  * service: own bus name so that the panel can find it on the bus (LP:
    #1304434)
 -- Ubuntu daily release <email address hidden> Tue, 27 May 2014 14:06:04 +0000

Changed in indicator-printers (Ubuntu):
status: In Progress → Fix Released
Peter Sewell (peter-sewell) wrote :

Will this fix be released for 14.04LTS? I see that it's released for 14.10.

Pablo (pjferra) wrote :

I can confirm that indicator-printers (0.1.7+14.10.20140527-0ubuntu1) utopic is installable on trusty and solves the bug.

I downloaded it from

http://launchpadlibrarian.net/176413297/indicator-printers_0.1.7%2B14.10.20140527-0ubuntu1_amd64.deb

and installed it with gdebi.

A release for 14.04 from the main repository will be welcome

Installing the package:

http://launchpadlibrarian.net/176413297/indicator-printers_0.1.7%2B14.10.20140527-0ubuntu1_amd64.deb

on trusty does not solve the problem for me. The Printer Indicator does still not appear.

Hello antidopinguser, or anyone else affected,

Accepted indicator-printers into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/indicator-printers/0.1.7+14.04.20140527-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in indicator-printers (Ubuntu Trusty):
status: Triaged → Fix Committed
tags: added: verification-needed
Aibara Iduas (aibaraiduas) wrote :

Works for me, thanks (10.20140527-0ubuntu1_i386.deb).

@David Bamberger: did you log out and back in? It didn't appear for me immediately, but once I did that it worked fine.

Works here with indicator-printers 0.1.7+14.04.20140527-0ubuntu i386

tags: added: verification-done
removed: verification-needed

ok, works now. Thanks!

Peter Sewell (peter-sewell) wrote :

Works for me with 0.1.7+14.10.20140527-0ubuntu1

Sebastian (sebastian-werbung) wrote :

Works for me! Thanks!

Peter Sewell (peter-sewell) wrote :

I've found that the fix does not stay working after a reboot - Has anyone else found this?

I have to re-install the fix file and logout and back in again to make it work.

Aibara Iduas (aibaraiduas) wrote :

Works for me even after a reboot.

I can confirm what Peter says. I also have to reinstall the package after boot for getting the indicator working.
Strange.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-printers - 0.1.7+14.04.20140527-0ubuntu1

---------------
indicator-printers (0.1.7+14.04.20140527-0ubuntu1) trusty; urgency=low

  [ Lars Uebernickel ]
  * service: own bus name so that the panel can find it on the bus (LP:
    #1304434)
 -- Ubuntu daily release <email address hidden> Tue, 27 May 2014 10:02:52 +0000

Changed in indicator-printers (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for indicator-printers has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

how do i get this fix working constantly? I still have to follow the workaround Peter described in 26?

Peter Sewell (peter-sewell) wrote :

Hi David,

Here's what I've done and it seems to have worked - fingers crossed.

I removed the indicator-printers using Synaptic.
Added the Pre-release Updates in the repositories.
Then installed the indicator-printers using Synaptic.
Then changed the repositories back to normal unticking the Pre-release Updates.
Rebooted
And it stayed working for me.

Hope that helps.

Thank you very much Peter for your help!
Works great!

Peter Sewell (peter-sewell) wrote :

Only too glad to help.

I think the problem was that we had installed it via the .deb fix file but the official fix was in the unreleased repository which will correctly install itself.

Can't believe that more people weren't affected by this bug in the first place.

Anyway, all fixed now.

Igor Tarasov (tarasov-igor) wrote :

I have all updates installed (all update repositories enabled), and I still get no printing indicator. indicator-printers installed version is 0.1.7+14.04.20140527-0ubuntu1.

Teo (teo1978) wrote :

I had this problem some time ago and it somehow went away, but starting from recently I'm having this problem AGAIN.

I have all the current updates installed.

Is it supposed to be fixed in the updates currently available? If so, then it is not.

Peter Sewell (peter-sewell) wrote :

This has now stopped working for me too! So what's going on?

Samuel Reisman (sreisman101) wrote :

Same here.

I just uninstalled and reinstalled indicator-printers and still no printer indicator. dpkg -s indicator-printers returns Version: 0.1.7+14.04.20140527-0ubuntu1, so I'm on the supposedly "fixed" version.

Same as Samuel Reisman (#38) here:

14.04 LTS fully updated, latest version of indicator-printers installed, still no printer applet:
~> apt show indicator-printers
Package: indicator-printers
Priority: extra
Section: gnome
Installed-Size: 224 kB
Maintainer: Ubuntu Desktop Team <email address hidden>
Original-Maintainer: Lars Uebernickel <email address hidden>
Version: 0.1.7+14.04.20140527-0ubuntu1
Depends: libc6 (>= 2.2.5), libcairo2 (>= 1.2.4), libcups2 (>= 1.6.0), libdbusmenu-glib4 (>= 0.4.2), libdbusmenu-gtk3-4 (>= 0.4.2), libgdk-pixbuf2.0-0 (>= 2.22.0), libglib2.0-0 (>= 2.37.3), libgtk-3-0 (>= 3.0.0), libindicator3-7 (>= 0.4.90), libpango-1.0-0 (>= 1.18.0
), libpangocairo-1.0-0 (>= 1.14.0), cups (>= 1.5)
Recommends: indicator-applet (>= 0.2) | indicator-renderer, system-config-printer-gnome
Download-Size: 25.1 kB
Homepage: https://launchpad.net/indicator-printers
Bugs: https://bugs.launchpad.net/ubuntu/+filebug
Origin: Ubuntu
Supported: 5y
Task: ubuntu-desktop, ubuntu-usb, edubuntu-desktop, edubuntu-usb
APT-Manual-Installed: yes
APT-Sources: http://ar.archive.ubuntu.com/ubuntu/ trusty-updates/main amd64 Packages
Description: indicator showing active print jobs
 This indicator is designed to let you view and control active print jobs.

This issue isn't fixed yet.
 .
 It requires some way to be hosted into a panel. Either Unity or an indicator
 plugin for your desktop environment.

I still have this problem on 14.04, and have recently wasted quite a bit of ink & paper as a result.

I am not using a 'proposed' repository. The installed version is '0.1.7+14.04.20140527-0ubuntu1'

Peter Sewell (peter-sewell) wrote :

Anyone still affected by this bug please put on this new bug report which I've opened because no one on the Ubuntu Dev Team will be receiving updates from this current bug until enough of us report this issue is still happening on a NEW bug report - see comment #30 in this bug report.

I hope that someone in ubuntu's dev team will respond.

The more of us that say this bug is still affecting us the sooner we'll get help.

Thank you.

Peter Sewell (peter-sewell) wrote :

The new bug report number is Bug #1341562

Fixed for me now.

Indicator-printers still "0.1.7+14.04.20140527-0ubuntu1"

New Kernel "3.13.0-32-generic #57-Ubuntu SMP Tue Jul 15 03:51:08 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux"

Peter Sewell (peter-sewell) wrote :

Tim, I agree, I updated to the latest kernel last night and re-installed the indicator-printers and all is fine.

It's stayed working after several reboots so I think we are fixed.

Peter Sewell (peter-sewell) wrote :

This has stopped working again!

Anyone else found that the fix has stopped working?

Victor Passapera (vpassapera) wrote :

Stopped working here.

Peter Sewell (peter-sewell) wrote :

Victor, Please can you register that you have this fault on a new bug report https://bugs.launchpad.net/bugs/1341562

Because no one on the Ubuntu dev team will be reading this bug anymore as they think it's fixed.

Mine works sometimes and then not others. Very patchy..

przekop (przekop) wrote :

Stopped working

Ubuntu 32bit
latest kernel 3.13.0.33.39
latest indicator-printers 0.1.7+14.04.20140527-0ubuntu1

Amit Chougule (acamit333) wrote :

please can anyone gives me how to fix this problem of HPlaserjet 1020 Printer on ubuntu 14.04 and i have connected via usb but it not found and i installed hplip 3.14.6 on my system and i want all the steps tto recover the problem because i am the new user on linux so dont know more so give step by step procedure.

jakamo (jakamo) wrote :

I did indeed just encounter this problem today. I was already using latest indicator-printers 0.1.7+14.04.20140527-0ubuntu1.

After reading above, I did:

apt-get remove --purge indicator-printers
apt-get install indicator-printers
reboot

It's working now.

Peter Sewell (peter-sewell) wrote :

Hi Jakamo - I tried what you said in Post #50 and that didn't work for me. Sorry.

affects: indicator-printers (Ubuntu Trusty) → indicators-client (Ubuntu Trusty)
Coeur Noir (gerald-maruccia-e) wrote :

indicator printer does not show each time a job print is launched.

It's not linked to one particular software, sometimes indicator-printer shows up, sometimes it does not…

Ubuntu 14.04 (unity) regularly updated - kernel 3.16.x

https://forum.ubuntu-fr.org/viewtopic.php?id=1982901

John Klug (ski-brimson) wrote :

I never see any printer Icon.

I have:

klugja@peru:/usr/share/applications$ dpkg -l | grep indicator
ii gir1.2-appindicator3-0.1 12.10.1+13.10.20130920-0ubuntu4.1 amd64 Typelib files for libappindicator3-1.
ii indicator-applet-complete 12.10.2+14.04.20140403-0ubuntu1 amd64 Clone of the GNOME panel indicator applet
ii indicator-application 12.10.1+14.04.20140407-0ubuntu1 amd64 Application Indicators
ii indicator-appmenu 13.01.0+14.04.20140404-0ubuntu1 amd64 Indicator for application menus.
ii indicator-bluetooth 0.0.6+14.04.20140207-0ubuntu2 amd64 System bluetooth indicator.
ii indicator-datetime 13.10.0+14.04.20140415.3-0ubuntu1 amd64 Simple clock
ii indicator-keyboard 0.0.0+14.04.20140410.1-0ubuntu1 amd64 Keyboard indicator
ii indicator-messages 13.10.1+14.04.20140410-0ubuntu1 amd64 indicator that collects messages that need a response
ii indicator-power 12.10.6+14.04.20140411-0ubuntu1 amd64 Indicator showing power state.
ii indicator-printers 0.1.7+14.04.20140527-0ubuntu1 amd64 indicator showing active print jobs
ii indicator-session 12.10.5+14.04.20151021.1-0ubuntu1 amd64 indicator showing session management, status and user switching
ii indicator-sound 12.10.2+14.04.20140401-0ubuntu1 amd64 System sound indicator.
ii libappindicator1 12.10.1+13.10.20130920-0ubuntu4.1 amd64 Application Indicators
ii libappindicator3-1 12.10.1+13.10.20130920-0ubuntu4.1 amd64 Application Indicators
ii libindicator3-7 12.10.2+14.04.20141007.1-0ubuntu1 amd64 panel indicator applet - shared library
ii libindicator7 12.10.2+14.04.20141007.1-0ubuntu1 amd64 panel indicator applet - shared library
ii sni-qt:amd64 0.2.6-0ubuntu1 amd64 indicator support for Qt
ii telepathy-indicator 0.3.1+14.04.20140411-0ubuntu1 amd64 Desktop service to integrate Telepathy with the messaging menu.

and:
ii gnome-panel 1:3.8.0-1ubuntu12.2 amd64 launcher and docking facility for GNOME

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers