indicator-weather crashed with SIGSEGV in g_str_equal()

Bug #799222 reported by Moritz Naumann on 2011-06-18
30
This bug affects 6 people
Affects Status Importance Assigned to Milestone
indicator-weather (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: indicator-weather

This may have happened because I started indicator-weather from a terminal window (spawning it as a new process by appending '&') and later closed this terminal window. By this time indicator-weather was still functional, though.

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: indicator-weather 11.04.10+repack-0ubuntu2
ProcVersionSignature: Ubuntu 2.6.38-10.44-generic 2.6.38.7
Uname: Linux 2.6.38-10-generic x86_64
Architecture: amd64
Date: Fri Jun 10 18:20:54 2011
ExecutablePath: /usr/bin/indicator-weather
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/indicator-weather
ProcEnviron:
 LANGUAGE=de_DE:en
 PATH=(custom, user)
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x7f18a4a6ce56: movlpd (%rdi),%xmm1
 PC (0x7f18a4a6ce56) ok
 source "(%rdi)" (0x00000000) not located in a known VMA region (needed readable region)!
 destination "%xmm1" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: indicator-weather
StacktraceTop:
 ?? () from /lib/x86_64-linux-gnu/libc.so.6
 g_str_equal () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 g_hash_table_lookup () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 dbusmenu_menuitem_property_get_variant () from /usr/lib/libdbusmenu-glib.so.3
 dbusmenu_menuitem_properties_variant () from /usr/lib/libdbusmenu-glib.so.3
Title: indicator-weather crashed with SIGSEGV in g_str_equal()
UpgradeStatus: Upgraded to natty on 2011-04-09 (70 days ago)
UserGroups: adm admin cdrom dialout libvirtd lpadmin plugdev sambashare

Moritz Naumann (mnaumann) wrote :

StacktraceTop:
 __strcmp_ssse3 () at ../sysdeps/x86_64/multiarch/../strcmp.S:213
 g_str_equal (v1=<value optimized out>, v2=<value optimized out>) at /build/buildd/glib2.0-2.28.6/./glib/gstring.c:116
 g_hash_table_lookup_node (hash_table=0x1ca7990, key=0x7f1890038c70) at /build/buildd/glib2.0-2.28.6/./glib/ghash.c:331
 g_hash_table_lookup (hash_table=0x1ca7990, key=0x7f1890038c70) at /build/buildd/glib2.0-2.28.6/./glib/ghash.c:902
 dbusmenu_menuitem_property_get_variant (mi=0x7f1890069a40, property=0x7f1890038c70 "type") at /build/buildd/libdbusmenu-0.4.3/./libdbusmenu-glib/menuitem.c:1291

Changed in indicator-weather (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
visibility: private → public
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-weather (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers