indicator-weather crashed with TypeError in next_page(): unknown type (null)

Bug #747733 reported by bitu-derr on 2011-04-01
32
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Weather Indicator
Medium
Vadim Rutkovsky
indicator-weather (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: indicator-weather

Just upgraded Natty to beta 1 and rebooted. Soon after the reboot and login, the weather indicator actually appeared in the panel for the first time in weeks (yay!). I clicked the panel icon and a setup dialog opened. I entered my town and clicked next and it crashed.

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: indicator-weather 11.03.27+repack-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-7.39-generic 2.6.38
Uname: Linux 2.6.38-7-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Fri Apr 1 16:06:38 2011
ExecutablePath: /usr/bin/indicator-weather
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
InterpreterPath: /usr/bin/python2.7
ProcCmdline: /usr/bin/python /usr/bin/indicator-weather
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 SHELL=/bin/bash
PythonArgs: ['/usr/bin/indicator-weather']
SourcePackage: indicator-weather
Title: indicator-weather crashed with TypeError in next_page(): unknown type (null)
Traceback:
 Traceback (most recent call last):
   File "/usr/bin/indicator-weather", line 1511, in next_page
     self.builder.get_object("placelbl").set_label('<b>%s</b>' % self.place_selected[0])
 TypeError: unknown type (null)
UpgradeStatus: Upgraded to natty on 2011-03-27 (5 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

bitu-derr (biturica) wrote :
bitu-derr (biturica) wrote :

I don't know if it makes a difference, but I instinctively tried to select my town by entering my ~zip code~ into the dialog box. Since nothing seemed to happen, I deleted that and entered the nearest major city, then I noticed my actual smaller town had been populated into a drop-down menu, but not into the select box. I believe I tried to then select my town from the drop-down, in lieu of searching for the city I had entered instead.

After submitting this bug report, and closing the original dialogs and starting over, I entered the name (not zip code) of my actual town, clicked get cities, and it populated the select box itself correctly. I was able to continue without incident (I did no other configuration besides setting my location).

tags: removed: need-duplicate-check
visibility: private → public
Vadim Rutkovsky (roignac) wrote :

Confirmed from duplicate

Changed in indicator-weather (Ubuntu):
status: New → Confirmed
Changed in weather-indicator:
milestone: none → 11.04.23
status: New → Confirmed
Changed in weather-indicator:
assignee: nobody → Vadim Rutkovsky (roignac)
importance: Undecided → Medium
status: Confirmed → Fix Committed
Changed in weather-indicator:
status: Fix Committed → Fix Released
Changed in indicator-weather (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-weather - 11.05.31-0ubuntu1

---------------
indicator-weather (11.05.31-0ubuntu1) oneiric; urgency=low

  * New upstream release.
   - Ported settings to dconf, which will solve a number of
     desktopcouch-related bugs
   - Fix for LP: #747733 "indicator-weather crashed with
     TypeError in next_page(): unknown type (null)"
   - Fix for LP: #756704 "Numbers (temperature etc.) do
     not use local number format"
   - Fix for LP: #770652 "sunrise and sunset info incorrect"
   - Fix for LP: #765464 "do not see indicator-weather on the panel"
   - Fix for LP: #769842 "Weather Indicator should clear up corrupted DB"
   - Fix for LP: #778941 "Weather Indicator can't be disabled"
   - Fix for LP: #796314 "ROUND_CEiLiNG error in Turkish locale"
   - Fix for LP: #780973 "indicator-weather crashed with Unauthorized in
     request(): ('unauthorized', 'Authentication required.')"
  * debian/control:
   - Adjust dependencies for desktop-couch to dconf transition.
   - Bump Standards-Version to 3.9.2.
   - Explictily depend on libgtk2.0-bin to ensure we have
     /usr/bin/gtk-update-icon-cache (LP: #808387).
  * Convert from python-support to dh_python2.
  * debian/rules:
   - Drop get-orig-source target, not needed.
   - Fix debian/postinst to check for symbolic links as well.
 -- Andrew Starr-Bochicchio <email address hidden> Tue, 12 Jul 2011 01:44:53 -0400

Changed in indicator-weather (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers