indicator-weather crashed with SIGSEGV in dbusmenu_menuitem_get_children()

Bug #747586 reported by zeruke on 2011-04-01
326
This bug affects 109 people
Affects Status Importance Assigned to Milestone
Weather Indicator
Medium
Unassigned
indicator-weather (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: indicator-weather

happened right after login

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: indicator-weather 11.03.27+repack-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-7.39-generic 2.6.38
Uname: Linux 2.6.38-7-generic i686
NonfreeKernelModules: nvidia wl
Architecture: i386
Date: Fri Apr 1 12:23:59 2011
ExecutablePath: /usr/bin/indicator-weather
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110309)
InterpreterPath: /usr/bin/python2.7
ProcCmdline: /usr/bin/python /usr/bin/indicator-weather
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x8d5915 <dbusmenu_menuitem_get_children+37>: cmp %eax,(%edx)
 PC (0x008d5915) ok
 source "%eax" ok
 destination "(%edx)" (0x00000008) not located in a known VMA region (needed writable region)!
SegvReason: writing NULL VMA
Signal: 11
SourcePackage: indicator-weather
StacktraceTop:
 dbusmenu_menuitem_get_children () from /usr/lib/libdbusmenu-glib.so.3
 dbusmenu_menuitem_build_variant () from /usr/lib/libdbusmenu-glib.so.3
 dbusmenu_menuitem_build_variant () from /usr/lib/libdbusmenu-glib.so.3
 ?? () from /usr/lib/libdbusmenu-glib.so.3
 ?? () from /usr/lib/libdbusmenu-glib.so.3
Title: indicator-weather crashed with SIGSEGV in dbusmenu_menuitem_get_children()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

zeruke (oninekoze) wrote :

StacktraceTop:
 dbusmenu_menuitem_get_children (mi=0xa3c76c0) at ../../libdbusmenu-glib/menuitem.c:583
 dbusmenu_menuitem_build_variant (mi=0xa3c76c0, properties=0xb5203f18, recurse=0) at ../../libdbusmenu-glib/menuitem.c:1614
 dbusmenu_menuitem_build_variant (mi=0xa382800, properties=0xb5203f18, recurse=1) at ../../libdbusmenu-glib/menuitem.c:1622
 bus_get_layout (server=0xa0500e0, params=0xb5208298, invocation=0xa3c7980) at ../../libdbusmenu-glib/server.c:1206
 bus_method_call (connection=0x9f13090, sender=0xa3c4f28 ":1.17", path=0xa3c1c40 "/org/ayatana/NotificationItem/indicator_weather/Menu", interface=0xa3f0cb0 "com.canonical.dbusmenu", method=0xa3edfd0 "GetLayout", params=0xb5208298, invocation=0xa3c7980, user_data=0xa0500e0) at ../../libdbusmenu-glib/server.c:723

Changed in indicator-weather (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
visibility: private → public
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-weather (Ubuntu):
status: New → Confirmed
tags: added: precise
Keith Drummond (victor9098) wrote :

This just happened to me in Ubuntu 12.10 Beta 1

Ursula Junque (ursinha) on 2013-02-06
tags: added: raring
Changed in weather-indicator:
status: New → Confirmed
Cedara (cedara2) wrote :

also with Ubuntu 12.04

Joshua Tasker (jtasker) wrote :

Fixed in 13.05.17, available as a tarball or from the Weather Indicator Team PPA

Changed in weather-indicator:
status: Confirmed → Fix Released
milestone: none → 13.05.17
importance: Undecided → Medium
Chris J Arges (arges) wrote :

@jtasker
Can these fixes be applied to the version in the Ubuntu archive?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers