indicator-weather crashed with KeyError in finish_initializing(): u''

Bug #744702 reported by Paul Hinchberger III on 2011-03-29
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Weather Indicator
Medium
Vadim Rutkovsky
indicator-weather (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: indicator-weather

This happened when I tried to check the weather forecast.

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: indicator-weather 11.03.20+repack-0ubuntu2
ProcVersionSignature: Ubuntu 2.6.38-7.39-generic 2.6.38
Uname: Linux 2.6.38-7-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Mon Mar 28 22:32:20 2011
ExecutablePath: /usr/bin/indicator-weather
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110301.7)
InterpreterPath: /usr/bin/python2.7
ProcCmdline: /usr/bin/python /usr/bin/indicator-weather
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 SHELL=/bin/bash
PythonArgs: ['/usr/bin/indicator-weather']
SourcePackage: indicator-weather
Title: indicator-weather crashed with KeyError in finish_initializing(): u''
UpgradeStatus: Upgraded to natty on 2011-03-10 (18 days ago)
UserGroups: adm admin audio cdrom dialout dip fax floppy fuse lpadmin netdev plugdev sambashare tape video

tags: removed: need-duplicate-check
visibility: private → public
Vadim Rutkovsky (roignac) wrote :

Seems to be fixed by recent patch for Google Forecast by Felix

Changed in indicator-weather (Ubuntu):
status: New → Confirmed
Changed in weather-indicator:
assignee: nobody → Vadim Rutkovsky (roignac)
importance: Undecided → Medium
milestone: none → cloudy-3
status: New → Fix Committed

Indeed. I checked this last night and tonight and the forecast is working properly.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-weather - 11.03.27+repack-0ubuntu1

---------------
indicator-weather (11.03.27+repack-0ubuntu1) natty; urgency=low

  * New upstream release.
   - Fix for LP: #720030 "indicator invisible on first run",
     thanks Felix!
   - Fix for LP: #739209 "indicator-weather crashed with
     AttributeError in get_value(): 'NoneType' object has no
     attribute 'execute_view'"
   - Fix for LP: #739907 "indicator-weather failed to start
     falsely reporting duplicate instance", thanks Felix!
   - Fix for LP: #735667 "indicator-weather crashed with NetworkException
     in FetchReport(): HTTP Error 408: Request Time-out"
   - And even more bug fixes.
  * debian/indicator-weather.install: COPYING file no longer
    needed. Now uses common-license version.
  * Drop lintian over-ride for extra-license-file.
  * Drop debian/patches/01_lp_738804.patch, applied upstream.
  * debian/rules: No need to delete empty dir anymore.
  * fix-google-coordinates-lp739420.patch: Fix formatting
    of coordinates Google. Patch by Felix Lawrence!
    Fixes LP: #739420 and LP: #744702.
 -- Andrew Starr-Bochicchio <email address hidden> Mon, 28 Mar 2011 18:39:38 -0400

Changed in indicator-weather (Ubuntu):
status: Confirmed → Fix Released
Changed in weather-indicator:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers