indicator-weather crashed with KeyError in prepare_forecast_data(): 'unit_system'

Bug #739420 reported by Leonard Lausen on 2011-03-21
178
This bug affects 29 people
Affects Status Importance Assigned to Milestone
Weather Indicator
High
Vadim Rutkovsky
indicator-weather (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: indicator-weather

I just pressed the "Prognose" (in english forecast) button... Then nothing happened and suddenly the option to submit this bug appeared. A forecast was not shown.

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: indicator-weather 11.03.20+repack-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-7.36-generic 2.6.38
Uname: Linux 2.6.38-7-generic i686
Architecture: i386
Date: Mon Mar 21 15:36:03 2011
EcryptfsInUse: Yes
ExecutablePath: /usr/bin/indicator-weather
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110315)
InterpreterPath: /usr/bin/python2.7
ProcCmdline: /usr/bin/python /usr/bin/indicator-weather
ProcEnviron:
 LANGUAGE=de_DE:en
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
PythonArgs: ['/usr/bin/indicator-weather']
SourcePackage: indicator-weather
Title: indicator-weather crashed with KeyError in prepare_forecast_data(): 'unit_system'
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Leonard Lausen (leezu) wrote :
tags: removed: need-duplicate-check
visibility: private → public
Changed in weather-indicator:
assignee: nobody → Vadim Rutkovsky (roignac)
importance: Undecided → High
milestone: none → cloudy-3
status: New → Confirmed
Changed in indicator-weather (Ubuntu):
status: New → Confirmed
Changed in weather-indicator:
status: Confirmed → In Progress
Felix Lawrence (felix-lawrence) wrote :

For some latitudes and longitudes (including mine), google weather was not returning any weather report. This turned out to be because the formatting was wrong. See the Jun 15 comment on this stackoverflow post for details:
http://stackoverflow.com/questions/2780836/using-google-weather-api-with-lat-and-lon-how-to-format

Fixing this also fixes a problem by which google weather wasn't working for me at all.

Changed in weather-indicator:
status: In Progress → Confirmed
tags: added: patch
Changed in indicator-weather (Ubuntu):
importance: Undecided → Medium
Vadim Rutkovsky (roignac) wrote :

Great job, Felix! The patch seems to solve the problem for Freiburg

Changed in weather-indicator:
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-weather - 11.03.27+repack-0ubuntu1

---------------
indicator-weather (11.03.27+repack-0ubuntu1) natty; urgency=low

  * New upstream release.
   - Fix for LP: #720030 "indicator invisible on first run",
     thanks Felix!
   - Fix for LP: #739209 "indicator-weather crashed with
     AttributeError in get_value(): 'NoneType' object has no
     attribute 'execute_view'"
   - Fix for LP: #739907 "indicator-weather failed to start
     falsely reporting duplicate instance", thanks Felix!
   - Fix for LP: #735667 "indicator-weather crashed with NetworkException
     in FetchReport(): HTTP Error 408: Request Time-out"
   - And even more bug fixes.
  * debian/indicator-weather.install: COPYING file no longer
    needed. Now uses common-license version.
  * Drop lintian over-ride for extra-license-file.
  * Drop debian/patches/01_lp_738804.patch, applied upstream.
  * debian/rules: No need to delete empty dir anymore.
  * fix-google-coordinates-lp739420.patch: Fix formatting
    of coordinates Google. Patch by Felix Lawrence!
    Fixes LP: #739420 and LP: #744702.
 -- Andrew Starr-Bochicchio <email address hidden> Mon, 28 Mar 2011 18:39:38 -0400

Changed in indicator-weather (Ubuntu):
status: Confirmed → Fix Released
Changed in weather-indicator:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers