"Forecast Information Cannot be fetched. Connection cannot be established"

Bug #1048193 reported by Alexander T. Stanton on 2012-09-09
508
This bug affects 170 people
Affects Status Importance Assigned to Milestone
Weather Indicator
High
Unassigned
indicator-weather (Ubuntu)
Undecided
Unassigned

Bug Description

For days the weather bug Forecast button's usefullness has been replaced with this error message "Forecast Information Cannot be fetched. Connection cannot be established" I've tried both the google and Yahoo option and neither works.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: indicator-weather 11.11.28-0ubuntu1.2
ProcVersionSignature: Ubuntu 3.2.0-30.48-generic 3.2.27
Uname: Linux 3.2.0-30-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.0.1-0ubuntu12
Architecture: amd64
Date: Sun Sep 9 07:09:32 2012
ExecutablePath: /usr/bin/indicator-weather
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
SourcePackage: indicator-weather
UpgradeStatus: No upgrade log present (probably fresh install)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-weather (Ubuntu):
status: New → Confirmed
todaioan (alan-ar06) on 2012-09-10
Changed in indicator-weather (Ubuntu):
status: Confirmed → Fix Committed
Nico (gizzmo) on 2012-09-13
no longer affects: weather-indicator

such a pain too.. enjoy my weather forecast and coffee in the morning(now I use HTC weather for android instead).. looks like there is an API change..:
gps
http://developer.yahoo.com/maps/rest/V1/geocode.html
forecast
http://developer.yahoo.com/weather/

code looks to be in

bin/indicator-weather @@331

            # Get YAHOO WOEID by english name of location
            baseurl = 'http://where.yahooapis.com/geocode?[location]'
            params = {'location': displayed_city_name, 'appid': 'mOawLd4s', 'flags': 'J'}
            url = '?'.join((baseurl, urlencode(params)))
            log.debug("Location: Get Yahoo WOEID, url %s" % url)
            f = urllib2.urlopen(url)
            s=f.read()
            null = None

not sure if its a simple address change or a whole rewrite..
let me know!

dpa2007 (dpa2007d) on 2012-09-27
Changed in indicator-weather (Ubuntu):
assignee: nobody → dpa2007 (dpa2007d)
assignee: dpa2007 (dpa2007d) → nobody
Mark Suarez (mavsuarez) on 2012-10-03
Changed in indicator-weather (Ubuntu):
status: Fix Committed → Fix Released
Val (vk1266) wrote :

The bug is still present in 11.11.28-0ubuntu1.2, Ubuntu 12.04 Precise 64-bit. I get the exact same error message, "Forecast information cannot be fetched. Connection cannot be established".

SVWander (windycitybythebay) wrote :

Would be nice if this bug were fixed but it isn't. Ubuntu 12.04 Precise 32-bit. Running on a Dell Insprion E1505. "Forecast information cannot be fetched. Connection cannot be established".

abrianb (abrianb2003) wrote :

This bug is not fixed, still getting the message. I have updated.

Miroslav Sabljić (civija) wrote :

@Mark Suarez

Why did you set this bug to FIx released? The bug isn't fixed and it isn't released. I've checked indicator-weather source and changelogs and there is nothing documented about fixing this. I'm using 12.10 with indicator-weather 12.07.30-0ubuntu1. This behaviour started when Google shut down their servers for weather forceast and indicator-weather is using them to display forceast infomation. So this will not be fixed until indicator-weather gets support for using some other forceast source

Please reopen this bug.

I agree.
Not fixed and not released.
I dont understand what is happening...

Em 20-10-2012 17:38, Miroslav Sabljić escreveu:
> @Mark Suarez
>
> Why did you set this bug to FIx released? The bug isn't fixed and it
> isn't released. I've checked indicator-weather source and changelogs and
> there is nothing documented about fixing this. I'm using 12.10 with
> indicator-weather 12.07.30-0ubuntu1. This behaviour started when Google
> shut down their servers for weather forceast and indicator-weather is
> using them to display forceast infomation. So this will not be fixed
> until indicator-weather gets support for using some other forceast
> source
>
> Please reopen this bug.
>

--
Gustavo Rocha

palimmo (palimmo) wrote :

not fixed yet

Changed in indicator-weather (Ubuntu):
status: Fix Released → Confirmed
Bob (bbrazie) wrote :

Is not!

Damon Hartman (area51pilot) wrote :

Still not fixed. Ubuntu 12.04 up to date 12.07.30 'Cloudy 10' in use with Yahoo Wx (Google Wx does the same)

Miroslav Sabljić (civija) wrote :

Guys, weather indicator is using google or yahoo to display typical weather info but for forecast information it is using only google. Some time ago google shut down their weather servers so indicator weather isn't going to work anymore until some of the developers rewrite this part to use some other source for displaying forecast information. On the indicator facebook page they said that no one is currently working or maintaing indicator weather.

So, is there any python programers among you guys? :)

tekstr1der (tekstr1der) on 2012-10-27
Changed in weather-indicator:
status: New → Confirmed

I just started to learn how to program. Give me a couple of days and I will look into it.. xD

Seriously.

MeMo (mbelgin) wrote :

Same problem... I am still keeping it since the icon is so cool. :)

John Doeee (craigslist45414) wrote :

NOOOOOOOOOOOOOOOTTTTTTTTTT FIIIIIIIIIIXXXXXXXXXXXXXXXXXXXXXXXXXXXED.............PLEASE SOMEONE FIX THE FORECAST BUTTON.......AND ALSO, THERE IS A GLITCH IN THE ICON NOT APPEARING AND YOU CAN WORK ON AFTER YOU FIX THE FORECAST BUTTON........GOSH DANG YOU UBUNTU

Damon Hartman (area51pilot) wrote :

Can confirm it is not fixed. Ubuntu 12.04 up to date 12.07.30 'Cloudy 10' in use with Yahoo Wx (Google Wx does the same)

reanimator (emerg-reanimator) wrote :

Hello everybody,

After waiting for several months of fixing this issue, I finally spend few hours to understand why it's takes so long.

My understanding is that weather-indicator is based on pywapi weather API which has support of
1. Google (apparently not usable anymore)
2. Yahoo (1 day forecast avaiable througth API - it is not a joke! )
3. NOAA (Available for US only)

Looks like the maintainer fellows are switching the underlying library which support more public frendly providers.
This may take a while.

In the meantime I will use my patched version to get forecast from Yahoo.
Yes, I know 1 day forecast is scanty. But after all it's better than disappointing error notifcation.

In fact only two file need to be updated:
- /usr/bin/indicator-weather
- /usr/share/indicator-weather/ui/ExtendedForecast.ui

Hope somebody find this patch useful.

tags: added: patch
Miroslav Sabljić (civija) wrote :

@reanimator
Thanks for you work! Unfortunately patch doesn't cleanly apply to the latest weather indicator source. Judging by the patch name you are using v11.11.28 from Precise and the latest version is 12.07.30. Could you please adapt it for the latest source and I will test it and create a proper debdiff patch which can be included to the official package?

Thomas (bu9s) wrote :

@civija
As far as I'm concerned, the patch worked for me on Ubuntu 12.04 and with v12.07.30 'Cloudy 10'.
I only patch the two files indicated and everything worked as expected.

@reanimator
Thanks by the way !

Miroslav Sabljić (civija) wrote :

I'm using Ubuntu 12.10. When I download a source deb package it already contains couple of patches that are also in this patch from reanimator. So the patches are already applied when extracting a deb package. I adapted the patch to apply cleanly and rebuild the deb package but it still doesn't work. Now I'm getting this message when I try to enter a location in setup process on the first run of indicator-weather.

/usr/lib/python2.7/dist-packages/gobject/constants.py:24: Warning: g_boxed_type_register_static: assertion `g_type_from_name (name) == 0' failed
  import gobject._gobject
Traceback (most recent call last):
  File "/usr/bin/indicator-weather", line 1892, in on_apply
    (location_code, location_details) = self.location.export_location_details()
  File "/usr/bin/indicator-weather", line 405, in export_location_details
    return (self.location_code, self.location_details)
AttributeError: Location instance has no attribute 'location_code'

Miroslav Sabljić (civija) wrote :

Fixed! This error was related to other bug.
https://bugs.launchpad.net/ubuntu/+source/indicator-weather/+bug/821233

I'm attaching a fixed deb package for quantal.

Miroslav Sabljić (civija) wrote :
Val (vk1266) wrote :

Excellent work Miroslav! I installed your deb on both my 12.04 and 12.10 installations (both are 64-bit), and indicator-weather now works like a charm on both machines!

Thank you!!!

Benjamin (nailartcenter) wrote :

please fix it until Ubuntu 12.04.2

Thanks!

I can confirm that the patch works if you set it the Weather Data source to Yahoo! Good job. You finally got it!

Correction: The icon works, but I still get same error message when I click on the forecast.

reanimator (emerg-reanimator) wrote :

Great news!

12.07.30-0ubuntu1_all_patched works for me too.

The strange thing what I did not receive any notification to my (g)email account.

Andre (ajx) wrote :

Thank you very much, Miroslav. "indicator-weather_12.07.30-0ubuntu1_all_patched.deb" fixes all bugs for me on Precise 64bit. Forecast is set to Yahoo! and works (2 days). Also, I can add new locations.

When will this version find its way into the regular Ubuntu updates for Precise?

Oded Sela (shmany) wrote :

Still exist on the regular distribution when can we get it?

magnumXopus (jpressel-t) wrote :

I'm affected by this bug.

Joshua Tasker (jtasker) wrote :

Oded: the project needs maintainers, the previous ones seem to have dropped out due to lack of interest and/or time. Especially people with debugging experience are needed.

I have been fixing bugs in my spare time but I do not have the time to become a maintainer. I posted my fixes in a PPA for people who are interested. If you want a fixed version with a four day forecast, you can get it here: https://launchpad.net/~jtasker/+archive/weather-indicator

Damon Hartman (area51pilot) wrote :

unable to download file .. area private.
On 05/06/2013 12:19 AM, Joshua wrote:
> Oded: the project needs maintainers, the previous ones seem to have
> dropped out due to lack of interest and/or time. Especially people with
> debugging experience are needed.
>
> I have been fixing bugs in my spare time but I do not have the time to
> become a maintainer. I posted my fixes in a PPA for people who are
> interested. If you want a fixed version with a four day forecast, you
> can get it here: https://launchpad.net/~jtasker/+archive/weather-
> indicator
>

Joshua Tasker (jtasker) wrote :

The fix for this has been released in the latest version (13.05.17), it is available at the Weather Indicator Team PPA: https://launchpad.net/~weather-indicator-team/+archive/ppa

Changed in weather-indicator:
milestone: none → 13.05.17
importance: Undecided → Critical
importance: Critical → High
status: Confirmed → Fix Released
Damon Hartman (area51pilot) wrote :

Cant install because I cant figure out how to resolve this dependency issue for the version of python-pywapi it's asking for ...

The following packages have unmet dependencies:
 indicator-weather : Depends: python-pywapi (>= 0.3.2) but it is not going to be installed

Please advise ... I prefer this weather indicator

Joshua Tasker (jtasker) wrote :

pywapi 0.3.2 is available from the Release PPA here:

https://launchpad.net/~pywapi-devel/+archive/ppa

Damon Hartman (area51pilot) wrote :

Thx Joshua ... was able to update to pywapi 0.3.2 and install indicator-weather. :) (my preferred WX indicator)

To post a comment you must log in.