Indicator title not translated

Bug #1502926 reported by Víctor R. Ruiz on 2015-10-05
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Alejandro J. Cura
indicator-transfer (Ubuntu)
High
Charles Kerr
indicator-transfer-buteo (Ubuntu)
High
Charles Kerr

Bug Description

Test case.
- Switch the phone to Spanish.
- Open the indicators.

Expected result.
- "Files" label must be translated to Spanish.

Actual result.
- "Files" appears in English.

current build number: 141
device name: krillin
channel: ubuntu-touch/rc-proposed/bq-aquaris.en

Related branches

Víctor R. Ruiz (vrruiz) wrote :
tags: added: touch-l10n
Changed in indicator-transfer (Ubuntu):
importance: Undecided → High
Víctor R. Ruiz (vrruiz) wrote :

phablet@ubuntu-phablet:/usr/share/locale-langpack/es/LC_MESSAGES$ grep "Files" indicator-transfer.mo
Binary file indicator-transfer.mo matches

Charles Kerr (charlesk) wrote :

Jibel in #phablet reports the same thing, and I'm seeing it too.

Changed in indicator-transfer (Ubuntu):
assignee: nobody → Charles Kerr (charlesk)
status: New → In Progress
Charles Kerr (charlesk) wrote :

Looks like the problem is actually in indicator-transfer-buteo, which is a plugin module that indciator-transfer loads and shows calendar sync activity.

The buteo plugin is overwriting indicator-transfer's text domain. It the terms of <https://developer.gnome.org/glib/unstable/glib-I18N.html#glib-I18N.description>, it should be acting like a library instead of an application.

Changed in indicator-transfer-buteo (Ubuntu):
importance: Undecided → High
Charles Kerr (charlesk) on 2015-10-06
Changed in indicator-transfer-buteo (Ubuntu):
status: New → In Progress
Changed in indicator-transfer (Ubuntu):
status: In Progress → Triaged
Changed in canonical-devices-system-image:
milestone: none → ww46-2015
assignee: nobody → Alejandro J. Cura (alecu)
importance: Undecided → High
status: New → Triaged
Charles Kerr (charlesk) on 2015-10-13
Changed in indicator-transfer-buteo (Ubuntu):
assignee: nobody → Charles Kerr (charlesk)
Changed in indicator-transfer (Ubuntu):
status: Triaged → Invalid
Charles Kerr (charlesk) on 2015-10-22
Changed in indicator-transfer-buteo (Ubuntu):
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
status: Triaged → Fix Committed
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers