sound indicator not working after amarok close

Bug #992262 reported by piotrekkr on 2012-04-30
16
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Obsolete project please ignore
Undecided
Unassigned
The Sound Menu
Fix Released
Low
Conor Curran
indicator-sound (Ubuntu)
Low
Ken VanDine
Precise
Low
Unassigned

Bug Description

Hi,

I'm using ubuntu 12.04 with unity. I've set Amarok as default music player. I'm runing Amarok using sound indicator menu and everything is ok until I close Amarok window using close button. After closing Amarok music stops and amarok is terminated. (IMHO it should hide amarok under indicator menu not terminate application). The problem is when Amarok terminates, sound indicator still holds info about last played song and I can't reopen player again using indicator menu. I think it's because indicator thinks that Amarok is still open and playing. It's like indicator have never got info that Amarok was terminated.

I'm expecting that after amarok terminates, sound indicator applet is cleared and there is no info such as last played song and play/next/prev buttons. It should be possible to run Amarok from indicator menu again.

My os:

piotrek@piotrek-desktop:~$ lsb_release -rd
Description: Ubuntu 12.04 LTS
Release: 12.04

Amarok version: 2:2.5.0-0ubuntu6

piotrekkr (piotrekkr) on 2012-04-30
description: updated
Myriam Schweingruber (myriam) wrote :

Not related to amarok, reassigning.

affects: amarok (Ubuntu) → indicator-sound
Bilal Akhtar (bilalakhtar) wrote :

Actually, this IS related to Amarok. Amarok should continue running it's background service even after it's closed.

affects: indicator-sound → amarok (Ubuntu)
Scott Kitterman (kitterman) wrote :

Bilal,

You may not be familiar with this, but in Ubuntu there has been a tradition of not flapping bug status back and forth, so I think that reverting the reassignment without discussion was inappropriate (so I'm putting it back). While you're certainly entitled to your opinion about what Amarok should do, you've got an Amarok upstream telling you that's not the case.

Personally, I don't think it's reasonable for indicator-sound to expect the entire world to adjust to its notions of how things should work and indicator-sound should handle cases like this more gracefully, but the indicator-sound may not care to do that. I can see three possible package/status combinations that might be reasonably applied here:

Amarok - Won't Fix
Indicator Sound - New
Indicator Sound - Won't Fix (if they choose not to address this case).

Given that Amarok upstream has told you they don't view this as a bug, I do not think keeping it on the books as an open amarok bug is useful.

affects: amarok (Ubuntu) → indicator-sound (Ubuntu)
Conor Curran (cjcurran) wrote :

Hi Scott, Bilal

Sorry just getting to this now.

>Personally, I don't think it's reasonable for indicator-sound to expect the entire world to adjust to its notions of how things >should work and indicator-sound should handle cases like this more gracefully, but the indicator-sound may not care to do that.

Not really sure what you mean by this. If you would like to elaborate I'm all ears....

There seems to be a bug in indicator-sound. The amarok MPRIS interface disappears as it should do from the bus. Investigating now.

Conor

Changed in indicator-sound:
status: New → In Progress
Changed in indicator-sound (Ubuntu):
status: New → In Progress
Changed in indicator-sound:
assignee: nobody → Conor Curran (cjcurran)
importance: Undecided → Low
Changed in indicator-sound (Ubuntu):
importance: Undecided → Low

Sorry about that. I made a bad assumption based on what was in the bug.

Conor Curran (cjcurran) wrote :

No problem, found the bug. AFAIR
I specifically handled the amarok case below but instead I should be returning the second entry in the array.

  private static string? determine_key(owned string desktop_or_interface)
    var temp = result.split("-");
    if (temp != null && temp.length > 1){
      result = temp[0];
    }

Therefore
      result = temp[1]

will SRU asap.

piotrekkr (piotrekkr) wrote :

Do you plan to add option to hide amarok into indicatior after using close button? It would be similar like in instant messaging clients when you click close button they runnig in background until you especially use menu -> close.

Conor Curran (cjcurran) wrote :

I have tested this and it seems to hide appropriately. Hitting the close button hides amarok, I can bring the window back up from the sound menu once it's hidden.
it also quits from the quit option in the menu.

piotrekkr (piotrekkr) wrote :

@Conor Curran (cjcurran)

In my case close button terminates amarok and and music stops :) Do you mean that after applying your patch Amarok will start to hide on close and music will be playing in background?

Conor Curran (cjcurran) wrote :

hi Piotrekkr,

Nope it seems like there is something broken with Amarok on your setup. I just installed from the repo on precise yesterday and it works fine here as expected. I have an up to date precise system (with proposed updates activated).

C

Changed in indicator-sound:
status: In Progress → Fix Committed
Changed in indicator-sound (Ubuntu):
assignee: nobody → Ken VanDine (ken-vandine)
Changed in indicator-sound (Ubuntu Precise):
importance: Undecided → Low
status: New → In Progress
Conor Curran (cjcurran) on 2012-05-03
Changed in indicator-sound:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-sound - 0.8.5.0-0ubuntu3

---------------
indicator-sound (0.8.5.0-0ubuntu3) quantal; urgency=low

  * debian/patches/lp_992262.patch
    - fix sound indicator not working after amarok close (LP: #992262)
  * debian/patches/lp_902715.patch
    - Partial fix which sets the accessibility property on the volume
      slider menu item. Previously this was achieved by sending a signal
      on the indicator object but now it seems the way to update orca is
      to set/update the appropriate property on the menuitem. Orca doesn't
      broadcast volume updates on slider movement but at least it updates
      when the user moves to the item on the menu, previously it was entirely
      silent. (LP: #902715)
 -- Ken VanDine <email address hidden> Thu, 03 May 2012 16:07:19 -0700

Changed in indicator-sound (Ubuntu):
status: In Progress → Fix Released

Hello piotrekkr, or anyone else affected,

Accepted indicator-sound into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in indicator-sound (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
piotrekkr (piotrekkr) wrote :

@Conor Curran
Ok indicator works fine now but Amarok still terminates after closing using close button. I think that I know what is happening. I've first deleted Amarok (with config files) using synaptic, next I've installed Amarok again. But it did't help so I've also deleted ~/.kde/appps/amarok and ~/.kde/config/amarok*. Default settings was applied so there was an Amarok icon in "tray" on start. When I used close button message was show that amarok will be hidden into tray icon and it hides on close. But AFAIK in unity there should be no "tray icons" just indicators. Second thing why use tray icon if amarok is already in sound indicator? So I've changed settings not to use tray icon. And now Amarok is terminating on close :( Could it be fixed somehow?

piotrekkr (piotrekkr) wrote :

I'll write to amarok team about this:) Thanks for helping with indicator.

Myriam Schweingruber (myriam) wrote :

@piotrekkr: no need to write to the Amarok team, I am following this bug :) The tray Icon when closing the window is the correct behavior for Amarok, to quit a KDE application you need to use Ctrl+Q. Nothing wrong on our side. Now what Unity makes is beyond our reach and it is not up to Amarok to change it's behavior IMHO.

piotrekkr (piotrekkr) wrote :

@Myriam Schweingruber (myriam)

I think quick hack could be like this:

In unity after unchecking "show tray icon" just not show icon in tray but in background amarok would be still working like minimised to tray and to restore amarok window just select amarok from sound indicator.

Maby it's stupid what I'm writing :) I'm not a linux programmer so I don't know if it is possible to run amarok in background without tray icon. Can you tell me if it's possible , and if it is possible , how much work would it be to change behaviour for unity?

Myriam Schweingruber (myriam) wrote :

Well, as I said, I don't know about Unity, but it is for sure not an Amarok bug. The SystemTray icon is necessary in KDE to be able to restore Amarok's GUI or access player features, now what the Unity requirements are I don't know. Since Amarok is a KDE application it works perfectly fine with KDE and I don't think it is up to Amarok to modify its behavior. You should address your questions to the Unity developers.

piotrekkr (piotrekkr) wrote :

Ok I'll write to unity team but I don't think they have any power to change Amarok behaviour. Is there any easy way to notify unity developers about this bug report so they could write their opinion below?

No. They have absolutely no ability to change Amarok. That's the point.
Amarok isn't going to be customized for Unity at the expense of it's primary
user base. How Unity needs to deal with that is up to them.

Scott Kitterman (kitterman) wrote :

In answer to the second part of your question, I've added canonical-design to the bug as they're the ones that will have to design a solution to the problem.

piotrekkr (piotrekkr) wrote :

Ok, so it all depends on unity team, maby they will do something about that. Thanks for help.

Conor Curran (cjcurran) wrote :

I see now what the problem is, it is the behaviour of amarok once the tray icon is disabled.
When it is disabled and removed the close button on the left will close the app. For unity music players we requested that players follow the behaviour outlined in the spec (wiki.ubuntu.com/SoundMenu).
https://wiki.ubuntu.com/SoundMenu#compliance

Amarok should just minimize on close button press and restore when activated again from the sound menu, like banshee or rhythmbox does. Banshee preserves how it operated before and handles how Ubuntu would it like it to operate by implementing a plugin for specific ubuntu UI behaviour.

Changed in canonical-design:
status: New → Invalid
Scott Kitterman (kitterman) wrote :

Which completely ignores that the entire world is not Ubuntu with sound menus.

Sebastien Bacher (seb128) wrote :

@Myriam: that's somewhat an amarok bug or at least a wishlist to better support which are not using a notification area. You are right that Amarok behaves fine on KDE, it doesn't mean it couldn't be "smarter" about non KDE environments and do the right things for those (other softwares do that and adapt to the features available in the environment they are used). You, as an upstream, are welcome to wontfix better unity support in amarok though and to recommend GNOME,Unity users to use a GTK based player if you consider a KDE player is meant to be used under KDE

Sebastien Bacher (seb128) wrote :

to better support *environments* which...

Scott Kitterman (kitterman) wrote :

@ seb128: Generally when I've worked with KDE based upstreams on these kinds
of issues they've been very open to resolving them when Canonical provided
patches.

piotrekkr (piotrekkr) wrote :

Added to *wishlist*

Conor Curran (cjcurran) wrote :

Scott,

All Amarok has to do is to check if the indicator sound menu's dbus interface is up.

'com.canonical.indicator.sound'

If it is then Amarok should be easily able to accommodate the wishes of Ubuntu.

Scott Kitterman (kitterman) wrote :

If it's easy, send a patch to bugs.kde.org. If it's got no downside in other
use cases, I'll advocate they accept it. I suspect that Canonical/Ubuntu's
wishes aren't much of a priority for them, so sending a patch is probably the
only way this gets done.

Sebastien Bacher (seb128) wrote :

the indicator issue has been resolved (i.e it works when amarok doesn't use the systray) so setting the indicator-sound SRU as verification-done, bug #994469 tracks the other issue discussed there

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-sound - 0.8.5.0-0ubuntu2.1

---------------
indicator-sound (0.8.5.0-0ubuntu2.1) precise-proposed; urgency=low

  * debian/patches/lp_992262.patch
    - fix sound indicator not working after amarok close (LP: #992262)
  * debian/patches/lp_902715.patch
    - Partial fix which sets the accessibility property on the volume
      slider menu item. Previously this was achieved by sending a signal
      on the indicator object but now it seems the way to update orca is
      to set/update the appropriate property on the menuitem. Orca doesn't
      broadcast volume updates on slider movement but at least it updates
      when the user moves to the item on the menu, previously it was entirely
      silent. (LP: #902715)
 -- Ken VanDine <email address hidden> Thu, 03 May 2012 16:16:41 -0700

Changed in indicator-sound (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers