indicator-sound-service crashed with SIGABRT in __libc_message()

Bug #957387 reported by Gros Ouaso on 2012-03-16
426
This bug affects 60 people
Affects Status Importance Assigned to Milestone
indicator-sound (Ubuntu)
Medium
Unassigned

Bug Description

the error happened without shutting the application

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: indicator-sound 0.8.4.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-18.29-generic-pae 3.2.9
Uname: Linux 3.2.0-18-generic-pae i686
ApportVersion: 1.94.1-0ubuntu2
Architecture: i386
Date: Fri Mar 16 16:11:39 2012
ExecutablePath: /usr/lib/indicator-sound/indicator-sound-service
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha i386 (20120315)
ProcCmdline: /usr/lib/indicator-sound/indicator-sound-service
ProcEnviron:
 SHELL=/bin/bash
 LANGUAGE=fr_CA:fr
 LANG=fr_CA.UTF-8
Signal: 6
SourcePackage: indicator-sound
StacktraceTop:
 raise () from /lib/i386-linux-gnu/libc.so.6
 abort () from /lib/i386-linux-gnu/libc.so.6
 ?? () from /lib/i386-linux-gnu/libc.so.6
 ?? () from /lib/i386-linux-gnu/libc.so.6
 ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
Title: indicator-sound-service crashed with SIGABRT in raise()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Gros Ouaso (gaetan-bolduc) wrote :

StacktraceTop:
 __libc_message (do_abort=2, fmt=0xb71aaf3c "*** glibc detected *** %s: %s: 0x%s ***\n") at ../sysdeps/unix/sysv/linux/libc_fatal.c:201
 malloc_printerr (action=<optimized out>, str=<optimized out>, ptr=0x8066a08) at malloc.c:5007
 standard_free (mem=0x8066a08) at /build/buildd/glib2.0-2.31.20/./glib/gmem.c:98
 g_free (mem=0x8066a08) at /build/buildd/glib2.0-2.31.20/./glib/gmem.c:252
 show_sound_settings_dialog (mi=0x92ab400, user_data=0xa247c) at /build/buildd/indicator-sound-0.8.4.0/./src/sound-service-dbus.c:243

affects: ubuntu → indicator-sound (Ubuntu)
Changed in indicator-sound (Ubuntu):
importance: Undecided → Medium
summary: - indicator-sound-service crashed with SIGABRT in raise()
+ indicator-sound-service crashed with SIGABRT in __libc_message()
tags: removed: need-i386-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-sound (Ubuntu):
status: New → Confirmed
tags: added: bugpattern-needed
visibility: private → public
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-sound - 0.8.4.1-0ubuntu1

---------------
indicator-sound (0.8.4.1-0ubuntu1) precise; urgency=low

  * New upstream release.
    - fix i18n of indicator-sound's accessible description (LP: #957517)
    - don't abort isound via g_error() if it can't connect to the
      bus (LP: #953111)
  * debian/patches/sound_nua.patch
    - don't try to free a static string (LP: #957387)
 -- Ken VanDine <email address hidden> Mon, 19 Mar 2012 11:22:00 -0400

Changed in indicator-sound (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.