indicator-sound-service crashed with SIGABRT in raise()

Bug #953111 reported by GuyR on 2012-03-12
88
This bug affects 19 people
Affects Status Importance Assigned to Milestone
The Sound Menu
Invalid
Low
Unassigned
indicator-sound (Ubuntu)
Low
Unassigned

Bug Description

Ubuntu 12.04 beta1

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: indicator-sound 0.8.3.0-0ubuntu1
Uname: Linux 3.2.9-030209-generic i686
ApportVersion: 1.94.1-0ubuntu2
Architecture: i386
CheckboxSubmission: 592d2a6e0d18bcb44c8ff4a0517b9d98
CheckboxSystem: 4029317434a5f787a60302f0f64e8786
Date: Mon Mar 12 16:22:41 2012
ExecutablePath: /usr/lib/indicator-sound/indicator-sound-service
ProcCmdline: /usr/lib/indicator-sound/indicator-sound-service
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANGUAGE=fr_FR:fr:en
 LANG=fr_FR.UTF-8
Signal: 6
SourcePackage: indicator-sound
StacktraceTop:
 raise () from /lib/i386-linux-gnu/libc.so.6
 abort () from /lib/i386-linux-gnu/libc.so.6
 g_assertion_message () from /lib/i386-linux-gnu/libglib-2.0.so.0
 g_assertion_message_expr () from /lib/i386-linux-gnu/libglib-2.0.so.0
 ?? () from /usr/lib/i386-linux-gnu/gio/modules/libgvfsdbus.so
Title: indicator-sound-service crashed with SIGABRT in raise()
UpgradeStatus: Upgraded to precise on 2012-03-09 (3 days ago)
UserGroups: adm admin audio cdrom dialout dip fax floppy fuse lp lpadmin mythtv netdev plugdev root scanner tape video

Related branches

GuyR (guy-rouger) wrote :
visibility: private → public

StacktraceTop:
 g_assertion_message (domain=0xb046e52d <Address 0xb046e52d out of bounds>, file=0xb046f46f <Address 0xb046f46f out of bounds>, line=328, func=0xb046f5a0 <Address 0xb046f5a0 out of bounds>, message=<optimized out>) at /build/buildd/glib2.0-2.31.20/./glib/gtestutils.c:1860
 g_assertion_message_expr (domain=0xb046e52d <Address 0xb046e52d out of bounds>, file=0xb046f46f <Address 0xb046f46f out of bounds>, line=328, func=0xb046f5a0 <Address 0xb046f5a0 out of bounds>, expr=0xb046f480 <Address 0xb046f480 out of bounds>) at /build/buildd/glib2.0-2.31.20/./glib/gtestutils.c:1871
 ?? ()
 ?? ()
 ?? ()

tags: added: apport-failed-retrace
tags: removed: need-i386-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-sound (Ubuntu):
status: New → Confirmed
Conor Curran (cjcurran) on 2012-03-13
Changed in indicator-sound:
status: New → Confirmed
importance: Undecided → Medium
assignee: nobody → Conor Curran (cjcurran)
Conor Curran (cjcurran) on 2012-03-15
Changed in indicator-sound:
milestone: none → 0.8.4.0
status: Confirmed → Triaged
Changed in indicator-sound (Ubuntu):
status: Confirmed → In Progress
Charles Kerr (charlesk) wrote :

Duplicate bug #830715 has a slightly less corrupt log message:

StacktraceTop:
 g_assertion_message (domain=<optimized out>, file=<optimized out>, line=<optimized out>, func=0x7fddc43a0be0 <Address 0x7fddc43a0be0 out of bounds>, message=0x7fddc003aa20 "assertion failed: (fd_id == data->extra_fd_count)") at /build/buildd/glib2.0-2.31.6/./glib/gtestutils.c:1810

Conor Curran (cjcurran) on 2012-03-16
Changed in indicator-sound:
status: Triaged → In Progress
Conor Curran (cjcurran) wrote :

Not so sure where this is coming from. I did notice that I was using g_errors instead of g_criticals. Attached branch rectifies this.

Changed in indicator-sound:
status: In Progress → Fix Committed
Conor Curran (cjcurran) wrote :

This seems to be some problem in the depths of GLib dbus. For now I will leave this bug as confirmed just to collate the bugs.
ISound however should now not abort if it does come up against some problematic DBus behavior.

Changed in indicator-sound:
status: Fix Committed → Confirmed
Changed in indicator-sound (Ubuntu):
status: In Progress → Confirmed
Changed in indicator-sound:
milestone: 0.8.4.0 → none
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-sound - 0.8.4.1-0ubuntu1

---------------
indicator-sound (0.8.4.1-0ubuntu1) precise; urgency=low

  * New upstream release.
    - fix i18n of indicator-sound's accessible description (LP: #957517)
    - don't abort isound via g_error() if it can't connect to the
      bus (LP: #953111)
  * debian/patches/sound_nua.patch
    - don't try to free a static string (LP: #957387)
 -- Ken VanDine <email address hidden> Mon, 19 Mar 2012 11:22:00 -0400

Changed in indicator-sound (Ubuntu):
status: Confirmed → Fix Released
Conor Curran (cjcurran) wrote :

No reports since I tidied up the g_error fix. Marking incomplete with a view to it expiring unless others in the meantime report similar issues.

Changed in indicator-sound:
status: Confirmed → Incomplete
Charles Kerr (charlesk) wrote :

Launchpad Janitor isn't confused, this isn't fixed yet. :)

Changed in indicator-sound (Ubuntu):
status: Fix Released → Incomplete
Conor Curran (cjcurran) on 2012-05-05
Changed in indicator-sound:
status: Incomplete → Confirmed
Changed in indicator-sound (Ubuntu):
status: Incomplete → Confirmed
Sebastien Bacher (seb128) wrote :

closing the bug since there was no reply to the question nor new activity or duplicate

Changed in indicator-sound (Ubuntu):
importance: Undecided → Low
status: Confirmed → Invalid
Changed in indicator-sound:
assignee: Conor Curran (cjcurran) → nobody
importance: Medium → Low
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers