Ubuntu

indicator-sound-service crashed with SIGSEGV in g_strdup()

Reported by Barry Drake on 2012-03-04
60
This bug affects 10 people
Affects Status Importance Assigned to Milestone
The Sound Menu
Medium
Conor Curran
indicator-sound (Ubuntu)
Medium
Unassigned

Bug Description

Occurred after installing and opening Banshee.

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: indicator-sound 0.8.3.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-17.27-generic-pae 3.2.6
Uname: Linux 3.2.0-17-generic-pae i686
NonfreeKernelModules: fglrx
ApportVersion: 1.94-0ubuntu1
Architecture: i386
Date: Sun Mar 4 20:10:45 2012
ExecutablePath: /usr/lib/indicator-sound/indicator-sound-service
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha i386 (20111220)
ProcCmdline: /usr/lib/indicator-sound/indicator-sound-service
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANGUAGE=en_GB:en
 LANG=en_GB.UTF-8
SegvAnalysis:
 Segfault happened at: 0xb719c2b6: movdqu (%edi),%xmm1
 PC (0xb719c2b6) ok
 source "(%edi)" (0x0424548b) not located in a known VMA region (needed readable region)!
 destination "%xmm1" ok
SegvReason: reading unknown VMA
Signal: 11
SourcePackage: indicator-sound
StacktraceTop:
 ?? () from /lib/i386-linux-gnu/libc.so.6
 g_strdup () from /lib/i386-linux-gnu/libglib-2.0.so.0
 ?? ()
 ?? ()
 ?? ()
Title: indicator-sound-service crashed with SIGSEGV in g_strdup()
UpgradeStatus: Upgraded to precise on 2012-02-17 (16 days ago)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Barry Drake (b-drake) wrote :

StacktraceTop:
 g_strdup (str=0x424548b <Address 0x424548b out of bounds>) at /build/buildd/glib2.0-2.31.18/./glib/gstrfuncs.c:355
 playlists_menuitem_active_playlist_update (self=0x8fa3780, detail=0xbf99a474) at playlists-menu-item.c:630
 mpris2_controller_fetch_active_playlist (self=0x8f9c4f0) at mpris2-controller.c:1270
 mpris2_controller_fetch_active_playlist (self=0x8f9c4f0) at mpris2-controller.c:1228
 mpris2_controller_property_changed_cb (self=0x8f9c4f0, interface_source=0x8fd7f30 "org.mpris.MediaPlayer2.Playlists", changed_properties=0x8fc38b8, invalid=0x8fd7cb8, invalid_length1=0) at mpris2-controller.c:604

Changed in indicator-sound (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-sound (Ubuntu):
status: New → Confirmed
visibility: private → public
Conor Curran (cjcurran) on 2012-03-12
Changed in indicator-sound:
assignee: nobody → Conor Curran (cjcurran)
status: New → In Progress
importance: Undecided → Medium
Conor Curran (cjcurran) on 2012-03-13
Changed in indicator-sound:
status: In Progress → Fix Committed
milestone: none → 0.8.4.0
Conor Curran (cjcurran) on 2012-03-16
Changed in indicator-sound:
status: Fix Committed → Fix Released
Conor Curran (cjcurran) on 2012-03-16
Changed in indicator-sound (Ubuntu):
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-sound - 0.8.4.0-0ubuntu1

---------------
indicator-sound (0.8.4.0-0ubuntu1) precise; urgency=low

  * New upstream release.
    - indicator-sound "Choose Playlist" menu item does nothing when using
      Rhythmbox (LP: #952550)
    - crashed with SIGSEGV in g_strdup() (LP: #946607)
    - crashed with SIGABRT in pa_operation_unref() (LP: #944148)
    - crashed with signal 5 in g_type_create_instance() (LP: #921755)
    - slider on unmute resets volume (LP: #921065)
    - play controls not exposed in HUD (LP: #949032)
    - unity-panel-service at 100% cpu when opened /w rb without album
      cover (LP: #806848)
 -- Ken VanDine <email address hidden> Fri, 16 Mar 2012 14:04:30 -0400

Changed in indicator-sound (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers