indicator-sound-service crashed with SIGSEGV in __GI___libc_free()

Bug #945827 reported by markba on 2012-03-03
42
This bug affects 5 people
Affects Status Importance Assigned to Milestone
The Sound Menu
Fix Released
Medium
Conor Curran
indicator-sound (Ubuntu)
Medium
Unassigned

Bug Description

Auto generated

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: indicator-sound 0.8.3.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-17.27-generic-pae 3.2.6
Uname: Linux 3.2.0-17-generic-pae i686
ApportVersion: 1.94-0ubuntu1
Architecture: i386
CrashCounter: 1
Date: Sat Mar 3 21:06:13 2012
ExecutablePath: /usr/lib/indicator-sound/indicator-sound-service
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha i386 (20120302)
ProcCmdline: /usr/lib/indicator-sound/indicator-sound-service
ProcEnviron:
 SHELL=/bin/bash
 LANG=nl_NL.UTF-8
SegvAnalysis:
 Segfault happened at: 0xb7178e76 <free+38>: mov -0x4(%ecx),%ecx
 PC (0xb7178e76) ok
 source "-0x4(%ecx)" (0x000f6e74) not located in a known VMA region (needed readable region)!
 destination "%ecx" ok
SegvReason: reading unknown VMA
Signal: 11
SourcePackage: indicator-sound
StacktraceTop:
 free () from /lib/i386-linux-gnu/libc.so.6
 ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
 g_free () from /lib/i386-linux-gnu/libglib-2.0.so.0
 ?? ()
 ?? ()
Title: indicator-sound-service crashed with SIGSEGV in free()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Related branches

markba (mark-baaijens) wrote :

StacktraceTop:
 __GI___libc_free (mem=0xf6e78) at malloc.c:2968
 standard_free (mem=0xf6e78) at /build/buildd/glib2.0-2.31.18/./glib/gmem.c:98
 g_free (mem=0xf6e78) at /build/buildd/glib2.0-2.31.18/./glib/gmem.c:252
 playlist_details_destroy (self=0xb7504ff4) at mpris2-interfaces.c:1759
 playlist_details_free (self=0xb7504ff4) at mpris2-interfaces.c:1774

Changed in indicator-sound (Ubuntu):
importance: Undecided → Medium
summary: - indicator-sound-service crashed with SIGSEGV in free()
+ indicator-sound-service crashed with SIGSEGV in __GI___libc_free()
tags: removed: need-i386-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-sound (Ubuntu):
status: New → Confirmed
visibility: private → public
Conor Curran (cjcurran) on 2012-03-19
Changed in indicator-sound (Ubuntu):
status: Confirmed → In Progress
Changed in indicator-sound:
status: New → Confirmed
assignee: nobody → Conor Curran (cjcurran)
importance: Undecided → Medium
Conor Curran (cjcurran) wrote :

This must be an MPRIS implementation error by some active player. The playlists are on and the 'ActivePlaylist' valid property is True but the playlistdetail strings are NULL. Branch attached has a more defensive approach to dealing with that interface.

Conor Curran (cjcurran) on 2012-03-19
Changed in indicator-sound:
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-sound - 0.8.4.1-0ubuntu2

---------------
indicator-sound (0.8.4.1-0ubuntu2) precise; urgency=low

  * debian/patches/lp_945827.patch
    - fix for a playlist crasher (LP: #945827)
 -- Ken VanDine <email address hidden> Tue, 20 Mar 2012 16:40:24 -0400

Changed in indicator-sound (Ubuntu):
status: In Progress → Fix Released
Conor Curran (cjcurran) on 2012-03-21
Changed in indicator-sound:
status: In Progress → Fix Released
milestone: none → 0.8.4
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers