Sound Settings link doesn't work in GNOME Classic

Bug #941704 reported by Jeremy Bicha on 2012-02-27
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
The Sound Menu
Won't Fix
Medium
Conor Curran
indicator-sound (Ubuntu)
Medium
Ken VanDine

Bug Description

In GNOME Classic, clicking Sound Settings just opens System Settings instead of opening the Sound panel of System Settings.

This is because gnome-control-center has been patched to use the "sound-nua" redesigned panel on Unity but not for GNOME. Also, the Ubuntu packaging for indicator-sound, in the sound_nua.patch has patched the Sound Settings link to point to sound-nua.

indicator-sound should sniff for the currently running desktop session. If it's Unity, show sound-nua; but if it's GNOME, show sound.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: indicator-sound 0.8.2.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-17.27-generic 3.2.6
Uname: Linux 3.2.0-17-generic x86_64
ApportVersion: 1.93-0ubuntu2
Architecture: amd64
CheckboxSubmission: 201084ed41ea7548f8becd47fa4d1e6c
CheckboxSystem: c541d13ea4f205f2fd751f76ed21105b
Date: Sun Feb 26 20:01:17 2012
SourcePackage: indicator-sound
UpgradeStatus: No upgrade log present (probably fresh install)

Jeremy Bicha (jbicha) wrote :
Conor Curran (cjcurran) on 2012-03-13
Changed in indicator-sound:
status: New → Triaged
importance: Undecided → Medium
Changed in indicator-sound (Ubuntu):
status: New → Confirmed
Changed in indicator-sound:
assignee: nobody → Conor Curran (cjcurran)
milestone: none → 0.8.4.0
Sebastien Bacher (seb128) wrote :

basically the way it's done at other places is

if (!g_strcmp0 (g_getenv ("XDG_CURRENT_DESKTOP"), "Unity"))
 unity_value
else
  upstream_value

Conor Curran (cjcurran) wrote :

We'll carry this as a distro patch until this work gets upstreamed into Gnome.

Changed in indicator-sound:
status: Triaged → Won't Fix
milestone: 0.8.4.0 → none
Changed in indicator-sound (Ubuntu):
status: Confirmed → Fix Committed
Changed in indicator-sound (Ubuntu):
status: Fix Committed → In Progress
importance: Undecided → Medium
assignee: nobody → Sebastien Bacher (seb128)
Changed in indicator-sound (Ubuntu):
assignee: Sebastien Bacher (seb128) → Ken VanDine (ken-vandine)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-sound - 0.8.3.0-0ubuntu2

---------------
indicator-sound (0.8.3.0-0ubuntu2) precise; urgency=low

  * debian/patches/sound_nua.patch
    - Sound Settings link doesn't work in GNOME Classic (LP: #941704)
 -- Ken VanDine <email address hidden> Fri, 16 Mar 2012 13:39:03 -0400

Changed in indicator-sound (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers