Synchronise mute and volume between lightdm and respective user sessions

Bug #915253 reported by Conor Curran on 2012-01-12
26
This bug affects 4 people
Affects Status Importance Assigned to Milestone
The Sound Menu
Fix Released
Medium
Unassigned
indicator-sound (Ubuntu)
Undecided
Unassigned

Bug Description

Currently when at the login screen if the user mutes the volume and then logs in the mute state is not 'carried over' into that users session.

why not sychronise audio state between login screen and user session.

Conor Curran (cjcurran) on 2012-01-12
Changed in unity-greeter:
assignee: nobody → Conor Curran (cjcurran)
status: New → Confirmed
Conor Curran (cjcurran) wrote :

I'm kinda thinking that it would be easier to do this in the indicator-sound. Only because I can tell when I'm in the greeter and also have communication with the pulse daemon setup. Therefore I will be able to write to the accounts service quite easily from the service on volume state change.

Changed in pulseaudio:
assignee: nobody → David Henningsson (diwic)
Conor Curran (cjcurran) on 2012-01-12
Changed in indicator-sound:
status: New → Triaged
assignee: nobody → Conor Curran (cjcurran)
importance: Undecided → Medium
Robert Ancell (robert-ancell) wrote :

Just remember that you will have to get the greeter to tell the indicator which user is selected so you know which user in AccountsService to modify.

Changed in unity-greeter:
status: Confirmed → Triaged
importance: Undecided → Medium
Conor Curran (cjcurran) wrote :

yep thanks Robert, Will start patching in the next few days.

Conor Curran (cjcurran) wrote :

On my backlog...

Norbert (nrbrtx) wrote :

Confirmed on Ubuntu 12.04 with unity-greeter 0.2.8-0ubuntu1.
It's LTS, guys! Do not be a Windows Vista!!

Changed in pulseaudio:
importance: Undecided → Wishlist
Changed in unity-greeter:
assignee: Conor Curran (cjcurran) → nobody
Changed in indicator-sound:
assignee: Conor Curran (cjcurran) → nobody
David Henningsson (diwic) wrote :

I'm unassigning me from this bug, because I don't see this happening in the near future.

Changed in pulseaudio:
assignee: David Henningsson (diwic) → nobody
affects: unity-greeter → unity-greeter (Ubuntu)
Michael Terry (mterry) wrote :

This should be doable just within indicator-sound these days. The greeter shares which user is selected over DBus. And indicator-sound can register a custom field with AccountsService by itself.

See https://code.launchpad.net/~mterry/telephony-service/greeter-contacts/+merge/199910 for an example of adding a new field and listening for greeter user changes (though granted, that's qt code instead of glib.

This has become more important with the phablet images, since once we split the greeter, the user will definitely have the expectation that volume changes in greeter will carry over.

no longer affects: pulseaudio
no longer affects: unity-greeter (Ubuntu)
Michael Terry (mterry) wrote :

Indicator-sound itself supports this now. It just needs accountsservice-ubuntu-schemas to be installed. Which it is on touch. And could be on desktop if we wanted to modify the ubuntu-desktop metapackage.

Changed in indicator-sound (Ubuntu):
status: New → Fix Released
Changed in indicator-sound:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers