indicator-sound-service crashed with SIGABRT in pa_operation_unref()

Bug #908682 reported by Adolfo Jayme on 2011-12-26
46
This bug affects 5 people
Affects Status Importance Assigned to Milestone
The Sound Menu
Fix Released
High
Conor Curran
indicator-sound (Ubuntu)
Medium
Unassigned

Bug Description

Maybe a dupe of bug 737847. Apport said:

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: indicator-sound 0.8.0.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-6.12-generic 3.2.0-rc6
Uname: Linux 3.2.0-6-generic i686
NonfreeKernelModules: wl
ApportVersion: 1.90-0ubuntu1
Architecture: i386
Date: Mon Dec 26 00:09:59 2011
ExecutablePath: /usr/lib/indicator-sound/indicator-sound-service
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
ProcCmdline: /usr/lib/indicator-sound/indicator-sound-service
Signal: 6
SourcePackage: indicator-sound
StacktraceTop:
 __kernel_vsyscall ()
 raise () from /lib/i386-linux-gnu/libc.so.6
 abort () from /lib/i386-linux-gnu/libc.so.6
 pa_operation_unref () from /usr/lib/i386-linux-gnu/libpulse.so.0
 ?? ()
Title: indicator-sound-service crashed with SIGABRT in __kernel_vsyscall()
UpgradeStatus: Upgraded to precise on 2011-11-16 (39 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Related branches

Adolfo Jayme (fitojb) wrote :

StacktraceTop:
 pa_operation_unref (o=0x0) at pulse/operation.c:67
 handle_event (mi=0x8734008, name=0x8735720 "change-value", value=0xb6202898, timestamp=0) at /build/buildd/indicator-sound-0.8.0.0/./src/slider-menu-item.c:117
 dbusmenu_menuitem_handle_event (mi=0x8734008, name=0x8735720 "change-value", variant=0xb6202898, timestamp=0) at /build/buildd/libdbusmenu-0.5.1/./libdbusmenu-glib/menuitem.c:1707
 event_local_handler (user_data=0x8735748) at /build/buildd/libdbusmenu-0.5.1/./libdbusmenu-glib/server.c:1530
 g_timeout_dispatch (source=0x8760e18, callback=0xd395e0 <event_local_handler>, user_data=0x8735748) at /build/buildd/glib2.0-2.31.4.tested/./glib/gmain.c:3857

Changed in indicator-sound (Ubuntu):
importance: Undecided → Medium
summary: - indicator-sound-service crashed with SIGABRT in __kernel_vsyscall()
+ indicator-sound-service crashed with SIGABRT in pa_operation_unref()
tags: removed: need-i386-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-sound (Ubuntu):
status: New → Confirmed
Adolfo Jayme (fitojb) on 2012-01-13
visibility: private → public
Conor Curran (cjcurran) wrote :

How reproducible is this guys ?

It's like the pulse context pointer disappears in the middle of a volume change event from the indicator.

Does it happen every time ?

Changed in indicator-sound:
assignee: nobody → Conor Curran (cjcurran)
status: New → Triaged
importance: Undecided → High
milestone: none → 0.8.3.0
Conor Curran (cjcurran) on 2012-03-01
Changed in indicator-sound:
status: Triaged → In Progress
Conor Curran (cjcurran) on 2012-03-01
Changed in indicator-sound:
status: In Progress → Fix Committed
Conor Curran (cjcurran) on 2012-03-01
Changed in indicator-sound (Ubuntu):
status: Confirmed → In Progress
Changed in indicator-sound:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-sound - 0.8.3.0-0ubuntu1

---------------
indicator-sound (0.8.3.0-0ubuntu1) precise; urgency=low

  * New upstream release.
    - Fixed memory corruption issue (LP: #897218)
    - crashed with SIGABRT in pa_operation_unref (LP: #908682)
    - Banshee shown in sound menu after removal until reboot (LP: #771202)
    - Coverity PASS_BY_VALUE - CID 10620 (LP: #937451)
    - App icon and name are not aligned (LP: #939929)
 -- Ken VanDine <email address hidden> Fri, 02 Mar 2012 11:26:41 -0500

Changed in indicator-sound (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers