Playback controls don't highlight anything like other menu items

Bug #906050 reported by Matthew Paul Thomas
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
indicator-sound (Ubuntu)
Medium
Charles Kerr

Bug Description

indicator-sound 0.7.9-0ubuntu2.1, Ubuntu 11.10

The way the playback items (Previous, Play/Pause, Next) highlight when focused is very different from the way other menu items are highlighted when focused.

Specifically, the button icons currently get a blurred ring around them in the highlight color.

Instead, the whole button should be filled with the highlight color, like it would if it was a menu item; and the icon should turn white, or whatever color is used for highlighted menu item text.

[Originally reported as part of <https://blueprints.launchpad.net/ubuntu/+spec/ps-p-indicator-refinements>.]

Related branches

description: updated
Revision history for this message
Bilal Akhtar (bilalakhtar) wrote :

Incomplete for now, please change status when a mockup is available.

Changed in indicator-sound:
status: New → Incomplete
Changed in indicator-sound:
status: Incomplete → New
Changed in indicator-sound:
assignee: Matthew Paul Thomas (mpt) → Alberto Ruiz (alberto.ruiz)
description: updated
description: updated
Changed in indicator-sound:
status: New → Triaged
Olli Ries (ories)
Changed in indicator-sound:
assignee: Alberto Ruiz (alberto.ruiz) → nobody
importance: Undecided → Low
importance: Low → Medium
Charles Kerr (charlesk)
Changed in indicator-sound:
status: Triaged → In Progress
assignee: nobody → charles (charlesk)
Charles Kerr (charlesk)
Changed in indicator-sound:
status: In Progress → Fix Committed
Revision history for this message
Conor Curran (cjcurran) wrote :

It is very similar to lp:524541 but I can't see how that branch fixes this bug on the playback controls.

Changed in indicator-sound:
status: Fix Committed → Triaged
Revision history for this message
Charles Kerr (charlesk) wrote :

Conor: yes, you're right. Thanks for the correction

Revision history for this message
Lars Karlitski (larsu) wrote :

I implemented Matthew's design on how the playback menu item should be highlighted recently (see bug #733285).

Changed in indicator-sound:
status: Triaged → Fix Released
Revision history for this message
Matthew Paul Thomas (mpt) wrote :

Bug 733285 was about *when* the items are highlighted, and thank you for fixing it. This bug is about *how* they are highlighted, i.e. what they look like.

Changed in indicator-sound:
status: Fix Released → Triaged
description: updated
Ted Gould (ted)
Changed in indicator-sound (Ubuntu):
assignee: nobody → Charles Kerr (charlesk)
importance: Undecided → Medium
status: New → Triaged
Revision history for this message
Xavi Garcia (xavi-garcia-mena) wrote :

As the MPRIS controls seem to be OK in the sound indicator and Mathew's comment points to a cosmetic issue I'm assigning this to unity and moving it as Invalid for the indicator-sound.

Please feel free to re-open for indicator-sound if you think this is still a valid bug for indicator-sound.

Changed in indicator-sound (Ubuntu):
status: Triaged → Invalid
Changed in unity (Ubuntu):
assignee: nobody → Michał Sawicz (saviq)
Revision history for this message
Michał Sawicz (saviq) wrote :

This is about unity, not unity8, I've nothing to do with the former :)

Changed in unity (Ubuntu):
assignee: Michał Sawicz (saviq) → nobody
Adolfo Jayme (fitojb)
no longer affects: unity (Ubuntu)
Changed in indicator-sound (Ubuntu):
status: Invalid → Triaged
Revision history for this message
Xavi Garcia (xavi-garcia-mena) wrote :

Confirmed it's not an indicator issue, the issue is very old and the icons seem to be fixed now.

no longer affects: indicator-sound
Changed in indicator-sound (Ubuntu):
status: Triaged → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers